Subject: [trill] TRILL and IEEE 1588 PTP

From: Nandakumar Natarajan <[email-masked]>
Date: Fri, 23 Jan 2015 00:49:35 +0000 (UTC)

Hi,
Is there any existing documentation on supporting IEEE 1588 PTP protocol in a TRILL network? Thanks for any pointers.
Thanks,Nanda

---

From: Tal Mizrahi <[email-masked]>
Date: Sat, 24 Jan 2015 14:09:54 +0000

Hi Nanda,

The IEEE 1588 standard does not include a mapping for TRILL, nor is there currently a plan to add a TRILL mapping in the next revision of IEEE 1588.
Personally, I am not aware of any work in the IETF on 1588 over TRILL. On a (somewhat) related note, there was  some discussion about 1588 over MPLS (see draft-ietf-tictoc-1588overmpls, draft-mirsky-mpls-residence-time).

Cheers,
Tal.

From: trill [mailto:[email-masked]] On Behalf Of Nandakumar Natarajan
Sent: Friday, January 23, 2015 2:50 AM
To: [email-masked]
Subject: [trill] TRILL and IEEE 1588 PTP

Hi,

Thanks,
Nanda

---

From: Donald Eastlake <[email-masked]>
Date: Sat, 24 Jan 2015 11:30:42 -0500

If there is interest in IEEE 1588 over TRILL, I would think it would
be quite straight forward. Just assign an RBridge Channel protocol
number to it as was done for BFD.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Sat, Jan 24, 2015 at 9:09 AM, Tal Mizrahi <[email-masked]> wrote:
> Hi Nanda,
>
>
>
> The IEEE 1588 standard does not include a mapping for TRILL, nor is there
> currently a plan to add a TRILL mapping in the next revision of IEEE 1588.
>
> Personally, I am not aware of any work in the IETF on 1588 over TRILL. On a
> (somewhat) related note, there was  some discussion about 1588 over MPLS
> (see draft-ietf-tictoc-1588overmpls, draft-mirsky-mpls-residence-time).
>
>
>
> Cheers,
>
> Tal.
>
>
>
> Is there any existing documentation on supporting IEEE 1588 PTP protocol in
> a TRILL network? Thanks for any pointers.
>
>
>
> Thanks,
>
> Nanda
>
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Jon Hudson <[email-masked]>
Date: Sat, 24 Jan 2015 13:56:48 -0800

Speaking personally I would LOVE to see this.

Recent NTPd issues in the Wild have shown that 1588 might be a great tool to have.

Cheers 
Jon

> On Jan 24, 2015, at 8:30 AM, Donald Eastlake <[email-masked]> wrote:
>

---

From: Mingui Zhang <[email-masked]>
Date: Mon, 26 Jan 2015 02:24:19 +0000

Yes, I think we can make use of the PType = 5 RBridge Channel Tunnel Protocol (See draft-ietf-trill-channel-tunnel-02). It can tunnel Ethernet frames. 

Thanks,
Mingui

>-----Original Message-----
>From: trill [mailto:[email-masked]] On Behalf Of Donald Eastlake
>Sent: Sunday, January 25, 2015 12:31 AM
>To: Tal Mizrahi
>Cc: Nandakumar Natarajan; [email-masked]
>Subject: Re: [trill] TRILL and IEEE 1588 PTP
>

---

From: Haoweiguo <[email-masked]>
Date: Mon, 26 Jan 2015 05:47:04 +0000

Yes, 1588 has more clocks syncrionization accuracy than NTP. I also think 1588 over TRILL seems to be very similar to BFD, because PTP message is a multicast message, it can be conveyed using multicast RBridge channel.
Thanks,
weiguo
________________________________________
From: Jon Hudson [[email-masked]]
Sent: Sunday, January 25, 2015 5:56
To: Donald Eastlake
Cc: Nandakumar Natarajan; Tal Mizrahi; [email-masked]
Subject: Re: [trill] TRILL and IEEE 1588 PTP

Cheers
Jon

---

From: Tal Mizrahi <[email-masked]>
Date: Mon, 26 Jan 2015 06:41:30 +0000

Right, 1588 uses both multicast and unicast messages.
There are a couple of other issues to consider, to guarantee that time is distributed accurately:
- 1588 messages between every {master,slave} pair should be forwarded symmetrically, i.e., the forward direction and the reverse direction should use the same physical path.
- ECMP should not be used on 1588 messages.

I believe quite a few of the principles of draft-ietf-tictoc-1588overmpls are applicable to TRILL as well.

Cheers,
Tal.

-----Original Message-----
From: trill [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Monday, January 26, 2015 7:47 AM
To: Jon Hudson; Donald Eastlake
Cc: Tal Mizrahi; Nandakumar Natarajan; [email-masked]
Subject: Re: [trill] TRILL and IEEE 1588 PTP

Cheers
Jon

> 155 Beaver Street, Milford, MA 01757 USA [email-masked]
>
>