Subject: TAPS BOF: clarifications and pointer to mailing list

From: Michael Welzl <[email-masked]>
Date: Wed, 5 Mar 2014 16:29:14 +0000

Dear all,

I thought it would be helpful to give a little clarification about the TAPS BOF, for those of you who were there.

I was under the impression that what we're really planning to do didn't quite get across: an API? where? a middleware? So...

Defining and prescribing *one* API in *one* place of the stack is *not* the major goal of TAPS. The goal is to identify the services that are provided by IETF-defined transport protocols, look at services that applications really want from the network, and see how we can map the two onto each other. This is more abstract than an API in that it is not associated with one particular layer - it is helpful as implementation guidance for people doing APIs or middlewares. We have written a draft charter that tries to reflect that quite some time ago already:
https://sites.google.com/site/transportprotocolservices/home/charter-proposal-before-bof

If you look at the deliverables, you'll see the actual scope that we are thinking of. We would describe an example API, and we would specify how the services *can* be provided, but these two things are both meant as examples.

The intention of the agenda was:
- to give an overview of why this is needed (Jon's presentation)
- to give an example of how a richer set of services than just TCP and UDP can benefit an already widely deployed middleware, as an easy deployment path (don't change applications, just the middleware) (Martin's presentation)
- to give an *example* of how this could be implemented (Gorry's presentation)
- to explain how this relates to MIF (Margaret's presentation)

I am sorry if this wasn't clear enough; now I see that I should have perhaps given this background initially, but one always knows better in retrospect...

Please note that there is a website associated with this:
https://sites.google.com/site/transportprotocolservices/
with e.g. drafts, such as draft-hurtig-tsvwg-transport-apis-00 (this one should clarify some things, hopefully), and also an FAQ page, with answers to questions such as "Shouldn't this be an IRTF activity?". If you have such questions, the best thing to do would be to check this page, and if you disagree with what you see there, please join our list and tell us.

=> Well, please join us anyway if you're interested. The list subscription page is:
https://sympa.uio.no/ifi.uio.no/info/transport-services

I thank everyone who attended for a lively and interesting discussion, and I hope we can find a commonly agreed upon way to take this work ahead.

Cheers,
Michael Welzl

---

From: Michael Welzl <[email-masked]>
Date: Thu, 6 Mar 2014 18:27:47 +0000

Hi,

Just an update - the list for discussion TAPS related matters has just moved to [email-masked]
To subscribe, visit:
https://www.ietf.org/mailman/listinfo/taps

Cheers,
Michael