Subject: [Tsvwg] Re: MTU Fragmentatiion of control chunks

From: Qiaobing Xie <[email-masked]>
Date: Wed, 11 Jul 2001 11:21:53 -0500

Dinesh,

In general, SCTP control chunks are never fragmented. The Note you cited
below about INIT ACK is there because INIT and INIT ACK are the only
control chunks that may in theory become very large in size and have to
be sent in one packet. 

When that happens (should be very rare), the SCTP stack will let the IP
layer fragmentation to take care of the oversized packet.

-Qiaobing

Dinesh JN wrote:
> 
> In RFC 2960
> 
>    we have come across this note in RFC 2960
> 
>    IMPLEMENTATION NOTE: An implementation MUST be prepared to receive a
>    INIT ACK that is quite large (more than 1500 bytes) due to the
>    variable size of the state cookie AND the variable address list.  For
>    example if a responder to the INIT has 1000 IPv4 addresses it wishes
>    to send, it would need at least 8,000 bytes to encode this in the
>    INIT ACK.
> 
>    the fragmentation of Data chunk is very clear,but in cases above note,
> the size of the INIT CHUNK will be exceeding 1500 MTU, so how these chunks
> have to be handle
> 
> thanx in advance
> Dinesh
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Armando L. Caro Jr." <[email-masked]>
Date: Wed, 11 Jul 2001 13:10:16 -0400 (EDT)

The first release of our SCTP module for ns-2 is now available for
download. It currently supports the features in sections 6 and 7
of RFC2960 except:

   6.1 bi-directional data
   6.4 multi-homing
   6.8 checksum
   6.9 fragmentation
   7.3 path mtu discovery

We are currently working on:
   - Full ns-2 Application Layer API support
   - Unreliable Option

Future work includes support for:
   - Multihoming
   - Add/Delete IP Option

The patch and readme are available from:
	http://www.cis.udel.edu/~iyengar/research/SCTP/

Thanks,
Armando & Jana

-----------------------------------------------------------------------
Armando L. Caro Jr.                                  [email-masked]
University of Delaware                   http://www.cis.udel.edu/~acaro
-----------------------------------------------------------------------