Subject: RE: [Tsvwg] I-D ACTION:draft-ietf-tsvwg-sctpcsum-00.txt

From: [email-masked]
Date: Thu, 26 Jul 2001 16:01:24 -0400

Doug,

> As the serial media CRC32ITU (IEEE-802.3) is permanently
> used, then any argument for a different polynomial would
> clearly support use of this polynomial within SCTP.

That would be incorrect.  Intermediate network devices
strip and regenerate link CRCs.  The slight iSCSI
preference I see for the current CRC-32 in SCTP is
that it results in having both CRC-32 [SCTP] and
CRC-32C [iSCSI] coverage for corruption occurring in
such devices where there is no link CRC coverage.  If
SCTP uses CRC32C, the result is CRC-32C twice and no
other CRC in such locations.  You're correct that this
makes no difference for link errors on links that use
CRC-32, because between the CRC-32 on the link and the
CRC-32C in iSCSI, both CRCs are in the stack no matter
which CRC is used by SCTP.

Before this goes any further, I should point out that
this line of reasoning is basically unique to iSCSI, as
most other uses of SCTP are unlikely to have CRC-32C in
the protocol(s) above SCTP, and hence these other uses
will benefit from SCTP using CRC-32C over links that
use CRC-32.

> I find it odd for you to suggest that the IPS work
> group arrived at CRC32C as now documented but that the
> consensus was for CRC32ITU.

I either miswrote what you read or you misread what I wrote.
The state of things in the IPS WG is that iSCSI is using
CRC-32C.  This is the TSVWG WG, which may well reach a
different conclusion, as a different protocol is involved.
Like Randy, I believe the list discussion here in
TSVWG centered on the use of the current IEEE CRC-32
with SCTP.

Thanks,
--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140     FAX: +1 (508) 497-8500
[email-masked]       Mobile: +1 (978) 394-7754
---------------------------------------------------

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Douglas Otis" <[email-masked]>
Date: Thu, 26 Jul 2001 16:17:58 -0700

David,

Perhaps you were referencing consensus on tsvwg rather than ips.  I do not
recall a significant discussion within this work group within this area as
most of the discussion was concerning the general selection of CRC versus
various checksums.  I find it odd to think that you would wish to use a less
robust CRC to favor use of a more robust polynomial within an encapsulated
iSCSI.  This iSCSI polynomial can be optionally enabled and as there will be
a different range of bytes covered, two CRC checks with a superior pud
should be better than one using a CRC with a degenerated pud in the face of
larger frames.  SCTP should not be tailored to support iSCSI and, if you
think that CRC32C is to become the polynomial of choice, why not use it for
SCTP as you seem to suggest?

I am of course happy to see use of a CRC algorithm.  The selection of either
polynomial would have zero impact on the amount of software overhead.  The
only substantial difference is the pud with larger frames.  As it was worth
consideration within the ips work group, I also think it deserves discussion
within the tsvwg.  I also find that it would be strange for the IETF or IAB
to endorse two different polynomials within such a brief period of time.
The best polynomial should be selected based on merits of protection.  Even
if iSCSI were to enable CRC32C, I would still opt for CRC32C within SCTP.

Doug