Subject: RE: [Tsvwg] SCTP Heartbeat with multi-homing question

From: [email-masked]
Date: Thu, 19 Jul 2001 16:58:31 +0300

Hi all!

> Michael:
> 
> Thanks for the suggestions... I think we do
> need to clearify the heartbeat timing issues
> in possibly the implementors guide... I missed
> this one.. 
> 
> A while back we had a conversation on one of
> the lists... I think sigtran... discussing the
> intention of the jitter. The jitter is supposed
> to be a 0 - 2 second random addition to the timing
> so that you don't sync up the heartbeats :/ 

	But if you are allowed to have only one HEARTBEAT chunk on flight
(for the whole association), which heartbeats are going to be sent at the
same time? the ones sent to different associations? :-/

> So we you should be starting a timer along the lines of
> 
> RTO + HB.Interval + (Random value between 0.0 - 2.0)seconds.
> 
> This provides a jitter but not such a huge varience as
> is currently specified... I will attempt to work your suggestions
> into a new section in the implementors guide... I have started 
> accumulating some comments and I am sure I will find many
> more when I finally catch up with my email :-0

	BR Iván Arias Rodríguez

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: David Lehmann <[email-masked]>
Date: Fri, 20 Jul 2001 12:01:37 -0400

> same time? the ones sent to different associations? :-/

The RFC says 'should':
	Only one heartbeat should be sent each time the 
	heartbeat timer expires (if multiple destinations 
	are idle).

I still use the draft v9 algorithm to guarantee
a very short time for detecting complete connection loss
in signaling apps, regardless of the number of
destination addresses.

-David