Subject: RE: [Tsvwg] SCTP: 8.5.1: Rules for packet carrying ABORT

From: [email-masked]
Date: Thu, 19 Jul 2001 16:22:14 +0300

> Hello,

	Hi David!

> 	I have a quick question.  Actually, I really
> 	just want to confirm the accuracy of the text in
> 	8.5.1 (B).
> 
> 	The last bullet says:
>       -  The receiver MUST accept the packet if the Verification Tag
>          matches either its own tag, OR the tag of its peer.  
> Otherwise,
>          the receiver MUST silently discard the packet and take no
>          further action.
> 
> 	Doesn't the T bit matter as it does in "C) Rules for packet 
> 	carrying SHUTDOWN COMPLETE", where it says,
> 
>       -  The receiver of a SHUTDOWN COMPLETE shall accept the 
> packet if
>          the Verification Tag field of the packet matches its 
> own tag OR
>          it is set to its peer's tag and the T bit is set in the Chunk
>          Flags.
> 
> 	Please confirm that the T bit has no bearing on whether
> 	the ABORT chunk is accepted or not.

	The T bit DOES matter... This section should have been changed when
the T bit concept was introduced, and it is something that will be changed
in the new spec of RFC...

	The change is documented in the SCTP Implementors Guide draft, which
is the draft that specifies all the changes that will be done to RFC 2960...
You can retrieve this document from:

http://search.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpimpguide-01.txt

> -David

	BR Iván Arias Rodríguez

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: David Lehmann <[email-masked]>
Date: Thu, 19 Jul 2001 10:21:53 -0400

Thanks for the quick response.  (I looked in the
SCTP Implementors Guide draft.  Unfortunately,
I had version 00.  This correction was introduced in
version 01.)

-David