Subject: RE: [Tsvwg] SCTP Multihoming issue

From: [email-masked]
Date: Wed, 22 Aug 2001 20:55:11 +0300

Hi all,

	You might be completely right here Qiaobing... I guess that if in
the future somebody writes a draft about how to use multiple addresses to do
loadsharing, all these concerns may appear, and so a solution to them might
be provided... If you change the address selection procedure (so you change
the primary even if it is still up and working), you can modify the fast
retransmission algorithm as well, to match the new requirements... and
everything else you think would be helpful...

	BR Iván Arias Rodríguez

> -----Original Message-----
> From: ext Qiaobing Xie [mailto:[email-masked]]
> Sent: 22. August 2001 20:26
> To: Arias-Rodriguez Ivan (NRC/Helsinki)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Re: [Tsvwg] SCTP Multihoming issue
> 
> 
> Essentially we are talking about the traffic behavior when _multiple_
> destination addresses are involved _simultaneously_ in data 
> transmission
> (this can happen either during the changeover of the primary 
> address or
> when the upper layer intentionally directs data across different
> destination addresses).
> 
> Throughout the development of SCTP, we made it very clear that this
> "simultaneous, multi-path data transmission behavior" was a research
> topic (I remember Chip Sharp suggested that this could be a good
> research project for a Ph.D candidate).
> 
> There was no intention in SCTP design to address how traffic control
> should be done under such condition. This is the primary reason we
> removed round-robin from SCTP and made it a guiding principal 
> that "SCTP
> multi-homing was NOT meant for traffic sharing, but only for path
> redundancy!"
> 
> I don't think we know enough about "simultaneous, multi-path data
> transmission behavior" over Internet, nor do I think the time 
> is mature
> for us to talk about "solution" to modify SCTP for this purpose.
> 
> Therefore, my suggestion would be to stick with the principal 
> that "SCTP
> multi-homing is only for path redundancy." If your primary 
> address fails
> and you have to failover to an alternate, you shouldn't be 
> surprised to
> see some disturbance in the traffic pattern.
> 
> -Qiaobing

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 22 Aug 2001 13:51:50 -0500

Ivan,

See my comments below...

-Qiaobing

> everything else you think would be helpful...

Following the multi-homing design principal of SCTP, this change_primary
operation should not be a frequent event. Therefore, I'd really question
whether it is worthwhile to add complexity to the implementation (or the
spec) merely for the purpose of optimizing the retransmission pattern of
SCTP during these rare events.

---

From: Randall Stewart <[email-masked]>
Date: Wed, 22 Aug 2001 13:55:54 -0500

Qiaobing:

I completely agree with you!!

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)