Subject: [Tsvwg] Query!!!!!

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Mon, 20 Aug 2001 13:51:47 +0530 (India Standard Time)

Hi All,
   What should be SCTP's behaviour if it receives INIT chunk in
SHUTDOWN-PENDING state (i.e., peer restarts during shutdown)? What
indication should be sent to the ULP in this case?
Regards,
Vijay

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Mon, 20 Aug 2001 09:03:59 -0500

Vijay:

SHUTDOWN-PENDING when receiving an INIT chunk is no
different than being ESTABLISHED. You respond with
a INIT-ACK which contains a COOKIE. The cookie
will have inside it the tie-tags that are the
tags of the OLD association and the set of
new tags. No notification is given to the upper
layer until the COOKIE-ECHO arrives.

After all the various checks you will identify the
restart case as described in 5.2.4 in particular
the case looks the same as 5.2.4.1..

The association of course would (after the cookie
is recieved) go back to the ESTABLISHED state. The
app would have to do a shutdown again if it so wanted
but it may not if a restart did occur.... Also there
is a good chance that before the COOKIE-ECHO arrives
back you would receive an ABORT, since you had to have
had packets in the air when in order to be in SHUTDOWN-PENDING
and depending on when they hit the restarting peer, if it
is before the INIT the restarted peer would consider it
OOTB and send an ABORT.

In either case, if it was ABORT'ed or not, you still
end up with a "new" association with the restarted
peer.

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)