Subject: [Tsvwg] Re: M2PA: User Level Acknowledgements

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Nov 2001 23:58:14 -0600

Tom,

I think that TSV has fairly addressed this issue and has
indicated that GAP ACKs with no gap is illegal, that
a_rwnd = 0 cannot be permitted to stop data flow (zero
window probes), that artificially dropping a_rwnd is not
advisable, and that if ULP wants to withhold acks it needs
its own acks to withhold.

The situation with SCTP-level acks means also that neither
TSN nor Stream Sequence Number can be used by M2PA as BSNT
for changeover.

Please place sequence numbers and acks in the M2PA protocol:
I will prospose text if you would like.  This has the side-
benefit that multiple logical SS7 links can be placed each
in a separate stream in a single M2PA association and take
full advantage of SCTP's HOL blocking avoidance for improved
MTP performance under noise and delay.

Comments?

--brian

Brian F. G. Bidulock wrote:               (Wed, 25 Jul 2001 06:33:34)
> Tom,
> 
> I still see that you don't understand that M2PA needs
> user level acknowledgements which SCTP does not provide.
> The draft as it stands cannot handle Receive Congestion
> or Remote Processor Outage conditions correctly.
> 
> It will be necessary to put a sequence number on M2PA
> data messages and pass back an ACK at the M2PA level
> to fix this.  SCTP will not help.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Tom George <[email-masked]>
Date: Fri, 09 Nov 2001 17:31:31 -0600

Brian,

You are correct. M2PA draft version 4 will have M2PA-level sequence
numbers and acks. 

Suggested text would be welcome. 

I am not sure about putting multiple links on streams within an
association. What advantage does multiple streams give over multiple
associations?

tomG.

-- 
* Tom George        972-519-3168         [email-masked]   *
* PB2-1323       Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel USA, Inc.; 1000 Coit Rd, MS PB2-STPA; Plano TX 75075-5813   *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *