Subject: Re: [Tsvwg] SCTP: Data chunk in flight when a_rwnd = 0

From: Vern Paxson <[email-masked]>
Date: Sat, 03 Nov 2001 20:12:45 -0800

> My understanding of this is that the "one DATA chunk in flight" would
> have to be something other than new data. Am I correct?

No, it could be new data.

		Vern

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 4 Nov 2001 01:36:59 -0600

Vern,

That is not so clear from the text.

If the chunk is new data, however, the receiver appears
obliged to acknowledge this new data regardless of whether
the receive buffer space has been exhausted or not.
(Section 6.2: "The SCTP endpoint MUST always acknowledge
the reception of each valid DATA chunk.")

It this interpretation is correct, when a_rwnd = 0, new
data will continue to flow (2 chunks per RTT) and must
be acknowledged.

This makes it impossible for a receiver to stop inbound
traffic for intervals of several seconds.

Have I missed somewhere in the RFC where it mentions that
the receiver can refuse to acknowledge received DATA chunks
containing new data when it is advertising a receive window
of 0?

Or was it the intention of SCTP that it not permit a
receiver to stop traffic by setting a_rwnd = 0?

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦