Subject: [Tsvwg] Message Retrieval (was: SCTP and fragmentation)

From: Andreas Jungmaier <[email-masked]>
Date: Thu, 15 Nov 2001 17:41:55 +0100

Hello,

Another fine (probably implementation dependent) question is how to 
organize retrieval of data. RFC2960 states (in the example API) that 
there could be the functions :
RECEIVE_UNACKED, RECEIVE_UNSENT, which should be fairly useful for
MTP adaptation layers. 

Any ideas or enlightenment as to how that works together with
long "messages" ? (actually, "message" seems to imply something
short, but let's assume for a moment 5 MB message for a moment, my assoc
breaks, and I want to retrieve about 3 MB of data in order to
send it via a second association).

Andreas

- -- 
- ------------------------------------------------------------------------
Dipl.-Ing. Andreas Jungmaier              |                         _
Computer Networking Technology Group      | ASCII ribbon campaign  ( )
University of Essen                       |  - against HTML email   X
http://www.exp-math.uni-essen.de/~ajung   |              & vcards  / \

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 15 Nov 2001 10:09:30 -0600

Andreas:

I can only tell you how to do this with the socketapi draft :>

What we are doing is that:

IF the user is subscribed to data failure notifications
then we send each TSN up to the application with 
a state flag indicating if it was SENT or just QUEUED.

So basically the application will end up reading up
a large number of notifications with its 3M of data...

R

Andreas Jungmaier wrote:
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hello,
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.6 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> 
> iD8DBQE78/BTXAsLBNOCSsARAlLgAKCGj8/4j7rLs12nF9TXh0Mlby2XwQCgo9Tc
> RnfMfsSpJLfPbFlirIcqIyE=
> =Mnwl
> -----END PGP SIGNATURE-----
> 

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)