Subject: [Tsvwg] Heads up: TCP MIB extentions

From: Matt Mathis <[email-masked]>
Date: Wed, 5 Dec 2001 12:06:25 -0500 (EST)

Please note the attached Internet draft announcement.  It describes an extended
TCP MIB, designed to provide a direct way to query TCP connections to diagnose
performance problems.

I hope to introduce this as a work item for tsvwg.   The complication is
that RFC2012 is already under revision by inpnwg, mostly to update the
connection table to support IPv6 addresses.  See:
http://www.ietf.org/internet-drafts/draft-ietf-ipngwg-rfc2012-update-01.txt

I expect that most of the discussion at the IETF will be about process.

Thanks,
--MM--

---------- Forwarded message ----------
Date: Thu, 15 Nov 2001 07:05:51 -0500
From: [email-masked]
To: IETF-Announce:  ;
Subject: I-D ACTION:draft-mathis-rfc2012-extension-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: TCP Extended Statistics MIB
	Author(s)	: M. Mathis, R. Reddy, J. Heffner, J. Saperia
	Filename	: draft-mathis-rfc2012-extension-00.txt
	Pages		: 49
	Date		: 14-Nov-01

This draft describes extended performance statistics for TCP.  They
are designed to use TCP's ideal vantage point to diagnose performance
problems in both the network and the application.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-mathis-rfc2012-extension-00.txt

To remove yourself from the IETF Announcement list, send a message to
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-mathis-rfc2012-extension-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-mathis-rfc2012-extension-00.txt".

NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Wed, 05 Dec 2001 19:40:24 -0500

In message <[email-masked]>, Matt Ma
this writes:
>  This message is in MIME format.  The first part should be readable text,
>  while the remaining parts are likely unreadable without MIME-aware tools.
>  Send mail to [email-masked] for more info.
>
>--NextPart
>Content-Type: TEXT/PLAIN; CHARSET=US-ASCII
>Content-ID: <[email-masked]>
>

I don't speak MIB particularly well, but I think that the Security 
Considerations section needs to be expanded.  In particular, there are 
more entries that need to be read-protected as well, most notably
tcpEStatsDataSndNxt -- if I know that and know (or can guess) the 
connection 4-tuple, I can hijack the connection.

		--Steve Bellovin, http://www.research.att.com/~smb
		Full text of "Firewalls" book now at http://www.wilyhacker.com

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg