Subject: [Tsvwg] Section 7.1.10 sctpsocket-02.txt

From: "Kimble Scott (NET/MtView)" <[email-masked]>
Date: Thu, 27 Dec 2001 12:09:01 -0800

Section 7.1.10 Set Peer Primary Address (SCTP_SET_PEER_PRIMARY_ADDR)

An application can not utilize SCTP_SET_PEER_PRIMARY_ADDR with
getsockopt(2) to retrieve the primary peer address of a UDP-Style SCTP
instance because getsockopt(2) is read-only.  The sspp_assoc_id
parameter is not available to the kernel.  Consider returning EOPNOTSUPP
in this case.

[email-masked]
mobile 1-650-743-7903

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 27 Dec 2001 14:55:15 -0600

I am quite confused by your comment below.

You do need an association id if you wish to request the
peer to set its primary address for you (again using the
add-ip draft extension). In such a case the app calls
the setsockeopt(sctp_set_peer_primary_addr) with one of
its addresses that it would like to request the peer use as
a primary. 

You need a assoc-id and a local address to make this work. You
can have a "default" request that can be included in the INIT/INIT-ACK
and thus would not need a assoc-id... but you still need the flexibility
to make specific requests on specific associations.

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)