Subject: [Tsvwg] SACK acknowledging unsent data

From: "V.N.Sriram Chintalapati" <[email-masked]>
Date: Wed, 26 Dec 2001 09:40:48 -0800 (PST)

Hi,

I have a doubt.
what should be the behavior of SCTP stack if it
receives a SACK acknowledging unsent DATA?
a) Should it send an ABORT as SACK is acknowledging
DATA which is never sent, indicating that there is
something wrong with this association.
b) Should it accept acknowledgement for whatever
portion of DATA that is sent already.

I have looked into RFCs 2018 and 2883 and couldnot
find any discussion about this issue.
If this question is appropriate for an other list, can
you please redirect me to the same?

-Thanks n rgds,
Sriram

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Thu, 27 Dec 2001 13:10:37 -0600

Sriram:

No, I think this is a very good question and the right place
to ask it.

my stab at answers below...

> portion of DATA that is sent already.

I think we left this to be a implementation choice. I would imagine
that either option one can do but I would lean towards (a) if
it is possible to do in your implementation. This is because if
you receive a SACK on data you never sent there is a good chance
that an intruder has penetrated the stack and sent in something that
YOU did not send... either that or your peer is hopelessly confused.
Aborting would be, I think, the wiser thing to do..

Regards

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)