Subject: [Tsvwg] Section 4.3.1 sctpsocket-02.txt

From: Scott Kimble <[email-masked]>
Date: Fri, 14 Dec 2001 11:21:05 -0800

I may have missed the discussion on this issue.

Section 4.3.1 defines new meaning to a zero valued backlog parameter to
listen().

Historically, when the backlog parameter of listen() is zero, at least
one connection may be established.

Is it really the intention of the SCTP Socket API's draft to change the
meaning of the backlog parameter when it is zero?

--
[email-masked]
Office 1.650.864.6587
Mobile 1.650.743.7903

_______________________________________________
tsvwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Mon, 17 Dec 2001 07:44:01 -0600

Scott:

I don't know if we had this discussion per se on
the list :-)

But I do remember talking about it. I believe it was
Kacheong that mentioned to do it this way.. I had
asked a question to my co-authors (as I was working on
or FreeBSD SCTP stack) on this... "how do I turn off
listening on a UDP style socket?"... and this
was Kacheongs answer... Now if this changes a well
defined socket specification then we probably
should NOT use listen for the UDP model at all and
just add a new socket option. I believe Kacheong thought
that this was pretty much a unspecified behavior on what
to do if the listen() value is 0... I will let Kacheong
respond .. note he is out until after Jan 3 so it will
be a while.. 

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: Randall Stewart <[email-masked]>
Date: Mon, 31 Dec 2001 08:46:36 -0600

Scott:

After some inter-author discussion. My co-authors feel that
the zero back-log is not specified in posix to have any
meaning. In other words it is an implementation choice.
As such different platforms do different things with a zero
backlog...  Thus they wanted to use this feature as a way
to turn off accepting connections.

I have no qualms about instead adding another socket option 
that enables/disables connections.. this is how it
originally was laid out... If you can convince my co-authors
we can do this.. but for now I will leave it as is :>

R