Subject: [Tsvwg] Peer RWND = 0

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Fri, 8 Feb 2002 14:13:30 +0530 (India Standard Time)

Hi All,
  In the RFC, it is written that if the Peer Rwnd becomes ZERO, then we can
have one DATA chunk in the flight (if allowed by cwnd).

   My ques is:
      
          If, in the retransmitting queue there are some unsent chunk and
some chunks which has to be retransmitted.

        Is it necessary to send chunk first, which are marked for
retransmission?? What will happen if we will send the unsent chunk first ???

Lastly, Is there any function to get the MTU of the local interface (in
solaris)??

Regards,
Vijay

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: [email-masked]
Date: Fri, 8 Feb 2002 12:21:15 +0200

> Hi Ivan,

	Hi again Vijay,

>   Thanx for ur quick response.In RFC, the following line is written
> 
> C) When the time comes for the sender to transmit, before sending new
>       DATA chunks, the sender MUST first transmit any outstanding DATA
>       chunks which are marked for retransmission (limited by 
> the current
>       cwnd).
> 
> On page 68.
> 
> Does the above line mean that the chunks marked for 
> retransmission must go
> first when the peer rwnd is ZERO??? (I  think no....above 
> line points to the
> cwnd and not to the peer rwnd......may be i m wrong)

	It does not matter in which situation you are. When time to send something comes, you must always send first the lowest TSNs. If you only have unsent chunks, so you must send first the unsent chunk with the lowest TSN, and then the next one and so on (this basically means that you send new TSNs in order...). If you also have some chunks marked for  retransmission, then you must send first the oldest TSN marked for retransmission (and then the next one and so on) before you are able to send any unsent chunk (note that the newest chunk marked for retransmission must always be older than the unsent chunk with the lowest TSN).

	Note that the paragraph tells you what to send (supposing you can send something), not when to send.

> What will happen if we will send the unsent  chunk first ???

	You would be violating the protocol. Some bad guys could be interested in breaking some other rules so their data transmissions can go faster :-). But I don't see the point about not following this rule. If you don't do in that way, the receiver will have holes in its incoming queue and won't be able to deliver anything to the upper user... :-/

	BR Iván Arias Rodríguez

> 
> Regards,
> Vijay
> 
> 
> 
> 
> 
> -------Original Message-------
> From: [email-masked]
> Date: Saturday, February 09, 2002 02:32:07 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Tsvwg] Peer RWND Hi Vijay,
> > -----Original Message-----
> > From: ext Vijay Kumar Choudhary [mailto:[email-masked]]
> > Sent: 08. February 2002 10:44
> > To: [email-masked]
> > Subject: [Tsvwg] Peer RWND > 
> > 
> > Hi All,
> Don't know where exactly, but somewhere in 2960 it says that 
> if you have
> some TSNs to send, you have to send first the oldest one... 
> So in this case,
> the chunks marked for retransmission must go first.
> I think there is one. I think that it is one of those 
> getsockopt and the
> like... :-/
> BR Iván Arias Rodríguez
> > Regards,
> > Vijay
> >

---

From: [email-masked]
Date: Fri, 8 Feb 2002 15:19:10 +0200

> hi,
> I would like to know when you will be in such situation?( 
> some bytes marked for
> retransmission as well as RWND = 0)
> bcoz, when your timer times out, and when you mark chunk for 
> retransmission,
> RWND opens up ( if its zero ) becasue you will  add the bytes 
> marked for
> retransmission to the RWND

	Yes, it is true that it shouldn't be the normal case at all. But, if the peer is shrinking its window, you can end up having a null rwnd even though you don't have anything in flight. This is why in RFC 2960 it says that you are always allowed to have at least one TSN in flight no matter the value of rwnd. If you wouldn't do so you could never know about an enlargement of the rwnd...

	BR Iván Arias Rodríguez

> Thnx,
> ashraf
> Vijay Kumar Choudhary wrote:
> 
> > Hi Ivan,
> >
> >       chunks which are marked for retransmission (limited 
> by the current
> >       cwnd).
> >
> > On page 68.
> >
> > Don't know where exactly, but somewhere in 2960 it says 
> that if you have