Subject: [Tsvwg] RE: ICSC Sockets API Extensions Charter Approved

From: "Douglas Otis" <[email-masked]>
Date: Thu, 7 Feb 2002 21:09:47 -0800

Kirk,

There is work establishing a DDP (Direct Data Placement) and perhaps an RDMA
layer or shim for SCTP.  This provides methods for allowing direct placement
with/without tags and would also allow emulation of TCP partial writes.
Please note this allows "TCP/IP stack bypass" while providing congestion
avoidance without introducing new IP protocols.  SCTP is used without
modification for this purpose.

Your on going effort at:
http://www.opengroup.org/icsc/ working toward an API for protocols such as:
http://www.ietf.org/rfc/rfc2327.txt and
http://www.ietf.org/rfc/rfc2326.txt within
http://www.ietf.org/html.charters/mmusic-charter.html

There are already documents addressing Socket Descriptions for SCTP at:
http://www.ietf.org/internet-drafts/draft-ietf-tsvwg-sctpsocket-03.txt

How do you envision a collaboration with this ongoing effort?

A DDP/(RDMA)/SCTP draft will be available soon.  Presently this document is
being reviewed by Stephen Bailey [mailto:[email-masked]] and Allyn
Romanow [mailto:[email-masked]] of the RDMA effort and will be posted to
the IETF and announced on tsvwg:

tsvwg [mailto:[email-masked]]
To subscribe with message: subscribe email_address
tsvwg-request [mailto:[email-masked]

An RDMA reflector is at:
RDMA [mailto:[email-masked]]
http://groups.yahoo.com/group/RDMA/

An SCTP-DDP reflector is at:
SCTP-DDP [mailto:[email-masked]]
http://groups.yahoo.com/group/SCTP-DDP/

Doug

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Teisberg, Robert" <[email-masked]>
Date: Fri, 8 Feb 2002 14:22:34 -0600

Can we please keep IETF debates out of TOG?

> -----Original Message-----
> From: Douglas Otis [mailto:[email-masked]]
> Sent: Friday, February 08, 2002 2:19 PM
> To: [email-masked]
> Cc: Tsvwg
> Subject: RE: [Tsvwg] RE: ICSC Sockets API Extensions Charter Approved
> 
> 
> Robert,
> 
> > > There is ongoing work in creating a DDP layer for SCTP as
> > > indicated in the pending announcement of a draft within the
> > > tsvwg.  The only IP protocol suitable for RDMA would be
> > > SCTP unless there is interest in something like UDP or RDP
> > > which would incur acceptance issues.
> >
> > I'm not going to get into this except to note that not 
> everyone agrees
> > SCTP is the only suitable protocol.
> 
> There are efforts related to the introduction of an added 
> layer beneath or
> within TCP to handle framing in a fashion analogous to a 
> scheme proposed for
> iSCSI and as with Julian Satran and Stephen Bailey's ongoing 
> efforts toward
> such introduction.  Framing would be a requirement for RDMA if direct
> placement were desired.  You should also note such TCP 
> framing schemes are
> drafts and are not classified as part of the IP protocol 
> suite.  I believe
> the ICSC announcement made reference to this as a TCP/IP stack bypass.
> 
> > > A draft such as this can become an informational RFC.  None the
> > > less, it indicates ongoing efforts.  Unless you wish to 
> exclude SCTP,
> > > there should be interest in this effort.
> >
> > I don't wish to exclude SCTP.  On the contrary, I wish to include as
> > many alternatives as possible.
> 
> It is good SCTP is being considered.  As SCTP offers more 
> features, there
> may be additional options found when working with SCTP not seen on
> alternatives and you will note SCTP does have an impact on 
> the socket API.
> A view by RDMA in seeing SCTP as a subset of possible 
> transports is not a
> problem.  SCTP offers capabilities beyond alternatives and 
> should receive
> additional consideration for applications beyond RDMA as 
> well.  Specialized
> adapters for each application seems a poor approach.
> 
> Doug
> 
> 
> 
>