Subject: [Tsvwg] First DATA chunk

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Tue, 5 Feb 2002 15:06:36 +0530 (India Standard Time)

Hi All,
  In SACK chunk, what will be the value of the cumulative TSN Ack if the
first DATA chunk is missed?

Or,

If the first DATA chunk is missed, does the SACK needs to be send at all?
Regards,
Vijay

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Arun Prasad <[email-masked]>
Date: Tue, 05 Feb 2002 15:23:15 +0530

Hi Vijay,
there is no need to send SACK if u dont receive DATA packets at all....... ur
second point is right..

Thanks
-arun

--
****************************************************************
V.Arun Prasad
HCL Technologies Ltd.
51, Jawaharlal Nehru Road,
Ekkattuthangal,
Guindy Industrial Estate,
Chennai - 600097.

Contact # : 9144 - 2334174
            9144 - 2334181
            extn : 233
****************************************************************

---

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Tue, 5 Feb 2002 16:02:22 +0530 (India Standard Time)

Hi Arun,

    U didnt get my point.Suppose i have received the second DATA chunk
without receiving the first DATA chunk.Does the SACK needs to be send.If YES
 then what will be the value of the cumulative TSN Ack in SACK chunk.If NO,
what will be the behaviour of SCTP. 

Rehards,
Vijay
-------Original Message-------
From: Arun Prasad
Date: Wednesday, February 06, 2002 03:01:45 AM
To: Vijay Kumar Choudhary
Cc: [email-masked]
Subject: Re: [Tsvwg] First DATA chunk
Hi Vijay,
there is no need to send SACK if u dont receive DATA packets at all.......
ur
second point is right..
Thanks
-arun

---

From: Randall Stewart <[email-masked]>
Date: Tue, 05 Feb 2002 05:36:15 -0600

Vijay:

If two packets are sent Chunk 101 and Chunk 102. And the
initial TSN IS 101... and then somewhere in the network
101 is dropped...

You would end up sending a SACK with a CUM-ACK of 100 and
gap report of 1 showing [2,2].

The RFC is specific about that and tells each side to set
there cum-ack point to Initial-TSN minus 1.

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)

---

From: Arun Prasad <[email-masked]>
Date: Tue, 05 Feb 2002 17:07:25 +0530

Hi Vijay,
    sorry, I got ur querry now....  I can think of one way to do it.... Just check
whether this is OK....

Let the
    Initial Cumulative TSN  = InitTsn -1 (Receiver side)
    Initial Cumulative TSN Ack Pt =  InitTsn - 1 (Sender side)

    Now consider ur condition, the SACK will be generated with the
Cum TSN Ack as "Initial Cum TSN", along with the gap blocks....
Upon receiving this SACK,  the endpoint recognises this to be a
valid SACK according to the below lines from RFC......
    So I think, there is no need to handle seperately for this condition,
but to have the initial values as specified above.....

i) If Cumulative TSN Ack is less than the Cumulative TSN Ack
         Point, then drop the SACK.   Since Cumulative TSN Ack is
         monotonically increasing, a SACK whose Cumulative TSN Ack is
         less than the Cumulative TSN Ack Point indicates an out-of-
         order SACK.

Is this suggestion ok???

Thanks
-arun