Subject: RE: [Tsvwg] RE: [rdma] a proposal for a different No-Data-Touch f ramer for TC P

From: "WENDT,JIM (HP-Roseville,ex1)" <[email-masked]>
Date: Wed, 20 Feb 2002 08:58:00 -0800

Pat & Steph,
There are two new variations under discussion here.
Maybe we can establish unique names for them now.

* "Padded FIM"
  Steph's version inserts pad bytes after one or more
  packed ULP PDUs to reach the next marker interval
  (which is the EMSS and forces the marker to
  occupy the first bytes in the next TCP segment 
  payload). Sort of a padded-FIM scheme.

* "Aligning FIM"
  My original scheme was to align ULP PDUs to the start
  of TCP segments, pack mutiple PDUs into a TCP segment
  if possible, and allow the markers to fall where they
  may in the data stream (and not necessarily in the
  same TCP segment as the ULP PDU they point to). This
  scheme doesn't insert pad bytes into the stream.
  When the ULP PDUs are limited to the EMSS, it does
  allow each ULP PDU to be fully contained in a single
  TCP segment and allows that segment to be immediately
  and fully processed and direct placed with no need
  to maintain residual state information. The impact on
  network bandwidth is that some shorter TCP segments
  may be emitted (i.e. more protocol header bytes
  vs data bytes) depending upon the characteristics
  of the ULP packet stream.

Jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, February 19, 2002 5:05 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Tsvwg] RE: [rdma] a proposal for a different 
> No-Data-Touch
> f ramer for TC P 
> 
> 
> Steph,
> 
> I wouldn't consider this a leading candidate as the potential 
> inefficiencies
> are 
> too large. Packing can improve the efficiency if there is a 
> stream of short
> PDUs.
> However, it is very common to have a mix of long and short 
> PDUs in the data
> path.
> When a small PDU is followed by a large PDU such that the 
> combination of the
> two 
> doesn't fit in the fixed length segment, then one has no 
> alternative but to
> pad
> the segment containing the short PDU and start a new segment 
> with the large
> PDU.
> 
> For bulk data protocols, the overwhelming majority of data in 
> large PDUs as
> you say
> IF one is comparing bytes in small packets vs bytes in large packets.
> However, 
> by packet count, there are a lot of small packets. Usually 
> more than half
> the packets
> are short (commands, status, R2T's, etc). The mixture of packet sizes
> reduces 
> efficiency with a fixed length scheme.
> 
> Bandwidth in the LAN isn't expensive, but it isn't free either. More
> importantly,
> bandwith for applications crossing the WAN is expensive and 
> wasting it in a
> fixed
> length "aligning FIM" would not be acceptable.
> 
> Regards,
> Pat
> 
> -----Original Message-----
> From: Stephen Bailey [mailto:[email-masked]]
> Sent: Friday, February 15, 2002 11:31 AM
> To: THALER,PAT (A-Roseville,ex1)
> Cc: [email-masked]
> Subject: Re: [Tsvwg] RE: [rdma] a proposal for a different 
> No-Data-Touch
> framer for TC P 
> 
> 
> Pat,
> 
> > I don't understand what you are suggesting.
> 
> Actually, it seems you do understand what he's suggesting, but are not
> buying it :^)
> 
> The way I'd define it, it's not that the ULP PDUs are fixed length,
> but that the framing protocol may add padding within a finite
> interval.  For best transport efficiency, you would need to do what
> TUF calls `ULPDU packing'.  You may end up with more than one ULPDU
> per finite interval.
> 
> It actually seems like it might be a pretty good scheme.  Your finite
> interval would be EMSS, and the segmentation algorithm would be
> similar to the current TUF except to get markers at the beginning of
> segments.
> 
> This might be a new leading candidate.  It's no touch and completely
> safe.  The cost is that you must either do ULPDU packing (the
> unpacking is actually the burdensome part, but I personally never
> thought it was too horrible), or live with inefficient transport of
> small messages.  For bulk data protocols (e.g. storage) the
> overwhelming majority of the data you carry is in large
> (interval-sized) PDUs, so a small loss of transport efficiency for the
> control PDUs won't hurt.
> 
> Alright, you've done it again Jim!  By muddying the waters we clarify
> them :-?
> 
> Steph
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Douglas Otis" <[email-masked]>
Date: Wed, 20 Feb 2002 13:35:52 -0800

Jim,

There could be a third variant.  FIM with TLV bundling by creating a common
header confirmed by a checking scheme followed by standardized encapsulation
of ULP data units called Chunks.  This TLV bundling would reduce the affects
of alignment attempts.

Doug