Subject: RE: [Tsvwg] Peer RWND = 0

From: [email-masked]
Date: Fri, 8 Feb 2002 11:38:50 +0200

Hi Vijay,

> -----Original Message-----
> From: ext Vijay Kumar Choudhary [mailto:[email-masked]]
> Sent: 08. February 2002 10:44
> To: [email-masked]
> Subject: [Tsvwg] Peer RWND = 0
> 
> 
> Hi All,
>   In the RFC, it is written that if the Peer Rwnd becomes 
> ZERO, then we can
> have one DATA chunk in the flight (if allowed by cwnd).
> 
>    My ques is:
>       
>           If, in the retransmitting queue there are some 
> unsent chunk and
> some chunks which has to be retransmitted.
> 
>         Is it necessary to send chunk first, which are marked for
> retransmission?? What will happen if we will send the unsent 
> chunk first ???

	Don't know where exactly, but somewhere in 2960 it says that if you have some TSNs to send, you have to send first the oldest one... So in this case, the chunks marked for retransmission must go first.

> Lastly, Is there any function to get the MTU of the local 
> interface (in
> solaris)??

	I think there is one. I think that it is one of those getsockopt and the like... :-/

	BR Iván Arias Rodríguez

> Regards,
> Vijay
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg
> 

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Vijay Kumar Choudhary" <[email-masked]>
Date: Fri, 8 Feb 2002 15:38:07 +0530 (India Standard Time)

Hi Ivan,

  Thanx for ur quick response.In RFC, the following line is written

C) When the time comes for the sender to transmit, before sending new
      DATA chunks, the sender MUST first transmit any outstanding DATA
      chunks which are marked for retransmission (limited by the current
      cwnd).

On page 68.

Does the above line mean that the chunks marked for retransmission must go
first when the peer rwnd is ZERO??? (I  think no....above line points to the
cwnd and not to the peer rwnd......may be i m wrong)

What will happen if we will send the unsent  chunk first ???

Regards,
Vijay

-------Original Message-------
From: [email-masked]
Date: Saturday, February 09, 2002 02:32:07 AM
To: [email-masked]; [email-masked]
Subject: RE: [Tsvwg] Peer RWND Hi Vijay,
> Subject: [Tsvwg] Peer RWND > 
> 
> Hi All,
Don't know where exactly, but somewhere in 2960 it says that if you have
some TSNs to send, you have to send first the oldest one... So in this case,
the chunks marked for retransmission must go first.
> Lastly, Is there any function to get the MTU of the local 
I think there is one. I think that it is one of those getsockopt and the
like... :-/
BR Iván Arias Rodríguez

---

From: Arun Prasad <[email-masked]>
Date: Fri, 08 Feb 2002 15:50:39 +0530

> cwnd and not to the peer rwnd......may be i m wrong)

    I think ur guess inside the brackets is right...

> What will happen if we will send the unsent  chunk first ???

        It will create unnecessary gaps in the Receiver side... No point in sending
new data chunks to the peer when the old ones havent reached there.... (because
the ones u are sending also will not reach the Application, as it is out of sequence...)
Am I answering ur Question????

> Vijay

Thanks
-arun

--
****************************************************************
V.Arun Prasad
HCL Technologies Ltd.
51, Jawaharlal Nehru Road,
Ekkattuthangal,
Guindy Industrial Estate,
Chennai - 600097.

Contact # : 9144 - 2334174
            9144 - 2334181
            extn : 233
****************************************************************

---

From: Ashraf <[email-masked]>
Date: Fri, 08 Feb 2002 16:43:12 +0530

hi,
I would like to know when you will be in such situation?( some bytes marked for
retransmission as well as RWND = 0)
bcoz, when your timer times out, and when you mark chunk for retransmission,
RWND opens up ( if its zero ) becasue you will  add the bytes marked for
retransmission to the RWND

Thnx,
ashraf