Subject: Re: [Tsvwg] FW: I-D ACTION:draft-culley-iwarp-mpa-00.txt

From: Joe Touch <[email-masked]>
Date: Fri, 27 Sep 2002 10:33:25 -0700

Teisberg, Robert wrote:
>>Fri 9/27/2002 9:57 AM, Joe Touch wrote:
> 
> 
>>>At 12:50 AM 9/25/2002, Joe Touch wrote:
>>>
>>>
>>>>	there are other indications:
>>>>
>>>>RECEIVE: (circa pg 57):
>>>>...
>>>>     If insufficient incoming segments are queued to satisfy the
>>>>     request, queue the request.
>>>>...
>>>>     When the TCP takes responsibility for delivering data 
>>>
>>to the user
>>
>>>>     that fact must be communicated to the sender via an
>>>>     acknowledgment.
>>>>
>>>>That last one seems the clincher on the point, BTW.
>>>
>>In the first case, it isn't necessarily that TCP is being 
>>permitted to 
>>place data with gaps in the buffer; 
> 
> 
> It isn't forbidden, so how can it not be permitted?

The converse is required (see below).

>>it may be that the buffer is only 
>>partially filled. The second part - that says that data 
>>delivered to the 
>>user must be ack'd - is key. TCP doesn't ack data until all 
>>data prior 
>>has been received.
> 
> In fact, the quoted text says that data *that TCP has taken responsibility
> for delivering* must be ack'd.  Actual delivery can happen either before
> or after the ack.

Agreed. However, if the data is placed to the application and the 
connection closed before TCP receives the data in the gap, it CANNOT 
EVER be acked. That's why it -breaks- TCP.

Joe

_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Teisberg, Robert" <[email-masked]>
Date: Fri, 27 Sep 2002 11:29:33 -0500