Subject: [Tsvwg] Congestion Control in SCTP

From: "[email-masked]" <[email-masked]>
Date: Tue, 3 Sep 2002 12:08:43 +0200

Hi, 
I'm an italian student, for my thesis i'm studing congestion control in
Tcp and SCTP. I've already read almost all the RFC and Draft about this
issue.
I have some questions:

1)what are actual open issue about Congestion control in SCTP?

2)Is it possible use in SCTP congestion algorithms non-TCP-compatible?

3)Vegas algorithm has some competition problems with Reno algorithm in 
TCP. Is possible use Vegas algorithm in SCTP?

Best Regards Senny 
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Tue, 03 Sep 2002 12:28:57 -0500

Senny

Please direct SCTP implementation questions and issues to
[email-masked]

Regards

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 15:27:37 -0600

Randall,

Is SCTP now a Cisco protocol and no longer an IETF protocol?

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Craig Rodrigues <[email-masked]>
Date: Tue, 3 Sep 2002 18:20:17 -0400

> Is SCTP now a Cisco protocol and no longer an IETF protocol?

This is not true.  Scot Bradner had previously asked Randall
if a new SCTP mailing list could be created to take most of the
SCTP discussions off of tsvwg.

Cisco is merely providing the resources for the
mailing list as a service to the SCTP community.

See: http://www.sctp.org/mailinglists.html

==========================================================================
   Mailing lists
     * sctp-impl mailing list
       The   sctp-impl   mailing   list   is  for  questions  related  to
       implementing  and  using  SCTP. It is provided as a service to the
       IETF by Cisco Systems Inc. Views expressed on this list may NOT be
       the views of Cisco Systems.
       To subscribe to the sctp-impl mailing list:
         1. Send an e-mail to [email-masked].
         2. Type   subscribe  sctp-impl  <e-mail_address>  in  the  body.
            Replace <e-mail_addess> with your e-mail address.
         3. Leave the Subject field empty.
         4. You will receive an e-mail acknowledging you are on the list.
            This  e-mail  contains  information on unsubscribing from the
            list. Save this message for future reference.
         5. To post to the list send e-mail to
            [email-masked].

        Mailing list archives are found here:  http://www.sctp.org/archive/
==========================================================================

-- 
Craig Rodrigues        Distributed Systems and Logistics, Office 6/325A
[email-masked]       BBN Technologies, a Verizon company
(617) 873-4725         Cambridge, MA
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: Randall Stewart <[email-masked]>
Date: Tue, 03 Sep 2002 17:23:46 -0500

No, cisco agreed (at the request of Scott Bradner) to
host a mail exploder to deal with SCTP implementation issues.
Scott asked me to set this up and I was able to get it
together....

It is much like how sigtran used to be hosted by nortel.. this
did not make any of the sigtran protocols nortel network's :-0

R

---

From: Peter Lei <[email-masked]>
Date: Tue, 03 Sep 2002 17:27:33 -0500

Of course not... :)

Please check the archives:
  http://www.ietf.org/mail-archive/working-groups/tsvwg/current/msg03065.html

SCTP implementation / usage questions are being moved to this new list.

--peter

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 17:20:36 -0600

Peter,

I don't see this SCTP implementation mailing list listed on the TSVWG charter.
Is there an official IETF mail archive for this new list?  Is this list for
official TSVWG discussions related to SCTP implementation such as the SCTP
Implementor's Guide drafts?  Will I-D Actions and comments for the SCTP
Implementor's Guide be posted to this new list?  If TSVWG work items are being
worked on this new list, why is the new list not listed under the TSVWG
charter under "Mailing Lists" with instructions for subscription,
unsubscription and accessing the IETF mail archive?  Why are SCTP MIB
discussions (which are really related to implementation) being held on
[email-masked] if SCTP implementation discussions are to be on this new list?

Why was SCTP implementation (whatever "implementation" means) whisked off and
being pushed to the side in the first place?  As the orginal note
demonstrates, there are few issues affecting SCTP that are not also of concern
to TCP and visa versa.

Does the TCP community view SCTP as some sort of evil twin that must be
locked away in a room?

--brian

---

From: Scott Bradner <[email-masked]>
Date: Tue, 3 Sep 2002 19:26:00 -0400 (EDT)

what he said

----

---

From: Craig Rodrigues <[email-masked]>
Date: Tue, 3 Sep 2002 18:20:17 -0400

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 17:28:54 -0600

Randall,

The SIGTRAN list was listed on the charter, moderated
by the WG chair, archived in the official IETF mail
archives, and the sole mailing list of the WG.

Are any of these the case for your new Cisco list?

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 17:31:05 -0600

Scott,

Please place this Cisco mailing list on the TSVWG charter
under "Mailing Lists", establish an IETF mail archive,
and indicate which TSGWG work items are to be dealt with
on this new list.

Thank you.

--brian

On Tue, 03 Sep 2002, Scott Bradner wrote:

> what he said
> 
> ----
> >From [email-masked]  Tue Sep  3 18:30:27 2002
> Date: Tue, 3 Sep 2002 18:20:17 -0400
> From: Craig Rodrigues <[email-masked]>
> To: "Brian F. G. Bidulock" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Tsvwg] Congestion Control in SCTP
> References: <[email-masked]> <[email-masked]> <[email-masked]>
> Mime-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: inline
> User-Agent: Mutt/1.2.5i
> In-Reply-To: <[email-masked]>; from [email-masked] on Tue, Sep 03, 2002 at 03:27:37PM -0600
> Sender: [email-masked]
> Errors-To: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.12
> Precedence: bulk
> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/tsvwg>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Id: Transport Area Working Group <tsvwg.ietf.org>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/tsvwg>,
> 	<mailto:[email-masked]?subject=subscribe>
>

---

From: Scott Bradner <[email-masked]>
Date: Tue, 3 Sep 2002 19:37:36 -0400 (EDT)

sigh - such a dark view of the world

asking Randall to set up a sctp-impl list is hardly the 1st time
that we have asked that questions about implementation of a 
protocol be moved off of the WG list where new work is being done
(we did this years ago in diffserv) 

there is no conspiracy here, just an attempt to get some of the
implementor chatter off of the tsvwg list

but, at Brian's "suggestion" I'll ask that information about the
list be added to the tsvwg web page

Scott

----

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 17:20:36 -0600

Peter,

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 17:47:39 -0600

Scott,

It might tbe different if the WG chair (you) announced the list,
rather than just an author (Randall).

I have some questions about this new list:

Is this new list intended only for non-work-item related mail?

Are SCTP I-D-Actions, draft and RFC discussion still to be performed
on the main tsvwg list?

For example, where do I discuss issues with the SCTP Implementor's
Guide?

You see, I don't care to see a lot of SCTP implementation drivel
either, however, I am interested in seeing all SCTP implementation
issues which impinge on a WG draft (work item) or RFC.  Where will
I find the WG related stuff?  Is the WG related stuff on tsvwg and
the drivel (err... thesis quesionts) on this new list?

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 3 Sep 2002 18:10:09 -0600

Randall,

Finally, I understand from Scott that this list, unlike
the SIGTRAN list you mention, is for non-WG-related items.
Please thank Cisco for assuming this non-essential traffic.

--brian