Subject: [Tsvwg] ABORT processing

From: bhanu <[email-masked]>
Date: Thu, 02 Jun 2005 19:46:29 +0530

Hai all..

The RFC-2960 section: 3.3.7 says:
    If an endpoint receives an ABORT with a format error or for an
   association that doesn't exist, it MUST silently discard it.

Here the "format error" indicates what..?

When a ABORT is received with some Error Causes, if one of the error 
causes in it
is invalid (i.e cause length may be wrong or the error content may be wrong)
what action need to be taken...?
Should we accept the ABORT by neglecting the error cause in it   or   
the whole ABORT
chunk need to be dropped..?

Please clarify.

Regards
Bhanu.
_______________________________________________
tsvwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tsvwg

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jun 2005 09:46:32 -0600

bhanu,

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: bhanu <[email-masked]>
Date: Thu, 02 Jun 2005 21:45:54 +0530

Hi

In my case the format of ABORT is correct (i.e:Type and chunk length is 
correct),
but the error cause in it is invalid..!! (e.g: cause length is invalid)

As the receiver will not do anything with the error cause built in an 
ABORT..!!
is it mandatory to drop ABORT..?

Please clarify
Bhanuprakash

I do not think the receiver will do anything  with it,

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 2 Jun 2005 18:24:41 +0200

Hi Bhanuprakash,

the important point here is that you do not send an ABORT!

Assuming that you got an ABORT for an existing association and
you have the number of bytes in the packet which is indicated
by the chunk length, it is up to you to delete the association
or not. But do not send anything.

Best regards
Michael

On Jun 2, 2005, at 18:15 Uhr, bhanu wrote:

>
>  Hi
>
>  In my case the format of ABORT is correct (i.e:Type and chunk length 
> is correct),
>>>    is  invalid (i.e cause length may be wrong or the error content 
>>> may be
>>>    wrong)

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 2 Jun 2005 18:21:04 +0200

Hi Bhanuprakash,

Assuming that you got an ABORT for an existing association and
you have the number of bytes in the packet which is indicated
by the chunk length, it is up to you to delete the association
or. But do not send anything.

Best regards
Michael