Subject: [Tsvwg] Heartbeat information

From: kzu kzu <[email-masked]>
Date: Thu, 16 Aug 2007 07:33:41 -0700 (PDT)

hi,
   
  I have seen that the heartbeat information has Destination address, originator address and the time.
  However the chunck has quite a lot of zeros in it, like :
  Heartbeat information length with 56 bytes, where 
  1st 8 bytes are for Destination address: but first 4 bytes are filled out with zeros.
   
  Then there are 12 bytes with zero.
   
  After that the orignator address:
  8 bytes are for Destination address: but first 4 bytes are filled out with zeros.
   
  I was wondering where I can find a reference to the right implement heartbeat information.
   
  From 2960, 8.3 Path Heartbeat, I could only find the required data inside heartbeat information.
   
  Thank you in advance,
  /Kazuo

---------------------------------
Choose the right car based on your needs.  Check out Yahoo! Autos new Car Finder tool.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 16 Aug 2007 12:19:06 -0600

kzu,

The format of the heartbeat information parameter is not specified
by the RFC and is up to the implementation.  Some implementations
pad the parameter out to a rather large size and use it for path
MTU discovery.  You have to decide what layout makes sense to your
implementation.  Also, be careful that some malicious endpoint might
manipulate the contents of the parameter.

--brian

kzu kzu wrote:                                (Thu, 16 Aug 2007 07:33:41)
>      _________________________________________________________________
> 
>    Choose  the  right  car based on your needs. Check out [1]Yahoo! Autos
>    new Car Finder tool.
> 
> References
> 
>    1. http://us.rd.yahoo.com/evt=48518/*http://autos.yahoo.com/carfinder/;_ylc=X3oDMTE3NWsyMDd2BF9TAzk3MTA3MDc2BHNlYwNtYWlsdGFncwRzbGsDY2FyLWZpbmRlcg--

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/