Subject: [Tsvwg] a query related to multi-homed feature about sctp using vrf

From: "li suozhu" <[email-masked]>
Date: Wed, 01 Aug 2007 22:41:01 +0800

Hi All, 

I have a query  related to multi-homed feature about sctp when using vrf.

There are two endpoints ,endpoint-1 and endpoint-2,Endpoint-1 has 2 
interfaces with same IP address but differents vrf( IP1-vrf 1, IP1-vrf2) 
,while endpoint-2 has 2 interfaces with IP2-vrf 1 and IP3-vrf 2 seprately.
In this case ,I want to know what the IPv4 Address Parameter will be ,in 
INIT (endpoint-1 is client)or INIT ACK(endpoint-1 is server) chunk ,Only 
one IPv4 Address or Two same IPv4 Address? and how can a sctp endpoint know 
vrf about a IP address ?

Could someone explain right solution?
 
Best regards,

Li

-----------------------------------------------------------------------

_________________________________________________________________
免费下载 MSN Explorer:   http://explorer.msn.com/lccn/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 1 Aug 2007 09:15:28 -0600

li,

What's a vrf?

--brian

li suozhu wrote:                                   (Wed, 01 Aug 2007 22:41:01)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: <[email-masked]>
Date: Wed, 1 Aug 2007 11:31:09 -0500

If there is only one IP address at an endpoint that endpoint is single homed as far as SCTP is concerned.  Only one IP address (if any) would be listed in it's INIT or INIT ACK chunks.  SCTP knows nothing about interfaces.

Ronnie

---
Ronnie Sellar			Emerson Network Power, Embedded Computing
Tel: +44 131 475 7015		Suite 4, 2 Anderson Place
Fax: +44 131 475 7001		Edinburgh EH6 5NP
mailto:[email-masked]	http://www.emersonembeddedcomputing.com

> -----Original Message-----
> From: li suozhu [mailto:[email-masked]] 
> Sent: 01 August 2007 15:41
> To: [email-masked]; [email-masked]
> Subject: [Tsvwg] a query related to multi-homed feature about 
> sctp using vrf
> 
> Hi All, 
> 
> There are two endpoints ,endpoint-1 and endpoint-2,Endpoint-1 
> has 2 interfaces with same IP address but differents vrf( 
> IP1-vrf 1, IP1-vrf2) ,while endpoint-2 has 2 interfaces with 
> IP2-vrf 1 and IP3-vrf 2 seprately.
> In this case ,I want to know what the IPv4 Address Parameter 
> will be ,in INIT (endpoint-1 is client)or INIT ACK(endpoint-1 
> is server) chunk ,Only one IPv4 Address or Two same IPv4 
> Address? and how can a sctp endpoint know vrf about a IP address ?
>

---

From: Peter Lei <[email-masked]>
Date: Wed, 01 Aug 2007 12:56:11 -0500

SCTP itself is unaware of VRFs (as is the case for TCP and UDP).   The
addresses sent within the protocol are interface agnostic.

However, you can extend the SCTP stack and applications to be VRF-aware
and we do have an implementation that allows this; we have extended the
API (in a implementation specific manner) to support VRFs.

If you can make the assumption that an association will belong to one and
only one VRF (which I think is an appropriate assumption), the INIT/INIT-ACK
chunks will only list the addresses that are part of the VRF.  Thus in
this case,
you would never list the same IP address more than once.

When responding to incoming packets, you will need to get the appropriate
VRF identifier from your OS/IP stack on a per-packet basis; this can be an
explicit VRF identifier or a mapping of some ingress interface
identifier to a
specific VRF.  Similarly on the egress side, you would likely need to
pass an
explicit VRF identifier to the OS/IP stack, or need to select an appropriate
egress interface (corresponding to the addresses sent in the INIT/INIT-ACK).

--peter

li suozhu wrote:
> one IPv4 Address or Two same IPv4 Address? and how can a sctp endpoint 
> know vrf about a IP address ?
>