Subject: FW: multipath congestion control and RFC 2861

From: <[email-masked]>
Date: Thu, 20 Jan 2011 15:01:19 +0200

Equally relevant for the work on CMT-SCTP - draft-tuexen-tsvwg-sctp-multipath-01.txt
Therefore forwarded here as well.

BR, Karen

_____________________________________________
From: Nielsen Karen
Sent: 20. januar 2011 13:43
To: multipathtcp
Subject: multipath congestion control and RFC 2861

Hi,

In the context of multipath TCP and coupled congestion control, I am wondering what the thoughts are in respect to
the limitation put on growth of not fully utilized congestion windows by RFC 2861 - as exemplified by the following text from RFC 2861.

  "For the separate issue of the increase of the congestion window in
   response to an acknowledgement, we believe the correct behavior is
   for the sender to increase the congestion window only if the window
   was full when the acknowledgment arrived."

The question seems relevant in connection with multipath TCP as it impacts to willingness (and possibility)
of TCP to "instantly" redistribute traffic from one failed path to other paths - or perhaps more strictly speaking: to have n-1 paths absorb
the traffic previously distributed on n paths.

Also the issue becomes very relevant when discussing the applicability of the multipath congestion control to SCTP (CMT-SCTP)
as SCTP (RFC 4960)  in text at least (not sure about all implementations) incorporates the RFC 2861 constrains on growth of not utilized CWNDs.

Thanks.

BR, Karen

*****************************************************************************************
Karen Egede Nielsen
Software Architect, Ph.D.

Tieto Denmark A/S
IP Solutions, Telecom & Media
Skanderborgvej 232, 8260 Viby J, DK-Denmark
Direct Phone / Mobile +45 25134336
E-mail: [email-masked]
*****************************************************************************************
www.tieto.com

Please note: The information contained in this message may be legally privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, you are hereby notified that any unauthorised use, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer. Thank You.

---

From: Randy Stewart <[email-masked]>
Date: Fri, 28 Jan 2011 07:55:50 -0500

Karen:

Has you note, SCTP does in-force RFC2861 in its cc.. and I know
that in FreeBSD-SCTP we do just that...

Now that being said, the cwnd is kept on a per destination basis... so each
destination in CMT would grow with the same thought.. i.e. only if
the destination was using the full cwnd.. I am not sure how that
plays with the resource pooling... which is implemented in FreeBSD SCTP now
but I am not sure if they applied the use-it-or-loose or not... I guess
I need to go peek at the code and see what they did ;-)

R
On Jan 20, 2011, at 8:01 AM, <[email-masked]> <[email-masked]> wrote:

>  
> Equally relevant for the work on CMT-SCTP – draft-tuexen-tsvwg-sctp-multipath-01.txt
> the limitation put on growth of not fully utilized congestion windows by RFC 2861 – as exemplified by the following text from RFC 2861.
>  
> of TCP to “instantly” redistribute traffic from one failed path to other paths – or perhaps more strictly speaking: to have n-1 paths absorb

-----
Randall Stewart
[email-masked]