Subject: TSVWG Adoption of draft-polk-tsvwg-intserv-multiple-tspec

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 1 Jul 2011 08:52:26 +0100 (BST)

This email confirms the adoption of the above draft by TSVWG as a work 
item. Authors please prepare a draft -00 working group ID including
the comments received during the WG adoption call.

New name: draft-ietf-tsvwg-intserv-multiple-tspec

This document received postive support by the WG, and noissues were noted 
about its suitability for adoption. A set of reviewers have been be 
identified who will provide feedback duing the WG/IETF process.

Best wishes,

Gorry Fairhurst
(tsvwg Chair)

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Thu, 7 Jul 2011 12:30:36 -0500

A small group has been working on implementing version 1 of the Saratoga transport protocol.  I will be giving a 10 minute synopsis at the 81 IETF (currently it looks like that will be Friday morning.)

Saratoga was originally developed to transfer remote-sensing imagery efficiently from a low-Earth-orbiting satellite constellation, but is useful for many other scenarios, including ad-hoc peer-to-peer communications, delay-tolerant networking, and grid computing. Saratoga Version 1 has hooks in place to accommodate file transfer, streaming, and bundling.

http://tools.ietf.org/html/draft-wood-tsvwg-saratoga-09

We currently are working implementations in PERL, C and C++.  Charles Smith (Commonwealth Scientific and Industrial Research Organization) has also been working on a wireshark plugin.

One interesting area that is being consider for deployment of  Saratoga is for ground-based space sensors that need to move hugh data sets fast.
 Implementations will likely be in FPGAs.  See:
PAPER
Lloyd Wood, Charles Smith, Wesley Eddy, William D. Ivancic, Chris Jackson: "Taking Saratoga from Space-Based Ground Sensors to Ground-Based Space Sensors," 2011 IEEE Aerospace Conference, Big Sky Montana, March 5 - 12, 2011  file size 374 Kbyte
http://roland.grc.nasa.gov/~ivancic/papers_presentations/2011/z04_0201.pdf
PRESENTATION
(PDF<http://roland.grc.nasa.gov/%7Eivancic/papers_presentations/2011/IEEE%20Aerospace%202011%20Saratoga%20Space%20to%20Ground.pdf>) file size 2.3 Mbyte
 http://roland.grc.nasa.gov/~ivancic/papers_presentations/2011/IEEE%20Aerospace%202011%20Saratoga%20Space%20to%20Ground.pdf

---

From: <[email-masked]>
Date: Thu, 7 Jul 2011 18:55:45 +0100

As Will mentions, we have multiple separate implementations of this Saratoga protocol specified in this draft, and we've tested for interoperability.

We'd like to take this draft forward to experimental status, and believe that tsvwg is the best place to do that.

Further information on Saratoga (draft, papers, presentations, etc.) is available at:
http://personal.ee.surrey.ac.uk/Personal/L.Wood/dtn/saratoga

thanks,

Lloyd Wood
http://sat-net.com/L.Wood/CCSR

On 7 Jul 2011, at 18:30, Ivancic, William D. (GRC-RHN0) wrote:

> (PDF) file size 2.3 Mbyte