Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-00.txt

From: [email-masked]
Date: Fri, 10 Jan 2014 05:46:19 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transport Area Working Group Working Group of the IETF.

        Title           : Generic UDP Encapsulation for IP Tunneling
        Authors         : Edward Crabbe
                          Lucy Yong
                          Xiaohu Xu
	Filename        : draft-ietf-tsvwg-gre-in-udp-encap-00.txt
	Pages           : 11
	Date            : 2014-01-09

Abstract:
   This document describes a method of encapsulating arbitrary protocols
   within GRE and UDP headers.  In this encapsulation, the source UDP
   port may be used as an entropy field for purposes of loadbalancing
   while the payload protocol may be identified by the GRE Protocol
   Type.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-gre-in-udp-encap/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tsvwg-gre-in-udp-encap-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Joe Touch <[email-masked]>
Date: Tue, 21 Jan 2014 17:21:07 -0800

This doc should include some of the recommendations on GRE fragmentation 
summarized here:

draft-bonica-intarea-gre-mtu-03

Ron and I spent quite a while going through the details; it'd be useful 
to not repeat that work in this doc.

Joe

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Jan 2014 20:07:45 -0000

Joe,

That is a good point and a good pointer and we should reference it.

It looks like draft-bonica-intarea-gre-mtu is relatively well advanced, but it isn't an Int Area WG document. Can you let us know what the plans are (adopted by a WG, AD sponsored, etc.)?

Thanks,
Adrian

> -----Original Message-----
> From: tsvwg [mailto:[email-masked]] On Behalf Of Joe Touch
> Sent: 22 January 2014 01:21
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-00.txt
>

---

From: Joe Touch <[email-masked]>
Date: Wed, 22 Jan 2014 13:37:25 -0800

On 1/22/2014 12:07 PM, Adrian Farrel wrote:
> It looks like draft-bonica-intarea-gre-mtu is relatively well
> advanced, but it isn't an Int Area WG document. Can you let us know what
> the plans are (adopted by a WG, AD sponsored, etc.)?

Ron might give us an update on that. I don't know the current status 
except as indicated within the document.

Joe

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 23 Jan 2014 06:09:08 +0000

Folks,

I promise to update the draft before IETF 89.

                         Ron

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Wednesday, January 22, 2014 3:08 PM
> To: 'Joe Touch'
> Cc: [email-masked]; Ronald Bonica
> Subject: RE: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-
> 00.txt
> 
> Joe,
> 
> It looks like draft-bonica-intarea-gre-mtu is relatively well advanced,
> but it isn't an Int Area WG document. Can you let us know what the
> plans are (adopted by a WG, AD sponsored, etc.)?
> 
> Thanks,
> Adrian
> 
> > This doc should include some of the recommendations on GRE
> > fragmentation summarized here:
> >
> > Ron and I spent quite a while going through the details; it'd be
> > useful to not repeat that work in this doc.
> >
> > Joe
> >
> > >   This draft is a work item of the Transport Area Working Group
> > > Working Group
> > of the IETF.
> > >
> > > Please note that it may take a couple of minutes from the time of
> > > submission until the htmlized version and diff are available at
> tools.ietf.org.
> > >