Subject: [tsvwg] GRE/UDP and UDP Guidelines drafts: applicability terms

From: "Black, David" <[email-masked]>
Date: Mon, 11 Jan 2016 16:59:45 +0000

<WG chair hat ON>

Both the GRE/UDP draft and the UDP Guidelines draft are defining and using
terminology for a couple of applicability scenarios:

GRE/UDP, section 1.1
(https://tools.ietf.org/html/draft-ietf-tsvwg-gre-in-udp-encap-08):
- General IP Network:
   1) Use of GRE-in-UDP in a general IP network including the Internet,
- Well-Managed Operator IP Network
   2) Use of GRE-in-UDP in a well-managed operator IP network,
	[this is about traffic management to avoid congestion, and about
		nature of the network or applications that enables safe use
		of zero UDP checksum for IPv6.]

UDP Guidelines, section 3.6
(https://tools.ietf.org/html/draft-ietf-tsvwg-rfc5405bis-07#section-3.6):
- General Internet.  By default, IETF specifications target deployment
      on the general Internet.  Experience has shown that successful
      protocols developed in one specific context or for a particular
      application tends to become used in a wider range of contexts.
- Controlled Environment  A protocol/encapsulation/tunnel could be
      designed to be used only within a controlled environment.  For
      example, an application designed for use by a network operator
      might only be deployed within the network of that single network
      operator or on networks of an adjacent set of cooperating network
      operators.

There will be a new version of the GRE/UDP draft coming in the near
future, and it would be good to get alignment on the above terminology
in that version.

</WG chair hat ON>

<WG chair hat OFF>
The following are some initial "strawman" ideas for discussion, starting
from a view that we may not need a total of 4 terms:

a) "General IP Network" and "General Internet" appear to be the same
	concept, so we should pick one term.  My initial suggestion is
	to use "General Network" and make the need to design for the Internet
	clear in the definition of the scenario.  I'm concerned that use
	of the word "Internet" in the name of the could be misinterpreted
	as the scenario being public-Internet-only (NB: capitalized 'I').

b) Controlled Environment seems to be a superset of Well-Managed [IP]
	Network.  I'd suggest using roughly those two terms:
	- Controlled Environment in the UDP Guidelines draft
	- Well Managed Network in the GRE/UDP draft, as an example (or
		subset) of a Controlled Environment.  It feels like a good
		idea to also discuss this in the UDP Guidelines draft (which
		already has some text on this), but it's probably more productive
		to work out the details in the GRE/UDP draft first.  I also
		don't think the "IP" acronym is essential as part of the name.

Thoughts? Dead Cats/Rotten Tomatoes? :-).

Seriously, please do comment - the results of this discussion should be
reflected in the next version of the GRE/UDP draft, and we're likely to
see significant usage of this terminology in drafts that use UDP-based
encapsulations in the future.

</WG chair hat OFF>

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: Lucy yong <[email-masked]>
Date: Tue, 12 Jan 2016 16:30:37 +0000

It is good for GRE/UDP draft to align with UDP Guidelines. UDP Guideline describes two types of applicability that IETF applications utilizes UDP: General Internet and Controlled Environment. The controlled environment means within single administrative domain or bilaterally agreed connection between domains Controlled environment can be managed/operated to meet certain conditions, which the general Internet can't. 

For GRE/UDP draft, it is better to define a well-managed operator network as a controlled environment that can avoid congestion; then address zero-udp checksum for IPv6 as an additional special case for a well-managed operator network. 

Thanks,
Lucy

-----Original Message-----
From: tsvwg [mailto:[email-masked]] On Behalf Of Black, David
Sent: Monday, January 11, 2016 11:00 AM
To: [email-masked]
Subject: [tsvwg] GRE/UDP and UDP Guidelines drafts: applicability terms

<WG chair hat ON>

Both the GRE/UDP draft and the UDP Guidelines draft are defining and using terminology for a couple of applicability scenarios:

GRE/UDP, section 1.1

There will be a new version of the GRE/UDP draft coming in the near future, and it would be good to get alignment on the above terminology in that version.

</WG chair hat ON>

<WG chair hat OFF>
The following are some initial "strawman" ideas for discussion, starting from a view that we may not need a total of 4 terms:

Seriously, please do comment - the results of this discussion should be reflected in the next version of the GRE/UDP draft, and we're likely to see significant usage of this terminology in drafts that use UDP-based encapsulations in the future.

</WG chair hat OFF>

Thanks,
--David

---

From: Tom Herbert <[email-masked]>
Date: Tue, 12 Jan 2016 09:11:09 -0800

> For GRE/UDP draft, it is better to define a well-managed operator network as a controlled environment that can avoid congestion; then address zero-udp checksum for IPv6 as an additional special cas…
I tend to agree. A well managed network is reasonable for relaxing the
congestion control requirements, but does not necessarily imply the
zero UDP6 checksum is acceptable.

---

From: "Black, David" <[email-masked]>
Date: Tue, 12 Jan 2016 17:21:22 +0000

With <WG chair hat OFF> I likewise agree (sorry for not making this clear in
the initial message).  Thanks, --David

> > It is good for GRE/UDP draft to align with UDP Guidelines. UDP Guideline
> describes two types of applicability that IETF applications utilizes UDP:
> General Internet and Controlled Environment. The controlled environment means
> within single administrative domain or bilaterally agreed connection between
> domains Controlled environment can be managed/operated to meet certain
> conditions, which the general Internet can't.
> >
> > For GRE/UDP draft, it is better to define a well-managed operator network as
> a controlled environment that can avoid congestion; then address zero-udp
> checksum for IPv6 as an additional special case for a well-managed operator
> network.
> >
> > There will be a new version of the GRE/UDP draft coming in the near future,
> and it would be good to get alignment on the above terminology in that
> version.
> >
> > </WG chair hat ON>
> >
> > <WG chair hat OFF>
> reflected in the next version of the GRE/UDP draft, and we're likely to see
> significant usage of this terminology in drafts that use UDP-based