Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-09.txt

From: [email-masked]
Date: Tue, 26 Jan 2016 17:49:11 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transport Area Working Group Working Group of the IETF.

        Title           : GRE-in-UDP Encapsulation
        Authors         : Edward Crabbe
                          Lucy Yong
                          Xiaohu Xu
                          Tom Herbert
	Filename        : draft-ietf-tsvwg-gre-in-udp-encap-09.txt
	Pages           : 24
	Date            : 2016-01-26

Abstract:
   This document describes a method of encapsulating network protocol
   packets within GRE and UDP headers. In this encapsulation, the
   source UDP port can be used as an entropy field for purposes of load
   balancing, while the protocol of the encapsulated packet in the GRE
   payload is identified by the GRE Protocol Type. This document
   specifies requirements for two applicability scenarios for this
   encapsulation: (1) General Internet and (2) well-managed operator
   networks; less restrictive requirements apply to the latter scenario
   by comparison to the former.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tsvwg-gre-in-udp-encap/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-tsvwg-gre-in-udp-encap-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-gre-in-udp-encap-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Lucy yong <[email-masked]>
Date: Thu, 28 Jan 2016 23:41:41 +0000

Hi All,

This version has quite editing changes which were suggested by the chair (David Black) and better aligns with 5405bis. The draft specifies gre/udp tunnel usage in two environments: general Internet and well-managed operator network (WMON), and names the two applications as Default GRE-in-UDP Tunnel and WMON GRE-in-UDP Tunnel, respectively. It specifies the requirements for each type of tunnels. 

The draft further defines a well-managed operator network as of an IP network that is traffic-engineered and/or otherwise
managed (e.g., via use of traffic rate limiters) to avoid congestion. Under a well-managed operator network, a gre/udp tunnel is less restrictive comparing to be used in general Internet.

The draft has addressed all comments from the meetings and mails. One caviar is:

Use of UDP src port for entropy may impact with middlebox behavior (see draft). To address this conflict, the draft recommends:

   If a GRE-in-UDP tunnel is expected to pass a middlebox, to avoid the
   impact, the operator either disable UDP source port for entropy or
   configure the middlebox to deal with the UDP source port variation.

This operation can be done easily for a well-managed operator network. Maybe hard in general Internet. Like to get the community feedback if this will be a concern or not. If yes, what is the better alternative?

We like to thank David Black a lot for the detail review and suggestions. 

Thanks,
Lucy

-----Original Message-----
From: tsvwg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, January 26, 2016 7:49 PM
To: [email-masked]
Cc: [email-masked]
Subject: [tsvwg] I-D Action: draft-ietf-tsvwg-gre-in-udp-encap-09.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.