Subject: Re: [tsvwg] : Q: transport recommendations for "routing protocols"

From: <[email-masked]>
Date: Sat, 30 Jan 2016 06:08:21 +0000 (UTC)

To me, "message exchange" is at a higher layer than exchanging 
binary frames. It's XML interaction or better. 

If I understand you right, you want your own messaging, but 
you don't want to have to reinvent transport and reliable 
message delivery. But you'll still have to reinvent the messaging 
stack above that. Good luck with that. 

CoAP translates to http rather like WAP did, with binary 
substitution and proxying to http; limited binary 
http equivalence is of limited use. Adopting http as much 
as possible makes more sense to me longterm.

 Lloyd Wood [email-masked] http://about.me/lloydwood 

----- Original Message -----
From: Toerless Eckert <[email-masked]>
To: [email-masked]
Sent: Saturday, 30 January 2016, 11:47
Subject: Re: [tsvwg] : Q: transport recommendations for "routing protocols"

Thanks, Lloyd, but i was rather trying to avoid some undesired
layer on top of TCP/SCTP. Rather continue my own choice of (reliable)
message exchanges. Maybe i do not understand well why i need to
be interested in http-dtn... Can you maybe rephrase ?

Cheers
    Toerless

On Fri, Jan 29, 2016 at 05:24:26AM +0000, [email-masked] wrote:
> > And then the IOT space says TCP is bad, use CoAP, but then i don't even 
> > have messagee exchanges anymore but put would ahve to reinvent it on top 
> > of something like PUT/GET primitives... ? *sigh*
> 
> I know.
> 
> That's why we came up with http-dtn.
> 
> http://http-dtn.sourceforge.net/
> 
> Then you could do RESTful exchanges, M2M with SOAP etc., on top of HTTP/TCP.
>  
> Lloyd Wood [email-masked] http://about.me/lloydwood 
> 
> 
> 
> 
> ________________________________
> From: Toerless Eckert <[email-masked]>
> To: [email-masked] 
> Sent: Thursday, 28 January 2016, 10:36
> Subject: [tsvwg] : Q: transport recommendations for "routing protocols"
> 
> 
> Are there any drats/RFC that would give me guidance if i wanted to design
> packet exchanges hop-by-hop between eg: routers/switches, with traffic
> patterns lets say like a routing protocol.
> 
> I see even new protocols like Babel run on top of datagram and have
> all their own retransmission/ultimate-consistency schemes, and i was
> wondering what opinions TSVWG has about this.
> 
> Or let me turn this around: I'd rather like to build a protocol that
> just uses hop-by-hop TCP and not reinvent all the transport aspects
> that go along with that (including remote adjacencies/tunnels across stupidly
> bad internet adjacencies with jitter and loss). But the ongoing reality of
> protocols like this does not seem to indicate that there's any evolving
> wisdom that this would be a good thing.
> 
> And then the IOT space says TCP is bad, use CoAP, but then i don't even
> have messagee exchanges anymore but put would ahve to reinvent it on top
> of something like PUT/GET primitives... ? *sigh*
> 
> So, really wondering.
> 
> Thanks!

>     Toerless

-- 
---
Toerless Eckert, [email-masked]

---

From: Lloyd Wood <[email-masked]>
Date: Sat, 30 Jan 2016 19:34:51 +0000 (UTC)

blockquote, div.yahoo_quoted { margin-left: 0 !important; border-left:1px #715FFA solid !important;  padding-left:1ex !important; background-color:white !important; } Toeless,To me, "message exchange" is at a higher layer than exchanging binary frames. It's XML interaction or better.If I understand you right, you want your own messaging, but you don't want to have to reinvent transport and reliable message delivery. But you'll still have to reinvent the messaging stack above that. Good luck with that.

CoAP translates to http rather like WAP did, with binary substitution and proxying to http; limited binary http equivalence is of limited use. As such, it might do as well longterm as WAP did. Adopting http as much as possible makes more sense to me longterm, and that's what we were suggesting with http-dtn.Lloyd Wood [email-masked] http://about.me/lloydwood 

----- Original Message -----
From: Toerless Eckert <[email-masked]>
To: [email-masked]
Sent: Saturday, 30 January 2016, 11:47
Subject: Re: [tsvwg] : Q: transport recommendations for "routing protocols"

Cheers
    Toerless