Subject: [tsvwg] [Errata Verified] RFC3390 (4583)

From: RFC Errata System <[email-masked]>
Date: Sun, 3 Apr 2016 06:21:34 -0700 (PDT)

The following errata report has been verified for RFC3390,
"Increasing TCP's Initial Window". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3390&eid=4583

--------------------------------------
Status: Verified
Type: Technical

Reported by: Joe Touch <[email-masked]>
Date Reported: 2016-01-06
Verified by: Martin Stiemerling (IESG)

Section: 1.

Original Text
-------------
   This increased initial window is optional: a TCP MAY start with a
   larger initial window.  However, we expect that most general-purpose
   TCP implementations would choose to use the larger initial congestion
   window given in equation (1) above.

Corrected Text
--------------
   This increased initial window is optional: a TCP MAY start with a
   smaller initial window.  However, we expect that most general-purpose
   TCP implementations would choose to use the larger initial congestion
   window given in equation (1) above.

Notes
-----
The MAY allows use of values smaller than this document allows, not larger.

--------------------------------------
RFC3390 (draft-ietf-tsvwg-initwin-04)
--------------------------------------
Title               : Increasing TCP's Initial Window
Publication Date    : October 2002
Author(s)           : M. Allman, S. Floyd, C. Partridge
Category            : PROPOSED STANDARD
Source              : Transport Area Working Group
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: <[email-masked]>
Date: Tue, 5 Apr 2016 00:16:30 +0000 (UTC)

"a TCP MAY start"

a TCP what? session? flow? transaction? tunnel? DoS attack?

thanks

L.

 Lloyd Wood [email-masked] http://about.me/lloydwood 

----- Original Message -----
From: RFC Errata System <[email-masked]>
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Sent: Sunday, 3 April 2016, 23:21
Subject: [tsvwg] [Errata Verified] RFC3390 (4583)

Section: 1.

Original Text
-------------

Corrected Text
--------------

Notes
-----

---

From: Joe Touch <[email-masked]>
Date: Mon, 4 Apr 2016 17:25:49 -0700

In the context of the document, it's clear that this refers to starting
a connection.

I don't think this is ambiguous except in taken out of context, as below.

Joe