Subject: [tsvwg] Inconsistencies between TCP RFCs and Linux implementation (was Re: Comments on draft-touch-tsvwg-udp-option)s-08

From: Tom Herbert <[email-masked]>
Date: Tue, 25 Apr 2017 12:19:23 -0700

> You'll have to start by explaining all the code you've already taken, some
> of which (e.g., TCP use of experimental ports) is prohibited by existing
> RFCs.
>
Which experimental ports are being abused?

> Check out Linux processing of TCP option 253 and 254 and tell me you have a
> leg to stand on.
>
Linux code use option 254 for TCP fast open along with a magic number
to distinguish it from other use cases. Given that there is now
assigned option for fast open this use of the experimental option can
be removed.

Are there other inconsistencies that need investigation?

Tom

---

From: Yuchung Cheng <[email-masked]>
Date: Tue, 25 Apr 2017 12:39:51 -0700

> assigned option for fast open this use of the experimental option can
Linux TFO implementation faithfully follows
https://tools.ietf.org/html/rfc7413#page-22

---

From: Joe Touch <[email-masked]>
Date: Tue, 25 Apr 2017 13:11:28 -0700

> Which experimental ports are being abused?

The code I saw last summer had implementations that didn't use ExIDs.
That might have been corrected by now.

Joe

---

From: Joe Touch <[email-masked]>
Date: Tue, 25 Apr 2017 13:22:35 -0700

I found the details:

    - there are two experimental ports, not one (253 and 254)

    - RFC 6994 defines ExIDs as valid for both experimental ports (even
if a given RFC uses examples of only one)

    -  an Experimental RFC (TFO) is deployed as default enabled in the
wild beyond those actively involved in the experiment (see RFC2026)

Joe

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Tue, 25 Apr 2017 20:34:46 +0000

+TCPM

IMHO a 7413bis could target standards track. Of course, details would have to be sorted out.

Michael (with no hat on)

---

From: Joe Touch <[email-masked]>
Date: Tue, 25 Apr 2017 14:06:10 -0700

> IMHO a 7413bis could target standards track. Of course, details would have to be sorted out.

It certainly could, but until then, Linux has jumped the gun.

Joe