Subject: Re: [tsvwg] WGLC for draft-ietf-tsvwg-le-phb-04 as PS, closes 18 June 2018

From: Brian E Carpenter <[email-masked]>
Date: Sun, 3 Jun 2018 09:06:16 +1200

I believe that this draft is complete and correct and will
improve the situation. It belongs on the standards track.

One possible nit: I'm not sure what the current doctrine is,
but possibly the Abstract should mention that RFC3662 is made
obsolete.

Regards
   Brian Carpenter

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Fri, 15 Jun 2018 11:43:07 +0200

Hi,

this came somewhat early, but ok.

I'll submit a version -05 soon with the following planned changes:
- mentioning of scavenger service in title and/or abstract
- abstract mentioning obsolescence of RFC 3662
- clarification of congestion control recommendations
- update of webrtc-qos (still in MISSREF)
- update referral to RFC to be draft-ietf-tsvwg-iana-dscp-registry

Regards
 Roland

Am 01.06.2018 um 03:57 schrieb Black, David:
> This email announces a TSVWG Working Group Last Call (WGLC) on:
> 
>  
> 
>                 A Lower Effort Per-Hop Behavior (LE PHB)
> 
>                        draft-ietf-tsvwg-le-phb-04
> 
> https://datatracker.ietf.org/doc/draft-ietf-tsvwg-le-phb/
> 
>  
> 
> This draft is intended to become a Proposed Standard RFC.
> 
>  
> 
> This WGLC will run through the end of the day on Monday, June 18.
> 
>  
> 
> Comments should be sent to the [email-masked] <mailto:[email-masked]>
> list, although purely
> 
> editorial comments may be sent directly to the author. Please cc: the
> 
> WG chairs at [email-masked] <mailto:[email-masked]>  if
> you would like the chairs to
> 
> track such editorial comments as part of the WGLC process.
> 
>  
> 
> No IPR disclosures have been submitted directly on
> 
> draft-ietf-tsvwg-le-phb-04 .
> 
>  
> 
> Thanks,
> 
> David, Gorry and Wes
> 
> (TSVWG Co-Chairs)
> 
>  
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 15 Jun 2018 08:20:30 -0700

I'm not sure whether this draft should update RFC 4594 or not. RFC 4594 refers to RFC 3662, and calls the service class "Low Priority Data". I suspect that this draft should either update 4594 or 4594 needs an erratum pointing to the new RFC.

> On Jun 15, 2018, at 2:43 AM, Bless, Roland (TM) <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Black, David" <[email-masked]>
Date: Sat, 16 Jun 2018 00:01:23 +0000

<WG-char-hat=OFF>

Fred,
[writing as draft shepherd]

This draft currently updates RFC 4594, which I think is the right thing to
do because a visible technical change is involved, namely changing the
recommended DSCP for Low-Priority-Data traffic from CS1 to LE. 

That sort of change is beyond what an erratum ought to do, as CS1 was
the intended value of that recommended DSCP when RFC 4594 was
published, e.g., item 7 of the IESG Errata Processing Guidelines
(https://www.ietf.org/iesg/statement/errata-processing.html) advises: 

  Changes that modify the working of a protocol to something that
  might be different from the intended consensus when the document
  was approved should be either Hold for Document Update or Rejected. 

I read this as advising reviewers to not approve an erratum making that
change to the recommended DSCP for Low-Priority-Data traffic, which
suggests that the draft's current approach of updating RFC 4594 is the
better course of action to reflect the change in consensus on the DSCP
value to use.

Beyond this, I've read the -04 draft, and want to thank Roland for all of his
efforts and patience to produce a cogent draft on this topic.   I found a
couple of statements for which it would be helpful to cite informative
references:

[1] Section 3.  Applicability

   Some network providers
   keep link utilization below 50% to ensure that all traffic is
   forwarded without loss after rerouting caused by a link failure.

[2] Section 6.  Recommended DS Codepoint

   This particular codepoint was chosen due to measurements on the
   currently observable DSCP remarking behavior in the Internet.

The latter statement could cite presentation (slides) to TSVWG and/or
NMRG at an IETF meeting week.

> > - update of webrtc-qos (still in MISSREF)

Please do add that text - if the webrtc-qos draft is still in MISSREF at the
RFC Editor when the le-phb draft reaches the RFC Editor, the likely course
of action (with AD approval) will be to ask the RFC Editor to update the
webrtc-qos draft and remove the relevant update text from this draft. 

Adding that text now ensures that the WG has the opportunity to
review that text before it is applied, so that our AD and the IESG
can be assured that any applied update reflects TSVWG consensus.

Thanks, --David

> -----Original Message-----
> From: Fred Baker [mailto:[email-masked]]
> Sent: Friday, June 15, 2018 11:21 AM
> To: Bless, Roland (TM); Black, David
> Cc: [email-masked]
> Subject: Re: [tsvwg] WGLC for draft-ietf-tsvwg-le-phb-04 as PS, closes 18
> June 2018
> 
> I'm not sure whether this draft should update RFC 4594 or not. RFC 4594
> refers to RFC 3662, and calls the service class "Low Priority Data". I suspect
> that this draft should either update 4594 or 4594 needs an erratum pointing
> to the new RFC.
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 15 Jun 2018 18:14:14 -0700

> On Jun 15, 2018, at 5:01 PM, Black, David <[email-masked]> wrote:
> 
> <WG-char-hat=OFF>
> 
> Fred,
> This draft currently updates RFC 4594

OK, I obviously skipped a step. Let's discuss in Montreal. I'm happy to update 4594, especially with collaborators, but I'll bet this isn't the only update...

> , which I think is the right thing to