Subject: Re: [Unbearable] New and Updated I-Ds

From: John Bradley <[email-masked]>
Date: Sun, 5 Jul 2015 17:27:16 -0300

I haven’t seen any feedback to this on the list.

Are you prosing that we adopt this as a working group document?

If there are any issues with that, lets discuss it on the list before we get to Prague.

John B.

> On Jun 16, 2015, at 4:30 PM, Andrei Popov <[email-masked]> wrote:
> 
> Also, please feel free to use GitHub to track issues and make pull requests: https://github.com/TokenBinding/Internet-Drafts <https://github.com/TokenBinding/Internet-Drafts>
>  
> Now that we have TBNEGO I-D, I’ve closed a couple of issues related to the use of ALPN.
>  
> Cheers,
>  
> Andrei
>  
> From: Andrei Popov 
> Sent: Friday, May 29, 2015 4:54 PM
> To: [email-masked] <mailto:[email-masked]>
> Subject: New and Updated I-Ds
>  
> In Dallas we agreed to define a new TLS extension for Token Binding key parameters negotiation, instead of using ALPN.
>  
> Today I’ve submitted TLS Extension for Token Binding Protocol Negotiation  I-D: https://datatracker.ietf.org/doc/draft-popov-tokbind-negotiation/ <https://datatracker.ietf.org/doc/draft-popov-tokbind-negotiation/>
>  
> I have also updated the Token Binding Protocol I-D: https://tools.ietf.org/html/draft-ietf-tokbind-protocol-01 <https://tools.ietf.org/html/draft-ietf-tokbind-protocol-01>
> The updated version has the following changes:
> -          Removed ALPN negotiation text;
> -          Added a Security Considerations sub-section discussing Token Binding key sharing between applications;
> -          Minor edits, nits, etc.
>  
> Comments are very welcome!
>  
> Cheers,
>  
> Andrei
> _______________________________________________
> Unbearable mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/unbearable <https://www.ietf.org/mailman/listinfo/unbearable>

---

From: Andrei Popov <[email-masked]>
Date: Mon, 6 Jul 2015 16:32:19 +0000

Ø  Are you prosing that we adopt this as a working group document?
https://datatracker.ietf.org/doc/draft-popov-tokbind-negotiation/ is written in support of WG’s decision in Dallas to use a new TLS extension to negotiate Token Binding parameters (instead of ALPN). I hope that we can continue discussing this I-D on the mailing list and converge in Prague. If the WG agrees that this is the right approach overall, I think we should proceed with a call for adoption, with full expectation that the document will keep evolving.

Ø  I haven’t seen any feedback to this on the list.
There has been some discussion:
https://mailarchive.ietf.org/arch/msg/unbearable/R5uakIeHnd2dYMzdY1zToHbxBKo - the proposal to harmonize algorithm IDs between TBNEGO and TBPROTO;
https://mailarchive.ietf.org/arch/msg/unbearable/0w8_F0H63TWpAb9x_V8SorZT0lg - among others, an idea that multiple TB parameter sets could be negotiated, e.g. the server could return both rsa2048_pkcs1.5_sha256(0) and  ecdsap256_sha256.
On both of these, I’d like to see a degree of consensus from the WG, before making the changes.

Ø  If there are any issues with that, lets discuss it on the list before we get to Prague.
Yes, this would be awesome!

Cheers,

Andrei

From: John Bradley [mailto:[email-masked]]
Sent: Sunday, July 5, 2015 1:27 PM
To: Andrei Popov
Cc: [email-masked]
Subject: Re: [Unbearable] New and Updated I-Ds

John B.

On Jun 16, 2015, at 4:30 PM, Andrei Popov <[email-masked]<mailto:[email-masked]>> wrote:

Also, please feel free to use GitHub to track issues and make pull requests: https://github.com/TokenBinding/Internet-Drafts

Cheers,

Andrei

From: Andrei Popov
Sent: Friday, May 29, 2015 4:54 PM
To: [email-masked]<mailto:[email-masked]>
Subject: New and Updated I-Ds

Today I’ve submitted TLS Extension for Token Binding Protocol Negotiation  I-D: https://datatracker.ietf.org/doc/draft-popov-tokbind-negotiation/

I have also updated the Token Binding Protocol I-D: https://tools.ietf.org/html/draft-ietf-tokbind-protocol-01

Cheers,

Andrei
_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable

---

From: Karthikeyan Bhargavan <[email-masked]>
Date: Mon, 6 Jul 2015 19:32:24 -0400

This has probably been discussed before, and if so, please excuse the question. (I couldn’t easily find an answer in the archives.)

The current proposals bind tokens to the tls-unique channel binding, which corresponds to a specific handshake.
This means that when an authenticated session is resumed on a new connection, a new token would need to
be issued (so probably the user would have to authenticate again.) Is this intended?

Resumption is not going away anytime soon, and I’ve been told that a majority of web connections use resumption,
so reissuing tokens for a majority of new connections seems excessive. Would there be interest in using a channel
binding that persists across resumption?

Best,
Karthik

> On 06 Jul 2015, at 12:32, Andrei Popov <[email-masked]> wrote:
> 
> https://datatracker.ietf.org/doc/draft-popov-tokbind-negotiation/ <https://datatracker.ietf.org/doc/draft-popov-tokbind-negotiation/> is written in support of WG’s decision in Dallas to use a new TLS extension to negotiate Token Binding parameters (instead of ALPN). I hope that we can continue discussing this I-D on the mailing list and converge in Prague. If the WG agrees that this is the right approach overall, I think we should proceed with a call for adoption, with full expectation that the document will keep evolving.
> 
> https://mailarchive.ietf.org/arch/msg/unbearable/R5uakIeHnd2dYMzdY1zToHbxBKo <https://mailarchive.ietf.org/arch/msg/unbearable/R5uakIeHnd2dYMzdY1zToHbxBKo> - the proposal to harmonize algorithm IDs between TBNEGO and TBPROTO;
> https://mailarchive.ietf.org/arch/msg/unbearable/0w8_F0H63TWpAb9x_V8SorZT0lg <https://mailarchive.ietf.org/arch/msg/unbearable/0w8_F0H63TWpAb9x_V8SorZT0lg> - among others, an idea that multiple TB parameter sets could be negotiated, e.g. the server could return both rsa2048_pkcs1.5_sha256(0) and  ecdsap256_sha256.
> On Jun 16, 2015, at 4:30 PM, Andrei Popov <[email-masked] <mailto:[email-masked]>> wrote:
> 
> [email-masked]

---

From: Andrei Popov <[email-masked]>
Date: Mon, 6 Jul 2015 23:44:44 +0000

Hi Karthik,

Ø  The current proposals bind tokens to the tls-unique channel binding, which corresponds to a specific handshake.

Ø  This means that when an authenticated session is resumed on a new connection, a new token would need to

Ø  be issued (so probably the user would have to authenticate again.) Is this intended?

No, the current proposals bind the token to a long-lived persistent key, so the token remains valid across TLS sessions and TLS connections.

Cheers,

Andrei

From: Karthikeyan Bhargavan [mailto:[email-masked]]
Sent: Monday, July 6, 2015 4:32 PM
To: Andrei Popov
Cc: John Bradley; [email-masked]
Subject: Re: [Unbearable] New and Updated I-Ds

Best,
Karthik

Cheers,

Andrei

From: John Bradley [mailto:[email-masked]]
Sent: Sunday, July 5, 2015 1:27 PM
To: Andrei Popov
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Unbearable] New and Updated I-Ds

John B.

Cheers,

Andrei

From: Andrei Popov

Cheers,

Andrei