Subject: Re: [Unbearable] Should Token Binding support non-TLS applications?

From: =JeffH <[email-masked]>
Date: Wed, 24 Feb 2016 13:29:52 -0800

Andrei replied:
 >MT said:
 >> Avoiding an abstraction layer at this point [i.e. not
 >> generalizing -tokbind-protocol] avoids having to do all
 >> that work and completely avoids the risk that we mess it up.
 >
 > I think that publishing TBPROTO and TBNEGO in their current form would
 > not preclude future documents describing the use of the Token Binding
 > protocol with e.g. Kerberos or DTLS. And Martin's point about delaying
 > the generalization until we have a few adaptations to various STLs makes
 > sense to me.

Ok, so given that the assessment over on the TLS list is that RFC5705 keying 
material exporter, which -tokbind-protocol (aka TBPROTO) normatively depends 
upon, is not compatible with TLS 1.3..

   https://www.ietf.org/mail-archive/web/tls/current/msg19329.html

..(if folks disagree, they perhaps ought to post to that thread), then it 
seems that we ought to do one of two things with -tokbind-protocol..

1. clarify that -tokbind-protocol is applicable to TLS 1.2 and earlier only, or,

2. wait for TLS 1.3 exporter to get defined and either add normative 
dependence just to the latter and otherwise keep spec TLS-specific (or 
generalize it for other underlying secure transports).

Doing #1 seems likely to get the present set of tokbind specs published sooner.

HTH,

=JeffH

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 25 Feb 2016 05:33:02 +0800

On Thu, Feb 25, 2016 at 5:29 AM, =JeffH <[email-masked]>
wrote:

> Ok, so given that the assessment over on the TLS list is that RFC5705
> keying material exporter, which -tokbind-protocol (aka TBPROTO) normatively
> depends upon, is not compatible with TLS 1.3..
>

I'm not quite following the problem here. When we are finished with TLS 1.3
we
will have defined an exporter for it and then Tokbind will be usable with
it.
Until TLS 1.3 is finished you couldn't use Tokbind it with TLS 1.3 anyway.
So
referring to the TLS 1.3 draft and saying we'll need exporters from there
seems straightforward, and the AD should be able to handle the mechanics.

-Ekr

Doing #1 seems likely to get the present set of tokbind specs published
> sooner.
>
> HTH,
>
>
> =JeffH
>
>
>
>
>
>
>
> _______________________________________________
> Unbearable mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/unbearable
>

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Feb 2016 13:52:33 -0800

> seems straightforward, and the AD should be able to handle the mechanics.

Yes, this is right.  We can't ship 1.3 without fixing exporters.

You could avoid referring to TLS 1.3 and simply allow TLS 1.3 to
obsolete 1.2 and 5705 in due course.  If you were concerned about time
frame.

---

From: Andrei Popov <[email-masked]>
Date: Wed, 24 Feb 2016 22:03:48 +0000

Ø  When we are finished with TLS 1.3 we

Ø  will have defined an exporter for it and then Tokbind will be usable with it.
Yes, this was my understanding too. I don’t see a reason to say TBPROTO is for TLS <= 1.2 only.

From: Unbearable [mailto:[email-masked]] On Behalf Of Eric Rescorla
Sent: Wednesday, February 24, 2016 1:33 PM
To: =JeffH <[email-masked]>
Cc: IETF Tokbind WG <[email-masked]>
Subject: Re: [Unbearable] Should Token Binding support non-TLS applications?

On Thu, Feb 25, 2016 at 5:29 AM, =JeffH <[email-masked]<mailto:[email-masked]>> wrote:
> the generalization until we have a few adaptations to various STLs makes

Ok, so given that the assessment over on the TLS list is that RFC5705 keying material exporter, which -tokbind-protocol (aka TBPROTO) normatively depends upon, is not compatible with TLS 1.3..

  https://www.ietf.org/mail-archive/web/tls/current/msg19329.html<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmail-archive%2fweb%2ftls%2fcurrent%2fmsg19329.html&data=01%7c01%7cAndrei.Popov%40microsoft.com%7cbebe90a20b074d7ef10e08d33d623051%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=yBJhIbSO%2fSRYXzsSU2aLRpybR%2bjVyniC%2f0ZncTP017U%3d>

..(if folks disagree, they perhaps ought to post to that thread), then it seems that we ought to do one of two things with -tokbind-protocol..

2. wait for TLS 1.3 exporter to get defined and either add normative dependence just to the latter and otherwise keep spec TLS-specific (or generalize it for other underlying secure transports).

I'm not quite following the problem here. When we are finished with TLS 1.3 we
will have defined an exporter for it and then Tokbind will be usable with it.
Until TLS 1.3 is finished you couldn't use Tokbind it with TLS 1.3 anyway. So
referring to the TLS 1.3 draft and saying we'll need exporters from there
seems straightforward, and the AD should be able to handle the mechanics.

-Ekr

HTH,

=JeffH

_______________________________________________
Unbearable mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/unbearable<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2funbearable&data=01%7c01%7cAndrei.Popov%40microsoft.com%7cbebe90a20b074d7ef10e08d33d623051%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=xwZYwwR9zyTghhAVx%2bIgbeJ273GngB5HfjV3XjgH2rI%3d>

---

From: Dirk Balfanz <[email-masked]>
Date: Thu, 25 Feb 2016 07:32:09 +0000

+1

Dirk.

On Wed, Feb 24, 2016 at 2:04 PM Andrei Popov <[email-masked]>
wrote:

> *From:* Unbearable [mailto:[email-masked]] *On Behalf Of *Eric
> Rescorla
> *Sent:* Wednesday, February 24, 2016 1:33 PM
> *To:* =JeffH <[email-masked]>
> *Cc:* IETF Tokbind WG <[email-masked]>
>
>
> *Subject:* Re: [Unbearable] Should Token Binding support non-TLS
> applications?
>
>
>
>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmail-archive%2fweb%2ftls%2fcurrent%2fmsg19329.html&data=01%7c01%7cAndrei.Popov%40microsoft.com%7cbebe90a20b074d7ef10e08d33d623051%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=yBJhIbSO%2fSRYXzsSU2aLRpybR%2bjVyniC%2f0ZncTP017U%3d>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2funbearable&data=01%7c01%7cAndrei.Popov%40microsoft.com%7cbebe90a20b074d7ef10e08d33d623051%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=xwZYwwR9zyTghhAVx%2bIgbeJ273GngB5HfjV3XjgH2rI%3d>
>