Subject: [Unbearable] triple handshake admonitions -- pare 'em down to one ?

From: "Hodges, Jeff" <[email-masked]>
Date: Wed, 9 Mar 2016 00:22:10 +0000

The admonition wrt "triple handshake vuln" appears four times in the three specs -- twice in TBPROTO, once each in TBNEGO and HTTPSTB.

Yes, it is important, but arguably, it only needs to appear in TBNEGO because it is TBNEGO that defines the TLS session establishment.  The other specs are at the next layer up and refer to TBNEGO wrt TLS establishment.

If y'all really want to keep the admonition in all three specs, then I'd pare TBPROTO down to one occurance, in security considerations.

HTH,

=JeffH

> grep -Hi "triple handshake" *xml

draft-ietf-tokbind-https-02.xml:      <section title="Triple Handshake Vulnerability in TLS">

draft-ietf-tokbind-https-02.xml:          TLS Token Binding. The triple handshake attack <xref

draft-ietf-tokbind-https-02.xml:          <title>Triple Handshakes and Cookie Cutters: Breaking and Fixing Authentication over

draft-ietf-tokbind-negotiation-02.xml:      <section title="Triple Handshake Vulnerability in TLS 1.2 and Older TLS Versions">

draft-ietf-tokbind-negotiation-02.xml:        associate a TLS connection with a Token Binding. The triple handshake attack

draft-ietf-tokbind-negotiation-02.xml:          <title>Triple Handshakes and Cookie Cutters: Breaking and Fixing Authentication over

draft-ietf-tokbind-protocol-04.xml:        <t>The triple handshake vulnerability in TLS 1.2 and older TLS versions affects the security

draft-ietf-tokbind-protocol-04.xml:      <section title="Triple Handshake Vulnerability in TLS 1.2 and Older TLS Versions">

draft-ietf-tokbind-protocol-04.xml:        TLS connection with a Token Binding. The triple handshake attack

draft-ietf-tokbind-protocol-04.xml:          <title>Triple Handshakes and Cookie Cutters: Breaking and Fixing Authentication over

---

From: Andrei Popov <[email-masked]>
Date: Fri, 25 Mar 2016 18:28:17 +0000

I don't feel strongly about this, but perhaps section 4 "Establishing a TLS Token Binding" would not be complete without mentioning the EMS requirement, among others. If folks think that reducing the repetition of the EMS mantra is important, I'll remove it from section 4.

Cheers,

Andrei

From: Unbearable [mailto:[email-masked]] On Behalf Of Hodges, Jeff
Sent: Tuesday, March 8, 2016 4:22 PM
To: Tokbind WG <[email-masked]>
Subject: [Unbearable] triple handshake admonitions -- pare 'em down to one ?

HTH,

=JeffH