Subject: [Unbearable] Treating Token Binding ID as an opaque byte sequence

From: Mike Jones <[email-masked]>
Date: Fri, 1 Jul 2016 22:00:08 +0000

In a private conversation with Andrei, we talked about adding a note to the spec recommending that Token Binding APIs treat the Token Binding ID as an opaque byte sequence, rather than as the structure defined in the protocol (type byte, followed by public key representation).  Doing so would allow the Token Binding ID contents to change in future protocol versions without breaking applications.

This is a reminder to add this note to the spec.

                                                                -- Mike

---

From: [email-masked]
Date: Mon, 04 Jul 2016 09:57:41 -0600

Quoting Mike Jones <[email-masked]>:

> In a private conversation with Andrei, we talked about adding a note  
> to the spec recommending that Token Binding APIs treat the Token  
> Binding ID as an opaque byte sequence, rather than as the structure  
> defined in the protocol (type byte, followed by public key  
> representation).  Doing so would allow the Token Binding ID contents  
> to change in future protocol versions without breaking applications.
>

submitted as: https://github.com/TokenBinding/Internet-Drafts/issues/48