Subject: [Unbearable] Attested TLS Token Binding

From: "Mandyam, Giridhar" <[email-masked]>
Date: Tue, 7 Mar 2017 22:02:30 +0000

Hello Tokbind WG,

Please note that the latest version of "Attested TLS Token Binding" has been uploaded and is available at https://datatracker.ietf.org/doc/draft-mandyam-tokbind-attest/.

The document has been simplified from the first version.  Among the major changes are:

a. A proposed tokbind.extension to carry attestation in the form of a CBOR object.  
b. Two initial attestation types:  packed (see the W3C Web Authentication API specification) and TPM (as defined by the Trusted Computing Group).  Attestation types should be extensible, but currently no registry is proposed in the document.  We are open to suggestions.
c. Removal of the attestation from the TLS handshake.  We do believe there are use cases for accessing the attestation in the clear, but this specification may not be the appropriate place for such a feature.

Look forward to any feedback you all may have.

-Giri Mandyam

---

From: Giridhar Mandyam <[email-masked]>
Date: Sat, 18 Mar 2017 21:00:15 +0000

Hello Tokbind WG,

Just a reminder to please provide reviews on this I.-D.

Thanks,
-Giri Mandyam

-----Original Message-----
From: Unbearable [mailto:[email-masked]] On Behalf Of Mandyam, Giridhar
Sent: Tuesday, March 07, 2017 2:03 PM
To: [email-masked]
Subject: [Unbearable] Attested TLS Token Binding

Hello Tokbind WG,

-Giri Mandyam

_______________________________________________
Unbearable mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/unbearable