Subject: [Unbearable] Alexey Melnikov's No Objection on draft-ietf-tokbind-negotiation-13: (with COMMENT)

From: Alexey Melnikov <[email-masked]>
Date: Thu, 10 May 2018 07:30:19 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-tokbind-negotiation-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-tokbind-negotiation/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

   struct {
       uint8 major;
       uint8 minor;
   } TB_ProtocolVersion;

I think naming them "major" and "minor" is misleading, because it doesn't
actually mean anything.

Lack of description of how versionning is to be used makes me sad, but I
understand that this was discussed in the WG.

---

From: Andrei Popov <[email-masked]>
Date: Thu, 10 May 2018 18:31:28 +0000

In the next revision, I will add text to explicitly say that "major" and "minor" are for human convenience only and carry no protocol significance.

Thanks,

Andrei

-----Original Message-----
From: Alexey Melnikov <[email-masked]> 
Sent: Thursday, May 10, 2018 7:30 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; John Bradley <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Alexey Melnikov's No Objection on draft-ietf-tokbind-negotiation-13: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&data=02%7C01%7CAndrei.Popov%40microsoft.com%7C5d8b9eb9ce2c426f27a708d5b6828f46%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636615594220695716&sdata=E467o6WxQHxlvE2GxubCyHC7SyuGFhW7T9ET4YrI4hQ%3D&reserved=0
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tokbind-negotiation%2F&data=02%7C01%7CAndrei.Popov%40microsoft.com%7C5d8b9eb9ce2c426f27a708d5b6828f46%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636615594220695716&sdata=6O%2BlA0ToaiGEjQdqAR1nEOt7nEFo1RbXMjLinFFpx5k%3D&reserved=0

   struct {
       uint8 major;
       uint8 minor;
   } TB_ProtocolVersion;

I think naming them "major" and "minor" is misleading, because it doesn't actually mean anything.

Lack of description of how versionning is to be used makes me sad, but I understand that this was discussed in the WG.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 10 May 2018 19:56:28 -0500

Hi, Andrei,

On Thu, May 10, 2018 at 1:31 PM, Andrei Popov <[email-masked]>
wrote:

> In the next revision, I will add text to explicitly say that "major" and
> "minor" are for human convenience only and carry no protocol significance.
>

So this is only used to tell humans how big a change is, in relative terms?

That works for me (and I had chimed in about major/minor versions during
IESG evaluation, so thank you).

Spencer

Thanks,
> Cc: [email-masked]; John Bradley <
> [email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> Please refer to https://na01.safelinks.protection.outlook.com/?url=
> https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-
> criteria.html&data=02%7C01%7CAndrei.Popov%40microsoft.com%
> 7C5d8b9eb9ce2c426f27a708d5b6828f46%7C72f988bf86f141af91ab2d7cd011
> db47%7C1%7C0%7C636615594220695716&sdata=E467o6WxQHxlvE2GxubCyHC7SyuGFh
> W7T9ET4YrI4hQ%3D&reserved=0
> https://na01.safelinks.protection.outlook.com/?url=
> https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-
> tokbind-negotiation%2F&data=02%7C01%7CAndrei.Popov%40microsoft.com%
> 7C5d8b9eb9ce2c426f27a708d5b6828f46%7C72f988bf86f141af91ab2d7cd011
> db47%7C1%7C0%7C636615594220695716&sdata=6O%2BlA0ToaiGEjQdqAR1nEOt7nEFo1Rb
> XMjLinFFpx5k%3D&reserved=0
>
>
>

---

From: Andrei Popov <[email-masked]>
Date: Fri, 11 May 2018 01:17:33 +0000

Hi, Spencer,

Correct, there is no special treatment of major/minor version octets in the Token Binding protocol.
No presumption of interoperability between clients and servers that support different “minor” versions.
(Similarly, a client that only supports TLS 1.1 cannot connect to a server that only supports TLS 1.2.)
No requirement to support previous “minor” versions.

But it has been convenient to use versions 0.<draft revision> for TB Internet-Draft implementations.
It also seems intuitive that the first standard version will be 1.0.

Cheers,

Andrei
From: Spencer Dawkins at IETF <[email-masked]>
Sent: Thursday, May 10, 2018 5:56 PM
To: Andrei Popov <[email-masked]>
Cc: Alexey Melnikov <[email-masked]>; The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Alexey Melnikov's No Objection on draft-ietf-tokbind-negotiation-13: (with COMMENT)

Hi, Andrei,

On Thu, May 10, 2018 at 1:31 PM, Andrei Popov <[email-masked]<mailto:[email-masked]>> wrote:
In the next revision, I will add text to explicitly say that "major" and "minor" are for human convenience only and carry no protocol significance.

That works for me (and I had chimed in about major/minor versions during IESG evaluation, so thank you).

Spencer

Thanks,

Andrei

-----Original Message-----
From: Alexey Melnikov <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, May 10, 2018 7:30 AM
To: The IESG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; John Bradley <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Alexey Melnikov's No Objection on draft-ietf-tokbind-negotiation-13: (with COMMENT)

   struct {
       uint8 major;
       uint8 minor;
   } TB_ProtocolVersion;