Subject: [Unbearable] Warren Kumari's No Objection on draft-ietf-tokbind-negotiation-12: (with COMMENT)

From: Warren Kumari <[email-masked]>
Date: Wed, 09 May 2018 08:04:56 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-tokbind-negotiation-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-tokbind-negotiation/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Please also see Will LIU's OpsDir review here:
https://datatracker.ietf.org/doc/review-ietf-tokbind-negotiation-10-opsdir-lc-liu-2017-12-04/
It suggests a simple change which will remove confusion/ambiguity.

The document says (in the Introduction):
"The negotiation of the Token Binding protocol and key parameters in
combination with TLS 1.3 and later versions is beyond the scope of this
document."

How hard would it be to make it work with TLS 1.3? Actually, what part of it
doesn't already? (I'm guessing I'm missing something super-obvious)...

---

From: Nick Harper <[email-masked]>
Date: Wed, 9 May 2018 11:00:59 -0700

It's pretty easy to make it work with TLS 1.3:
https://datatracker.ietf.org/doc/draft-ietf-tokbind-tls13/ is a short draft
that explains how. The reason for the split was because of document timing,
specifically not wanting to hold up the Token Binding drafts on publication
of TLS 1.3.

On Wed, May 9, 2018 at 8:04 AM, Warren Kumari <[email-masked]> wrote:

> _______________________________________________
> Unbearable mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/unbearable
>

---

From: Andrei Popov <[email-masked]>
Date: Wed, 9 May 2018 18:07:48 +0000

Hi Warren,

Thanks for the review. Will make the change suggested by Will Liu in the next revision.

TLS 1.3 is sufficiently different that the TB WG decided to specify the use of TB with TLS 1.3 in a separate document.

Cheers,

Andrei

-----Original Message-----
From: Warren Kumari <[email-masked]> 
Sent: Wednesday, May 9, 2018 8:05 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; John Bradley <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Warren Kumari's No Objection on draft-ietf-tokbind-negotiation-12: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&data=02%7C01%7CAndrei.Popov%40microsoft.com%7Cef4f94d5157a4ae1bae408d5b5be3b3c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636614751011830665&sdata=5wBkGrbBbh7jpzoGH3KYtPuE6CN4ls4klh4HkT1Xy7E%3D&reserved=0
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-tokbind-negotiation%2F&data=02%7C01%7CAndrei.Popov%40microsoft.com%7Cef4f94d5157a4ae1bae408d5b5be3b3c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636614751011830665&sdata=RGE3aQGPO7BxwbQo4bZ0l8utz3zDE%2Fm%2F8lVXd7tqMQA%3D&reserved=0

Please also see Will LIU's OpsDir review here:
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Freview-ietf-tokbind-negotiation-10-opsdir-lc-liu-2017-12-04%2F&data=02%7C01%7CAndrei.Popov%40microsoft.com%7Cef4f94d5157a4ae1bae408d5b5be3b3c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636614751011830665&sdata=mZ70PwPXXG78PxCvhtKN0XxvGnNIwZA98waxfxr44po%3D&reserved=0
It suggests a simple change which will remove confusion/ambiguity.

The document says (in the Introduction):
"The negotiation of the Token Binding protocol and key parameters in combination with TLS 1.3 and later versions is beyond the scope of this document."

How hard would it be to make it work with TLS 1.3? Actually, what part of it doesn't already? (I'm guessing I'm missing something super-obvious)...

---

From: Warren Kumari <[email-masked]>
Date: Thu, 10 May 2018 16:45:46 +0000

On Wed, May 9, 2018 at 2:07 PM Andrei Popov <[email-masked]>
wrote:

> TLS 1.3 is sufficiently different that the TB WG decided to specify the
> use of TB with TLS 1.3 in a separate document.
>
> Cheers,
>

​Okey doeky, WFM.
W​

> Cc: [email-masked]; John Bradley <
> [email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Warren Kumari's No Objection on
> draft-ietf-tokbind-negotiation-12: (with COMMENT)
>
> Please refer to
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&data=02%7C01%7CAndrei.Popov%40microsoft.com%7Cef4f94d5157a4ae1bae408d5b5be3b3c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636614751011830665&sdata=5wBkGrbBbh7jpzoGH3KYtPuE6CN4ls4klh4HkT1Xy7E%3D&reserved=0
> How hard would it be to make it work with TLS 1.3? Actually, what part of
> it doesn't already? (I'm guessing I'm missing something super-obvious)...
>
>
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf