Subject: [urn] NID syntax

From: "Svensson, Lars" <[email-masked]>
Date: Wed, 21 Dec 2016 12:14:50 +0000

All,

The syntax for formal URN namespaces declares:

[[
[...]
4. It MUST NOT start with ALPHA ALPHA "-", i. e. any string consisting of two letters followed by one hyphen".
5. It MUST NOT start with the string "xn--" or any other string consisting of two letters followed by two hyphens. [...]
]]

To me this feels redundant. If it must not start with ALPHA ALPHA "-", "any other string consisting of two letters followed by two hyphens" is forbidden already. I think we could conflate those two to:

[[
4. It MUST NOT start with any string consisting of two letters followed by one or two hyphens. Such strings are reserved for potential representation of DNS A-labels and similar strings in the future [RFC5890].
]]

Or are ALPHA ALPHA "-"-Strings reserved for something else? If so, then we should explain why those are forbidden, too.

Best,

Lars

*** Lesen. Hören. Wissen. Deutsche Nationalbibliothek *** 
-- 
Dr. Lars G. Svensson
Deutsche Nationalbibliothek
Informationsinfrastruktur
Adickesallee 1
60322 Frankfurt am Main
Telefon: +49 69 1525-1752
Telefax: +49 69 1525-1799
mailto:[email-masked] 
http://www.dnb.de

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 22 Dec 2016 12:24:29 -0700

> Or are ALPHA ALPHA "-"-Strings reserved for something else? If so, then we should explain why those are forbidden, too.

I think this is clearer (combining the relevant rules and the text that 
is currently shown after the bulleted list:

    3.  It MUST be more than two characters long and it MUST NOT start
        with ALPHA ALPHA "-", i.e., any string consisting of two letters
        followed by one hyphen; such strings are reserved for potential
        use as NIDs based on ISO alpha-2 country codes [ISO.3166-1] for
        eventual national registrations of URN namespaces (however, the
        definition and scoping of rules for allocation of responsibility
        for such country-code-based URN namespaces are beyond the scope
        of this document).

Peter

---

From: John C Klensin <[email-masked]>
Date: Tue, 27 Dec 2016 19:31:37 -0500

--On Thursday, December 22, 2016 12:24 PM -0700 Peter
Saint-Andre <[email-masked]> wrote:

>> 4. It MUST NOT start with ALPHA ALPHA "-", i. e. any string
>> consisting of two letters followed by one hyphen". 5. It MUST
>> NOT start with the string "xn--" or any other string
>> consisting of two letters followed by two hyphens. [...] ]]
>> 
>> To me this feels redundant. If it must not start with ALPHA
>> ALPHA "-", "any other string consisting of two letters
>> followed by two hyphens" is forbidden already. I think we
>> could conflate those two to:
>> 
>> [[
>> 4. It MUST NOT start with any string consisting of two
>> letters followed by one or two hyphens. Such strings are
>> reserved for potential representation of DNS A-labels and
>> similar strings in the future [RFC5890]. ]]
>> 
>> Or are ALPHA ALPHA "-"-Strings reserved for something else?
>> If so, then we should explain why those are forbidden, too.
> 
> I think this is clearer (combining the relevant rules and the
> text that is currently shown after the bulleted list:
> 
> 	    3.  It MUST be more than two characters long and it
> 	MUST NOT start with ALPHA ALPHA "-", i.e., any string
> 	consisting of two letters followed by one hyphen; such
> 	strings are reserved for potential use as NIDs based on
> 	ISO alpha-2 country codes [ISO.3166-1] for eventual
> 	national registrations of URN namespaces (however, the
> 	definition and scoping of rules for allocation of
> 	responsibility for such country-code-based URN
> 	namespaces are beyond the scope of this document).

That seems to me much better, but doesn't eliminate Lars's
concern about redundancy.  I've tentatively merged bullet 4 into
bullet 3, making it clear that the latter is a special case,
with an additional motivation, of the ' ALPHA ALPHA "-"' rule.

    john

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 28 Dec 2016 18:29:17 -0700

> with an additional motivation, of the ' ALPHA ALPHA "-"' rule.

Thanks. I don't mind a bit of redundancy here given that there are 
different reasons for the two rules, but if you've been able to artfully 
merge the two bullet points then so much the better.

Peter