Subject: Re: [urn] URN review team coordination

From: [email-masked] (Dale R. Worley)
Date: Mon, 23 Apr 2018 23:04:23 -0400

>> 3. The status of the "ITU" registration request is unclear to me - I've
>> seen nothing further since November:
>> 
>> https://www.ietf.org/mail-archive/web/urn/current/msg03832.html

My apologies for not reviewing this document before now.

draft-itu-urn looks quite fine to me, with this one consideration:  By
default, two URNs within a namespace are "equivalent" only if they are
exactly identical after the following transformations:

(1) the initial "urn:itu" part is converted to lower-cse
(2) in every %-encoding "%xx", the last two characters are converted to
upper case if they are letters

In this case, it means that the "ITU-Sector" component must be in lower
case, and the following portion of the URN is case-sensitive (except
within %-encodings).

If you want more lenient rules for URN equivalence, they need to be
spelled out in the registration template.

Dale

---

From: "OTA, Hiroshi" <[email-masked]>
Date: Fri, 27 Apr 2018 09:14:20 +0000

Hi Dale,

Thank you for your feedback.  It is well noted.

Currently, we are seeking an endorsement from the General Secretariat of ITU as suggested by John in his e-mail at https://www.ietf.org/mail-archive/web/urn/current/msg03832.html .  Sorry for not responding earlier.  It is taking much longer than expected.  As soon as we have got the endorsement, we will submit our request according to the "Fast Track" as in 6.3 of RFC8141.

Regards,
Hiroshi

---
Hiroshi OTA, Advisor, ITU-T SG15
International Telecommunication Union
Place des Nations CH-1211 Geneva 20 Switzerland
Tel: +41 22 730 6356
Fax: +41 22 730 5853
E-mail: [email-masked]

-----Original Message-----
From: Dale R. Worley <[email-masked]> 
Sent: Tuesday, April 24, 2018 05:04
To: OTA, Hiroshi <[email-masked]>; [email-masked]
Cc: TSB SG15 Secretariat, ITU <[email-masked]>
Subject: Re: URN review team coordination

>> 3. The status of the "ITU" registration request is unclear to me - 
>> I've seen nothing further since November:
>> 

draft-itu-urn looks quite fine to me, with this one consideration:  By default, two URNs within a namespace are "equivalent" only if they are exactly identical after the following transformations:

(1) the initial "urn:itu" part is converted to lower-cse
(2) in every %-encoding "%xx", the last two characters are converted to upper case if they are letters

In this case, it means that the "ITU-Sector" component must be in lower case, and the following portion of the URN is case-sensitive (except within %-encodings).

If you want more lenient rules for URN equivalence, they need to be spelled out in the registration template.

Dale