Subject: [urn] LEI namespace registration request

From: Ivan Marin <[email-masked]>
Date: Thu, 15 Jul 2021 08:26:14 +0000

Dear IETF members,

On behalf of GLEIF foundation (https://www.gleif.org/en/about/this-is-gleif) we kindly request the registration for URN namespace for the LEI – Global Legal Entity Identifier – that we support as a global organization world-wide.
The LEI-URN namespaces is intended to become standard.

Following your defined process we have filled out the URN namespace registration template “Appendix A”
Find this document attached to this email.

Do not hesitate to let us know any questions, modifications or requests you may have in order to make this happen.

Thanks in advance,

Ivan Marin
GLEIF Business Development
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Global Legal Entity Identifier Foundation (GLEIF)
Bleichstrasse 59, 60313, Frankfurt am Main, Germany
Work Phone: +49 69 9074999-22
Cell phone: +34 670 246 255
Email: [email-masked]<mailto:[email-masked]>
Web: www.gleif.org<http://www.gleif.org/>

[GLEIF Twitter Account]<http://bit.ly/1Me7uZx>   [GLEIF LinkedIn Company Page] <http://bit.ly/1OXTYLo>    [GLEIF Youtube Channel] <https://www.youtube.com/channel/UCP2xdWOFG7dWNaFIBKyejhg>    [GLEIF Blog] <https://www.gleif.org/en/newsroom/blog>    [Subscribe to GLEIF Newsletter] <https://bit.ly/35KkTaC>
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Global Legal Entity Identifier Foundation (GLEIF)
St. Alban-Vorstadt 5, PO Box, 4002 Basel, Switzerland
Chairman of the Board: Steven Joachim
CEO: Stephan Wolf
Commercial-Register-No.: CHE-200.595.965
LEI: 506700GE1G29325QX363

This message may contain confidential and/or privileged information. If you are not the intended recipient or if you have received this message in error, please notify the sender and delete this message. Any unauthorised copying, disclosure or distribution of this message is strictly forbidden.

---

From: "Henry S. Thompson" <[email-masked]>
Date: Thu, 15 Jul 2021 14:24:01 +0100

Please clarify the following points:

1) Are LEIs restricted to _non-human_ legal entities?  If so, please
   say so.  If not, then there _are_ serious privacy and
   interoperability considerations at the very least.

2) Is the GLEIF API web-based?  That is, is there a mapping from LEI
   URNs to http(s): URIs?  If so, please give an example,
   e.g. something like:

     https://lookup.api.gleif.org/7LTWFZYICNSX8D621K86

   for the example LEI shown in the answer to Syntax.1

Thanks,

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

---

From: Ivan Marin <[email-masked]>
Date: Thu, 15 Jul 2021 13:51:59 +0000

Dear Mr. Thompson,

Let me answer to your questions:

	[GLEIF answer]	
		YES, LEI codes are restricted to _non-human_ legal entities.

    2) Is the GLEIF API web-based?  That is, is there a mapping from LEI
       URNs to http(s): URIs?  If so, please give an example,
       	e.g. something like: https://lookup.api.gleif.org/7LTWFZYICNSX8D621K86
    	for the example LEI shown in the answer to Syntax.1

	[GLEIF answer]	
		YES, the GLEIF API is web based. An example to request the reference data for LEI 7LTWFZYICNSX8D621K86 looks like this: 
		https://api.gleif.org/api/v1/lei-records?filter[lei]=7LTWFZYICNSX8D621K86

Do not hesitate to outreach us if more clarifications are needed. 

Ivan Marin
GLEIF Business Development
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Global Legal Entity Identifier Foundation (GLEIF)
Bleichstrasse 59, 60313, Frankfurt am Main, Germany
Work Phone: +49 69 9074999-22
Cell phone: +34 670 246 255
Email: [email-masked]
Web: www.gleif.org <http://www.gleif.org/>
  
 <http://bit.ly/1Me7uZx>    <http://bit.ly/1OXTYLo>    <https://www.youtube.com/channel/UCP2xdWOFG7dWNaFIBKyejhg>    <https://www.gleif.org/en/newsroom/blog>    <https://bit.ly/35KkTaC>

On 15/7/21, 15:24, "Henry S. Thompson" <[email-masked]> wrote:

    

    
    Thanks,
    
    ht

---

From: "Henry S. Thompson" <[email-masked]>
Date: Thu, 15 Jul 2021 16:50:37 +0100

> Let me answer to your questions:

Thanks for prompt and helpful reply.

>                 YES, LEI codes are restricted to _non-human_ legal entities.

Please make this clear in any update once you've had other comments.

>                 YES, the GLEIF API is web based.

Likewise, please make this clear include this example

> An example to request the reference data for LEI 7LTWFZYICNSX8D621K86 looks like this:

And include this example where you talk about resolution.

Thanks,

ht

---

From: "Hakala, Juha E" <[email-masked]>
Date: Thu, 22 Jul 2021 08:39:13 +0000

Dear Mr. Marin; all, 

as an international standard, LEI meets the formal requirements for URN namespaces. 

The principles according to which GLEIF maintains LEIs mean that they are more persistent than identified legal entities. For instance, my former bank, which ceased to exist in 2018, still has a LEI and related metadata at https://search.gleif.org/#/record/3BAUHUB4IZR54J3EPO08

I accept the registration request, but have some additional questions: 

LEIs are not free (except in China), and at least in Finland they are quite expensive. Since URNs must be free, I suppose that there will not be extra cost for creating a URN from an existing LEI. 

Are you planning to create URNs retrospectively to all LEIs, independent of their registration status? Or will URNs be created on request only? 

Is there a plan to make urn:lei's actionable (e.g. in the format https://urn.gleif.org/urn:lei:<lei-number>? URN resolver could extract LEI code from the URN and pass it to the GLEIF API. Using the API directly (e.g. https://api.gleif.org/api/v1/lei-records?filter[lei]=urn:lei:7LTWFZYICNSX8D621K86) might not provide a sufficiently cool URI. 

GLEIF records can have multiple statuses: 

"The global LEI system retains records with MERGED, RETIRED, DUPLICATE or ANNULLED registration status for query resolution and historical reasons. These records continue to appear in data published by LOUs and the GLEIF."

Will all urn:lei's be treated in the same way when resolved, independently of the registration status? 

What metadata will be provided by default when urn:lei is resolved; for instance, will Level 2 metadata on who owns whom be included?  

All the best, 

Juha Hakala

-----Alkuperäinen viesti-----
Lähettäjä: urn <[email-masked]> Puolesta Ivan Marin
Lähetetty: torstai 15. heinäkuuta 2021 16.52
Vastaanottaja: Henry S. Thompson <[email-masked]>
Kopio: [email-masked]; Karla Mckenna <[email-masked]>
Aihe: Re: [urn] LEI namespace registration request

Dear Mr. Thompson,

    
	[GLEIF answer]	

	[GLEIF answer]	

Ivan Marin
Global Legal Entity Identifier Foundation (GLEIF) Bleichstrasse 59, 60313, Frankfurt am Main, Germany Work Phone: +49 69 9074999-22 Cell phone: +34 670 246 255
  
Global Legal Entity Identifier Foundation (GLEIF) St. Alban-Vorstadt 5, PO Box, 4002 Basel, Switzerland Chairman of the Board: Steven Joachim

    

    
    
    Thanks,
    
    ht

_______________________________________________
urn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/urn

---

From: Ivan Marin <[email-masked]>
Date: Thu, 22 Jul 2021 14:28:16 +0000

Thanks Mr. Hakala for your answer and the LEI namespace request acceptance.
 
Find below inline the answers to your questions.
Let us also know, please, if you have further questions we can answer
- whether something else is needed to release the namespace
- what the regular schedule can be expected
- and if there is any action needed from our side at this time.
 
Thanks for your support.

Ivan Marin
 
 <http://bit.ly/1Me7uZx>    <http://bit.ly/1OXTYLo>    <https://www.gleif.org/en/newsroom/blog>

 _____________________________________________________________________________________

On 22/7/21, 10:39, "Hakala, Juha E" <[email-masked]> wrote:

    Dear Mr. Marin; all,

    The principles according to which GLEIF maintains LEIs mean that they are more persistent than identified legal entities. For instance, my former bank, which ceased to exist in 2018, still has a LEI and related metadata at https://search.gleif.org/#/record/3BAUHUB4IZR54J3EPO08
_____________________________________________________________________________________
[GLEIF-IMS] True. LEIs are stable life-long. GLEIF maintains the LEI codes without expiration date, although they can be retired and the code exists and it is accessible in the database regardless the entity disappears and the codes are never reused. The status of each LEI is visible via the so called “Registration Status”.
_____________________________________________________________________________________
    I accept the registration request, but have some additional questions:

_____________________________________________________________________________________ 
[GLEIF-IMS] True. The use of LEI data is free of charge and access is provided without any limitations. There is no extra cost for the URN from an existing LEI. GLEIF, in addition, is continuously working on lowering the registration and renewal costs for LEIs.
_____________________________________________________________________________________

_____________________________________________________________________________________
[GLEIF-IMS] URNs are simply created on request using given format.    
_____________________________________________________________________________________

_____________________________________________________________________________________ 
[GLEIF-IMS] Our current URN format is the first one you have point out.  The GLEIF API is in constant evolution, and we could add this request in our roadmap if you feel that brings value for a better usage.
_____________________________________________________________________________________

   

_____________________________________________________________________________________
[GLEIF-IMS] Yes, all URNs will be treated the same way when resolved the same regardless the status.
_____________________________________________________________________________________

_____________________________________________________________________________________
[GLEIF-IMS] The lei:URN resolution indicates there is Level 2 metadata, i.e. links are included in the response. The Level 2 data can then be requested with additional requests.
_____________________________________________________________________________________

    All the best,
    
    Juha Hakala
   
    -----Alkuperäinen viesti-----
    Lähettäjä: urn <[email-masked]> Puolesta Ivan Marin
    Lähetetty: torstai 15. heinäkuuta 2021 16.52
    Vastaanottaja: Henry S. Thompson <[email-masked]>
    Kopio: [email-masked]; Karla Mckenna <[email-masked]>
    Aihe: Re: [urn] LEI namespace registration request
   
    Dear Mr. Thompson,

       
                [GLEIF answer] 

                [GLEIF answer] 

    Ivan Marin

    

       

       
        Thanks,
       
        ht