Subject: [Uta] DTLS in the Charter?

From: Andrei Popov <[email-masked]>
Date: Mon, 20 Jan 2014 23:51:26 +0000

charter-ietf-uta-01 talks about TLS; is DTLS excluded from the charter? If so, why? Otherwise, can the charter be revised to include DTLS?

Thanks,

Andrei

---

From: Leif Johansson <[email-masked]>
Date: Tue, 21 Jan 2014 08:47:27 +0100

On 2014-01-21 00:51, Andrei Popov wrote:
>
> charter-ietf-uta-01 talks about TLS; is DTLS excluded from the
> charter? If so, why? Otherwise, can the charter be revised to include
> DTLS?
>
>  
>
>
I don't see why DTLS should be excluded a priori but I think we need
some guidance from our AD for this question!

        Cheers Leif

---

From: Andrei Popov <[email-masked]>
Date: Tue, 21 Jan 2014 18:59:04 +0000

Excluding DTLS effectively limits the scope of UTA to those application protocols that run over TCP, which seems arbitrary. Any guidance from AD with regard to this would be very welcome.

Thanks,

Andrei

From: Uta [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Monday, January 20, 2014 11:47 PM
To: [email-masked]; [email-masked]
Subject: Re: [Uta] DTLS in the Charter?

I don't see why DTLS should be excluded a priori but I think we need some guidance from our AD for this question!

        Cheers Leif

---

From: Pete Resnick <[email-masked]>
Date: Tue, 21 Jan 2014 17:48:06 -0600

I don't think we really considered it at chartering time, given that the 
"initial set of representative application protocols is SMTP, POP, IMAP, 
XMPP, and HTTP 1.1", and none of those use other than TCP.

Andrei, were you suggesting we work on a *particular* item in our 
documents that you suspect will be ignored if we don't bring in 
discussion of DTLS, or is this just a theoretical question? I don't have 
a concern in principle, and "TLS" in the charter can be read to be more 
generic than "the TLS protocol", but I also want to make sure the WG is 
not going off on a tangent. If we're heading in an unexpected direction, 
I'd obviously like to clarify that in the charter. What were you 
thinking we ought to be discussing that we might not be able to?

pr

On 1/21/14 12:59 PM, Andrei Popov wrote:
>
> Excluding DTLS effectively limits the scope of UTA to those 
> application protocols that run over TCP, which seems arbitrary. Any 
> guidance from AD with regard to this would be very welcome.
>
> Thanks,
>
> Andrei
>
> *From:* Uta [mailto:[email-masked]] *On Behalf Of *Leif Johansson
> *Sent:* Monday, January 20, 2014 11:47 PM
> *To:* [email-masked]; [email-masked]
> *Subject:* Re: [Uta] DTLS in the Charter?
>
>     charter? If so, why? Otherwise, can the charter be revised to
>     include DTLS?
>
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta
>    

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Andrei Popov <[email-masked]>
Date: Wed, 22 Jan 2014 00:07:06 +0000

Hi Pete,

If this WG excludes DTLS, then securing widely-used application protocols such as RTP, RTCP, RDP, NTP, RPC, NFS, VoIP, etc. with DTLS is outside the scope of this WG. My question is whether all of the numerous application protocols that typically run over UDP are intentionally left outside the scope of UTA (in which case it would be good to explicitly state the reasons), or perhaps DTLS was omitted from the charter by mistake (in which case it would be great to update the charter).

Thanks,

Andrei

From: Pete Resnick [mailto:[email-masked]]
Sent: Tuesday, January 21, 2014 3:48 PM
To: Andrei Popov
Cc: Leif Johansson; [email-masked]; [email-masked]
Subject: Re: [Uta] DTLS in the Charter?

I don't think we really considered it at chartering time, given that the "initial set of representative application protocols is SMTP, POP, IMAP, XMPP, and HTTP 1.1", and none of those use other than TCP.

Andrei, were you suggesting we work on a *particular* item in our documents that you suspect will be ignored if we don't bring in discussion of DTLS, or is this just a theoretical question? I don't have a concern in principle, and "TLS" in the charter can be read to be more generic than "the TLS protocol", but I also want to make sure the WG is not going off on a tangent. If we're heading in an unexpected direction, I'd obviously like to clarify that in the charter. What were you thinking we ought to be discussing that we might not be able to?

pr

Thanks,

Andrei

From: Uta [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Monday, January 20, 2014 11:47 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Uta] DTLS in the Charter?

        Cheers Leif

Uta mailing list

[email-masked]<mailto:[email-masked]>

--

Pete Resnick <http://www.qualcomm.com/~presnick/><http://www.qualcomm.com/~presnick/>

---

From: Pete Resnick <[email-masked]>
Date: Tue, 21 Jan 2014 22:33:51 -0600

On 1/21/14 6:07 PM, Andrei Popov wrote:

> If this WG excludes DTLS, then securing widely-used application 
> protocols such as RTP, RTCP, RDP, NTP, RPC, NFS, VoIP, etc. with DTLS 
> is outside the scope of this WG. My question is whether all of the 
> numerous application protocols that typically run over UDP are 
> intentionally left outside the scope of UTA (in which case it would be 
> good to explicitly state the reasons), or perhaps DTLS was omitted 
> from the charter by mistake (in which case it would be great to update 
> the charter).
>

So, not many of the protocols you mention have defined protocol 
specifications (let alone wide deployment) for use with DTLS, so if you 
mean that you wish this WG to define DTLS usage for these protocols, 
that's certainly out of scope: None of the 4 bulleted items in the 
charter are about doing *initial* specifications of security for the 
protocols.

If you think any of those protocols (say RTP) needs to be needed to the 
"representative" list because there is already a spec on how to use it 
with DTLS (e.g., RFC 5764) and it is in need of change to better deal 
with current issues, that might be reasonable. I think a case would need 
to be made for why that work is similar to the other things being 
contemplated by the WG at this time. (As the charter says: "It is 
expected that other protocols that use TLS might later be updated using 
the guidelines from this WG, and that those updates will happen through 
other WGs or through individual submissions.")

So I don't think discussion of DTLS is absolutely precluded, but I think 
a case will have to be made about how it will achieve the goals of the 
WG as outlined in those 4 bullets in the charter. If the WG really 
intends to work on DTLS as part of its central work, a change to the 
charter is probably worth discussing. Again, I'd like to see a specific 
example of how such discussion would apply to a charter goal before 
saying absolutely one way or the other.

pr
>
> *From:* Pete Resnick [mailto:[email-masked]]
> *Sent:* Tuesday, January 21, 2014 3:48 PM
> *To:* Andrei Popov
> *Cc:* Leif Johansson; [email-masked]; [email-masked]
> I don't think we really considered it at chartering time, given that 
> the "initial set of representative application protocols is SMTP, POP, 
> IMAP, XMPP, and HTTP 1.1", and none of those use other than TCP.
>
> discussion of DTLS, or is this just a theoretical question? I don't 
> have a concern in principle, and "TLS" in the charter can be read to 
> be more generic than "the TLS protocol", but I also want to make sure 
> the WG is not going off on a tangent. If we're heading in an 
> unexpected direction, I'd obviously like to clarify that in the 
> charter. What were you thinking we ought to be discussing that we 
> might not be able to?
>
> pr
>
>     application protocols that run over TCP, which seems arbitrary.
>     Any guidance from AD with regard to this would be very welcome.
>
>     Thanks,
>
>     Andrei
>
>     *To:* [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
>     I don't see why DTLS should be excluded a priori but I think we
>     need some guidance from our AD for this question!
>
>             Cheers Leif
>
>       
>
>       
>
>     [email-masked]  <mailto:[email-masked]>
>
> Pete Resnick<http://www.qualcomm.com/~presnick/>  <http://www.qualcomm.com/%7Epresnick/>

---

From: Leif Johansson <[email-masked]>
Date: Wed, 22 Jan 2014 09:13:15 +0100

On 2014-01-22 05:33, Pete Resnick wrote:
>> intentionally left outside the scope of UTA (in which case it would
>> be good to explicitly state the reasons), or perhaps DTLS was omitted
>> from the charter by mistake (in which case it would be great to
>> update the charter).
>>
>
> specifications (let alone wide deployment) for use with DTLS, so if
> you mean that you wish this WG to define DTLS usage for these
> protocols, that's certainly out of scope: None of the 4 bulleted items
> in the charter are about doing *initial* specifications of security
> for the protocols.
>
> If you think any of those protocols (say RTP) needs to be needed to
> the "representative" list because there is already a spec on how to
> use it with DTLS (e.g., RFC 5764) and it is in need of change to
> better deal with current issues, that might be reasonable. I think a
> case would need to be made for why that work is similar to the other
> things being contemplated by the WG at this time. (As the charter
> says: "It is expected that other protocols that use TLS might later be
> updated using the guidelines from this WG, and that those updates will
> happen through other WGs or through individual submissions.")
>
> So I don't think discussion of DTLS is absolutely precluded, but I
> think a case will have to be made about how it will achieve the goals
> of the WG as outlined in those 4 bullets in the charter. If the WG
> really intends to work on DTLS as part of its central work, a change
> to the charter is probably worth discussing. Again, I'd like to see a
> specific example of how such discussion would apply to a charter goal
> before saying absolutely one way or the other.
>

As chair I interpret this as follows: write a draft covering a specific
case of profiling the use of DTLS in a protocol where there is already
spec covering DTLS. Such a draft might be in scope for UTA but it
probably won't get priority over HTTP, SMTP, XMPP etc...

        Cheers Leif

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 22 Jan 2014 10:31:47 +0000

Hi Andrei,

> from the charter by mistake (in which case it would be great to update 
The list of initial protocols was included in the Charter text in order 
to limit what the working group should work on. This is a prioritization 
mechanism.

Once the work on initial work items is finished, the WG can recharter to 
work on other similar things, including protocols running over DTLS.

Having said that, WG chairs can encourage writing of other related 
specifications.

Best Regards,
Alexey
>
> Thanks,
>
> Andrei
>
> *From:*Pete Resnick [mailto:[email-masked]]
>     *From:*Uta [mailto:[email-masked]] *On Behalf Of *Leif Johansson

---

From: Andrei Popov <[email-masked]>
Date: Wed, 22 Jan 2014 18:30:59 +0000

Thanks Alexey and Pete, this answers my question.

Cheers,

Andrei

From: Alexey Melnikov [mailto:[email-masked]]
Sent: Wednesday, January 22, 2014 2:32 AM
To: Andrei Popov; Pete Resnick
Cc: [email-masked]; [email-masked]; Leif Johansson
Subject: Re: [Uta] DTLS in the Charter?

Hi Andrei,

If this WG excludes DTLS, then securing widely-used application protocols such as RTP, RTCP, RDP, NTP, RPC, NFS, VoIP, etc. with DTLS is outside the scope of this WG. My question is whether all of the numerous application protocols that typically run over UDP are intentionally left outside the scope of UTA (in which case it would be good to explicitly state the reasons), or perhaps DTLS was omitted from the charter by mistake (in which case it would be great to update the charter).
The list of initial protocols was included in the Charter text in order to limit what the working group should work on. This is a prioritization mechanism.

Once the work on initial work items is finished, the WG can recharter to work on other similar things, including protocols running over DTLS.

Having said that, WG chairs can encourage writing of other related specifications.

Best Regards,
Alexey

Thanks,

Andrei

From: Pete Resnick [mailto:[email-masked]]
Sent: Tuesday, January 21, 2014 3:48 PM
To: Andrei Popov
Cc: Leif Johansson; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Uta] DTLS in the Charter?

pr

Thanks,

Andrei

        Cheers Leif

Uta mailing list

--

Pete Resnick <http://www.qualcomm.com/~presnick/><http://www.qualcomm.com/%7Epresnick/>

Uta mailing list