Subject: Re: [Uta] draft-ietf-uta-email-deep-01 is ready for WGLC

From: Leif Johansson <[email-masked]>
Date: Tue, 3 Nov 2015 02:03:04 +0100

On 2015-07-22 10:31, Leif Johansson wrote:
> On 2015-07-22 10:28, Alexey Melnikov wrote:
>> Hi,
>> I've reviewed changes between -01 and -00 and I think it is ready for
>> WGLC. I have reviewed -00 earlier.
> 
> Thx for getting the ball rolling Alexey! The other folk who volunteered
> to review last night should take this as cue to get their review in :-)
> 

Embarrassingly we are at IETF95 and none of the reviews promised at
IETF94 are in hand... The notes from IETF94 lists 4 names volunteering
to review DEEP...

Nudge-nudge

	Cheers Leif

---

From: Barry Leiba <[email-masked]>
Date: Tue, 3 Nov 2015 03:25:18 +0100

Leif appears to be in a time warp and is living in April 2016.  His
point, though, remains....

b

On Tue, Nov 3, 2015 at 2:03 AM, Leif Johansson <[email-masked]> wrote:
> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta

---

From: Leif Johansson <[email-masked]>
Date: Tue, 3 Nov 2015 07:06:56 +0100

> point, though, remains....

we know all about off-by-one errors, don't we

---

From: Aaron Zauner <[email-masked]>
Date: Tue, 3 Nov 2015 10:43:02 +0100

> IETF94 are in hand... The notes from IETF94 lists 4 names volunteering

I was one of them. Sorry, I completely forgot to write to list about
this. I've read the draft a couple of times over the summer, I think
it's ready for WGLC. This document is rather imporant in the context
of e-mail security, so let's get this done.

Aaron

---

From: Leif Johansson <[email-masked]>
Date: Wed, 4 Nov 2015 05:12:36 +0100

On 2015-11-03 10:43, Aaron Zauner wrote:
>> Embarrassingly we are at IETF95 and none of the reviews promised
>> at IETF94 are in hand... The notes from IETF94 lists 4 names
>> volunteering to review DEEP...
> 
> I was one of them. Sorry, I completely forgot to write to list
> about this. I've read the draft a couple of times over the summer,
> I think it's ready for WGLC. This document is rather imporant in
> the context of e-mail security, so let's get this done.
> 
> Aaron
> 

Thx Aron!

---

From: "Orit Levin (LCA)" <[email-masked]>
Date: Wed, 4 Nov 2015 05:42:30 +0000

Thanks, Aaron.
Actually, I am not sure that we are looking at the right document yet.
draft-ietf-uta-email-deep-01 was posted just before the last IETF. We have been waiting for the authors to post an updated version incorporating the feedback from that session and then call for the review.

Chris, Keith,
Have I missed something? Where do you stand on this?
Thanks,
Orit.

> -----Original Message-----
> From: Uta [mailto:[email-masked]] On Behalf Of Leif Johansson
> Sent: Tuesday, November 03, 2015 8:13 PM
> To: Aaron Zauner <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Uta] draft-ietf-uta-email-deep-01 is ready for WGLC
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
> 
> iEYEARECAAYFAlY5hbQACgkQ8Jx8FtbMZnfV5ACgxlvv+vnF3e4J7Hms98QTWX
> pw
> V5AAoKYgXIRYwUgbMqe5HhTwKYGy6GgW
> =Puez
> -----END PGP SIGNATURE-----
>

---

From: Chris Newman <[email-masked]>
Date: Wed, 04 Nov 2015 11:10:12 -0800

I should be able to do a revision late November.

		- Chris

On November 3, 2015 at 21:42:57 , Orit Levin (LCA) ([email-masked]) wrote:

Thanks, Aaron. 

Chris, Keith,

---

From: "Orit Levin (LCA)" <[email-masked]>
Date: Thu, 5 Nov 2015 00:09:56 +0000

Chris,
That sounds good. Thank you.
Although UTA is not meeting this week, as you could see even from the list only, people are waiting for the document to be completed and put to use!
Please, do you best, so that we are able to call for the WGLC reviews of -02 ASAP.
In the meanwhile, everyone is encouraged to (re)read the current -01 version and send any feedback that they may have to the list/editors as well.

Orit.

From: Chris Newman [mailto:[email-masked]]
Sent: Wednesday, November 04, 2015 11:10 AM
To: Orit Levin (LCA) <[email-masked]>; Leif Johansson <[email-masked]>; Aaron Zauner <[email-masked]>
Cc: [email-masked]
Subject: Re: [Uta] draft-ietf-uta-email-deep-01 is ready for WGLC

                      - Chris

On November 3, 2015 at 21:42:57 , Orit Levin (LCA) ([email-masked]<mailto:[email-masked]>) wrote:
Thanks, Aaron.
Actually, I am not sure that we are looking at the right document yet.
draft-ietf-uta-email-deep-01 was posted just before the last IETF. We have been waiting for the authors to post an updated version incorporating the feedback from that session and then call for the review.

Chris, Keith,

> To: Aaron Zauner <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]>
> > * Leif Johansson <[email-masked]<mailto:[email-masked]>> [03/11/2015 02:03:16] wrote:
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Uta mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/uta

---

From: Julien ÉLIE <[email-masked]>
Date: Thu, 12 Nov 2015 22:26:23 +0100

Hi,

> In the meanwhile, everyone is encouraged to (re)read the current -01
> version and send any feedback that they may have to the list/editors as
> well.

I have a question that may seem naive, but if I understand well how 
security tags work, "tls10" will always be advertised if "tls12" is.  So 
why bother to advertise "tls10"?
When TLS 1.3 has been standardized, will it mean that "tls10", "tls12" 
and "tls13" will all be advertised and latched?
I don't see the point in having such redundancy.

Besides, the draft says that "when a server advertises a security tag, 
it is making a commitment to support that security facility 
indefinitely" so it means that "tls10" can be advertised even though the 
server has disabled TLS 1.0 and 1.1 and only authorizes TLS 1.2.

The other point I would like to raise is the generality of this draft. 
Why is it focused only on e-mail?  I thought the UTA WG is for 
Applications in general.  Couldn't the security tags serve other 
protocols than POP, IMAP and SMTP?  For instance XMPP or NNTP?
So the IANA registry could be "Security Tags" instead of "Email Security 
Tags".  This way, any protocol could benefit of the available security 
tags instead of duplicating it several times.

-- 
Julien ÉLIE

« – Et souvenez-vous ! La seule chose que nous ayons à craindre,
     c'est que le ciel nous tombe sur la tête !
   – …Et souvenez-vous, Romains, la seule chose que nous ayons à
     craindre, c'est les Gaulois ! » (Astérix)