Subject: [Uta] Adam Roach's Discuss on draft-ietf-uta-mta-sts-17: (with DISCUSS)

From: Adam Roach <[email-masked]>
Date: Tue, 08 May 2018 23:48:54 -0700

Adam Roach has entered the following ballot position for
draft-ietf-uta-mta-sts-17: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-uta-mta-sts/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thanks to everyone who contributed to this document. I intend to ballot "yes,"
once the following issue has been resolved:

This document defines three modes: "enforce", "testing", and "none". It is
intended to work in conjunction with draft-ietf-uta-smtp-tlsrpt, which shows the
use of "mode: report" in all of its examples.

On a quick survey of hosts I can quickly find publishing MTA-STS records, I
find:

version: STSv1
mode: testing
mx: aspmx.l.google.com
mx: .aspmx.l.google.com
max_age: 86400

version: STSv1
mode: report
mx: mx00.emig.gmx.net
mx: mx01.emig.gmx.net
max_age: 604800

version: STSv1
mode: report
mx: mx1.comcast.net
mx: mx2.comcast.net
max_age: 2592000

version: STSv1
mode: report
mx: *.am0.yahoodns.net
max_age: 86400

The implementation confusion here appears to be real. Please ensure that
draft-ietf-uta-smtp-tlsrpt and draft-ietf-uta-mta-sts agree about valid values
for the "mode" parameter.

---

From: Daniel Margolis <[email-masked]>
Date: Thu, 10 May 2018 16:56:56 +0200

Thanks. We (as you may know) renamed "report" mode to "testing" mode late
in the review process. I have fixed the errors in TLSRPT to be consistent
with MTA-STS in our working draft.

On Wed, May 9, 2018 at 8:49 AM Adam Roach <[email-masked]> wrote:

> _______________________________________________
> Uta mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/uta
>

---

From: Adam Roach <[email-masked]>
Date: Thu, 10 May 2018 10:00:38 -0500

Thanks! Ping me when the revised version of TLSRPT is in the draft 
repository, and I'll clear this DISCUSS.

/a

On 5/10/18 09:56, Daniel Margolis wrote:
> Thanks. We (as you may know) renamed "report" mode to "testing" mode 
> late in the review process. I have fixed the errors in TLSRPT to be 
> consistent with MTA-STS in our working draft.
>
> On Wed, May 9, 2018 at 8:49 AM Adam Roach <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Please refer to
>     https://www.ietf.org/iesg/statement/discuss-criteria.html
>     mx: aspmx.l.google.com <http://aspmx.l.google.com>
>     mx: .aspmx.l.google.com <http://aspmx.l.google.com>
>     max_age: 86400
>
>     version: STSv1
>     mode: report
>     mx: mx00.emig.gmx.net <http://mx00.emig.gmx.net>
>     mx: mx01.emig.gmx.net <http://mx01.emig.gmx.net>
>     max_age: 604800
>
>     version: STSv1
>     mode: report
>     mx: mx1.comcast.net <http://mx1.comcast.net>
>     mx: mx2.comcast.net <http://mx2.comcast.net>
>     max_age: 2592000
>
>     version: STSv1
>     mode: report
>     mx: *.am0.yahoodns.net <http://am0.yahoodns.net>
>     max_age: 86400
>
>     [email-masked] <mailto:[email-masked]>