Subject: [Uta] FW: [Technical Errata Reported] RFC8460 (5889)

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 21 Nov 2019 04:37:45 +0300

Hi,

this is an erratum reported by Scott Kitterman about the missing IANA
registration item for DKIM in RFC8460. The chairs want to know the WG opinion on this. 

Regards,
Valery (for the chairs)

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: Thursday, October 31, 2019 9:21 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Technical Errata Reported] RFC8460 (5889)

The following errata report has been submitted for RFC8460, "SMTP TLS Reporting".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5889

--------------------------------------
Type: Technical
Reported by: Scott Kitterman <[email-masked]>

Section: 6.7

Original Text
-------------
Item is missing entirely

Corrected Text
--------------
6.7 DKIM Service Type

This document registers a new DKIM Service Type in the DomainKeys Identified Mail (DKIM) Parameters registry:

Service Type name: tlsrpt

Reference: RFC 8460

Status Active

Notes
-----
The new service type is discussed in Section 3, so it should have been added to the registry.  It's an IETF Review required registry, not Specification Required, so this can (and should) be addressed in terms at least of the registry now.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8460 (draft-ietf-uta-smtp-tlsrpt-23)
--------------------------------------
Title               : SMTP TLS Reporting
Publication Date    : September 2018
Author(s)           : D. Margolis, A. Brotman, B. Ramakrishnan, J. Jones, M. Risher
Category            : PROPOSED STANDARD
Source              : Using TLS in Applications
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 21 Nov 2019 10:13:16 +0800

I would guess we can't rectify this oversight via the errata system.  What
got IETF Review was the need for the registration, but not the registration
itself.

I imagine this should either be done through DISPATCH (which is chartered
to do minor housekeeping things like this) or through an AD-sponsored
document that contains only the registration.

-MSK

On Thu, Nov 21, 2019 at 9:37 AM Valery Smyslov <[email-masked]> wrote:

> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> This document registers a new DKIM Service Type in the DomainKeys
> Identified Mail (DKIM) Parameters registry:
>
> The new service type is discussed in Section 3, so it should have been
> added to the registry.  It's an IETF Review required registry, not
> Specification Required, so this can (and should) be addressed in terms at
> least of the registry now.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party can log in to change the status
> and edit the report, if necessary.
>

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 21 Nov 2019 11:00:05 +0800

> On 21 Nov 2019, at 10:13, Murray S. Kucherawy <[email-masked]> wrote:
> 
> I would guess we can't rectify this oversight via the errata system.  What got IETF Review was the need for the registration, but not the registration itself.
> 
> I imagine this should either be done through DISPATCH (which is chartered to do minor housekeeping things like this) or through an AD-sponsored document that contains only the registration.

Right. If there is urgency in fixing this, I can also do an IESG management item to get IESG to approve the registration.