Subject: Re: [Uta] draft-ietf-uta-rfc6125bis replacement status updated by Valery Smyslov

From: "Salz, Rich" <[email-masked]>
Date: Tue, 29 Jun 2021 17:37:55 +0000

Following the recommendations of our AD and WG chairs, I uploaded a new version of "use-san" to be a complete replacement of RFC6125. Peter and Jeff have agreed to be co-authors. Carsten graciously used tooling to convert the RFC Published XML to markdown. There is a GitHub repo for the document at https://github.com/richsalz/draft-ietf-uta-rfc6125bis  Right now it does NOT have the content from the draft, the first commits were about cleaning up the markdown.

First up is a pull request to make the wildcard changes.

On 6/29/21, 12:20 PM, "DraftTracker Mail System" <[email-masked]> wrote:

    Please DO NOT reply to this email.

    I-D: <draft-ietf-uta-rfc6125bis-00.txt>
    Datatracker URL: https://datatracker.ietf.org/doc/draft-ietf-uta-rfc6125bis/

    This document now replaces draft-ietf-uta-use-san instead of None

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 30 Jun 2021 14:32:22 +0000

>   Following the recommendations of our AD and WG chairs, I uploaded a new version of "use-san" to be a complete replacement of RFC6125. Peter and Jeff have agreed to be co-authors. Carsten gracious…

The pull request that brings forward the proposed wildcard changes can be found at https://github.com/richsalz/draft-ietf-uta-rfc6125bis/pull/1

The main change is that "*" can only appear in the left-most DNS label, and must be the first or only character in the label. Because of this simplification, much cautionary wording can be removed. Also, client support for "*" is now a MUST.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 30 Jun 2021 14:39:26 +0000

> Following the recommendations of our AD and WG chairs, I uploaded a new version of "use-san" to be a complete replacement of RFC6125. Peter and Jeff have agreed to be co-authors. Carsten graciously…

The pull request that brings forward the proposed "don't use the CN at all" changes can be found at https://github.com/richsalz/draft-ietf-uta-rfc6125bis/pull/2

The main change is that all references to CN-ID which is the Common Name RDN " where the value matches the overall form of a domain name (informally, dot-separated letter-digit-hyphen labels)" have been removed. A couple of sentences about why it should not be used were added, but the bulk of the change is 200 deleted lines.