Subject: Re: [v4tov6transition] troubling survey

From: Fred Baker <[email-masked]>
Date: Sun, 02 Jan 2011 00:06:09 -0000

On Sep 16, 2010, at 3:32 PM, Ed Jankiewicz wrote:

http://gcn.com/articles/2010/09/14/adoption-of-ipv6-is-slow.aspx

as the article notes, something like 10% of ISPs responded "No plans to implement IPv6" as in not even thinking about EVER doing it.  Overall, including end-user organizations there is still a lackluster interest in doing IPv6 now or soon.  And big reasons include "lack of knowledgeable staff", "lack of experience", "no business case/user demand" and "technical problems".   Real or perceived, getting better information out to marketplace about what you really need to know and need to do would help.  I hope that's what this list is about.

http://www.nro.net/documents/GlobalIPv6SurveySummaryv2.pdf

I think you will find this list is about operator questions regarding IPv6 deployment, and very much overlaps the v6ops list. It's not marketing. It's operational technology questions, many of them appropriate to your favorite *NOG.

There are a couple of ways to look at IPv6 adoption. There is a serious level of whistling in the dark regarding the IPv6 address space; I hear a lot of "I have enough addresses for another year; if I'm not out of addresses, why worry?" That, of course, is a lot like saying "I'm driving the car at 200 kph and I still have pavement ahead; why should that brick wall I see concern me?".

The other way to look at 10% of ISPs asleep at the wheel is that 90% aren't. Yes, they would like more customer demand - people waving money would really excite them, and at this point it's mostly a cost, not a revenue opportunity.  http://www.oecd.org/dataoecd/48/8/44961688.pdf suggests, however, that ISPs - especially in North America, long rumored to be the last place on earth anyone would deploy IPv6 - have been quietly deploying it in their networks and are preparing to deploy services to customers. Some, as Cameron noted the other day, are even going IPv6-only within specified domains.

We're having amusing conversations with our customers as they come up short. One salesman contacted me a couple of weeks ago when his customer was preparing their request to ARIN and had been told that they would get a pretty small allocation. They sales guy wanted to know what arguments for a larger allocation the company should offer: "would it make a difference if they said 'but we really need it, guys!'"? Of the options the salesman offered me, an incredulous "Deploy IPv6?!?" was the fourth, and yes, that's the realization the customer was having - feeling very much like his pants had just dropped down around his ankles. I suspect that as these stories become more common, we're going to suddenly find people wanting to deploy "right now", and and angry if everything doesn't work just perfectly out of the box.

---

From: Joel Jaeggli <[email-masked]>
Date: Sat, 01 Jan 2011 18:42:36 -0800

On 9/17/10 9:16 AM, Fred Baker wrote:
> 
> We're having amusing conversations with our customers as they come up
> short. One salesman contacted me a couple of weeks ago when his customer
> was preparing their request to ARIN and had been told that they would
> get a pretty small allocation. They sales guy wanted to know what
> arguments for a larger allocation the company should offer: "would
> it make a difference if they said 'but we really need it, guys!'"? Of
> the options the salesman offered me, an incredulous "Deploy IPv6?!?" was
> the fourth, and yes, that's the realization the customer was having -
> feeling very much like his pants had just dropped down around his
> ankles. I suspect that as these stories become more common, we're going
> to suddenly find people wanting to deploy "right now", and and angry if
> everything doesn't work just perfectly out of the box.

The senior management of a rather large company I'm inovolved with begin
asking pointed questions that indicated that they were now rather
interested in our preparedness for ipv6 deployment. We are in a good
position to talk intelligently about that but I imagine that this
discussion is going on in a rather large number of locations.

> 
> 
> _______________________________________________
> v4tov6transition mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v4tov6transition