Subject: RE: ocean: do not boil

From: "Bound, Jim" <[email-masked]>
Date: Thu, 26 Sep 2002 04:07:18 -0400

every input I get is that they don't want NAT and want it to go away as soon as possible.  for "some" (I say some) I am being told how fast can I get rid of IPv4 period at least on my site.  that "some" is as important as the Lowest Common Denominator or one size fits all view to me as an engineer.

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2002 11:36 PM
> To: Stewart Tansley
> Cc: Bound, Jim; [email-masked]
> Subject: Re: ocean: do not boil 
> 
> 
> >> 	in almost all of the installation of IPv6, they run 
> IPv4 and IPv6 in
> >> 	parallel - usually IPv4 is NATed, and IPv6 is globally reachable
> >> 	(sometimes IPv6 filtering device is in place).  i don't 
> share your
> >> 	view on this aspect on customer demand.
> >Is it demand, or is it necessity.
> 
> 	i should have written "in almost all of the 
> installation I'VE SEEN".
> 	so it's an input from real experiences.  and since Jim 
> is talking about
> 	customer demand, i think i was talking about customer 
> demand too.
> 	(and normally it's simpler to leave NAT'ed IPv4 as is - 
> don't touch it
> 	if it's running)
> 
> itojun
>

---

From: Keith Moore <[email-masked]>
Date: Thu, 26 Sep 2002 09:25:11 -0400

> every input I get is that they don't want NAT and want it to go away as 
> soon as possible.  for "some" (I say some) I am being told how fast can 
> I get rid of IPv4 period at least on my site.

that's quite interesting, and encouraging.  what it indicates to me is
that people need a way to disable IPv4-NAT and still leave IPv6 running.
I don't think that's rocket science.  

and I understand why sites might want to get rid of IPv4 as much as possible,
as soon as possible. but it's hard to believe that most sites won't need at 
least some IPv4-NAT in addition to IPv6 during a transition phase,
at least for awhile.   if nothing else many locally-used apps will have IPv4 
wired into them, and it will take time to upgrade all of those apps. 

Keith

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 Sep 2002 09:59:22 -0500

Hi Jim,

>every input I get is that they don't want NAT and want it to go away as soon as possible.  for "some" (I say some) I am being told how fast can I get rid of IPv4 period at least on my site.  that "s…

I would like to hope that you are right (and are in line with the 
operators and enterprises). For Keith, I understand, in academia one 
wants the latest.
What are the views then on the issue of IPv6 NATs?

>/jim

--behcet

---

From: Keith Moore <[email-masked]>
Date: Thu, 26 Sep 2002 16:27:08 -0400

> For Keith, I understand, in academia one wants the latest.

what I want is a network where I can build large distributed 
applications without having to design my own addressing system 
and routing protocols on top of layer 7.  this is trivial
with v6, it's nearly infeasible with v4+NAT.