Subject: RE: ocean: do not boil

From: "Bound, Jim" <[email-masked]>
Date: Wed, 25 Sep 2002 02:16:49 -0400

If the v6ops even try to address this they are going to not be listened too.  Its none of the IETFs business.

/jim

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Tuesday, September 24, 2002 11:13 AM
> To: Keith Moore
> Cc: Hesham Soliman (EAB); 'Bob Hinden'; Margaret Wasserman; 
> Randy Bush;
> Bob Fink; Jun-ichiro itojun Hagino; [email-masked]
> Subject: Re: ocean: do not boil
> 
> 
> Keith Moore wrote:
> > 
> > > >   > p2p applications can be designed to use intermediaries,
> > > >   > just like SMTP and HTTP. If I was designing an apps
> > > >   > protocol today, I would definitely make sure it could
> > > >   > be relayed between address spaces at applications level.
> > > >
> > > > => Are we in a position to mandate this?
> > > >
> > >
> > > This is the Internet, so no. But we (or if we were lucky the IAB)
> > > could make an architectural recommendation.
> > 
> > It would strike me as extremely bizarre for the IAB to recommend
> > that P2P applications define their own addressing system and
> > routing protocols when IPv6 offers reasonably good ones.
> 
> Who said anything about a new address space or about routing? 
> 
> Obviously we are talking about scenarios where the basic dual stack
> mechanism fails due to a connectivity gap. You then have two choices
> - resolve this by the sort of network level complexity Margaret's
>   message refers to.
> - resolve it at applications level. This may well involve an
>   applications level identifier namespace that works everywhere, 
>   like URIs or RFC 2822, but it doesn't imply replacing the IP 
>   locator namespace (a.k.a. addresses) or the IP routing system. 
> 
> I'm not suggesting that v6ops should work on this. But it's the
> way distributed computing systems are very likely to go, in 
> self-defence. If the v6ops scenarios ignore this, they are incomplete.
> 
>       Brian
> 
>

---

From: Keith Moore <[email-masked]>
Date: Wed, 25 Sep 2002 05:23:54 -0400

> If the v6ops even try to address this they are going to not be 
> listened too.  Its none of the IETFs business.

oh, that's silly.  developing mechanisms to allow apps to cope with a mixture
of v4 and v6 is certainly within IETF's business.

the reason it won't be listened to is because having apps do their own addressing
and routing is simply too difficult for most implementors.    it will be easier to 
arrange for v6 everywhere (by shipping 6to4 and/or Teredo drivers with the app)
than to build ad hoc networks at layer 7.

Keith