Subject: RE: WG Review: IPv6 Operations (v6ops)

From: "Bound, Jim" <[email-masked]>
Date: Wed, 4 Sep 2002 23:31:29 -0400

I don't hear that from any user in that way.  What I hear is there are several good mechanisms they like and want to apply for different reasons.  

Also the one we are missing in our thinking is the user who will deploy a dominant IPv6 backbone where the only access to IPv4 is simply to reach legacy systems.  They are also the ones deploying trial Mobile IPv6 networks with Mobile IPv6 handhelds.  For them Ipv4 is to be treated as-needed basis.  They don't even want to use 6to4.  They will use ISATAP to jump-start installed base.  They will use DSTM to give out addresses in ad-hoc manner.  These folks will also spend money which is the largest hammer for any mechanism.

But the key missing point in our collective thinking is assuming this type of network for IPv6 will only happen later during IPv6 adoption.  That is plain wrong.  Many of the users of IPv6 are building new and emerging systems that will be IPv6 out of the box and the networks for first deployment.

What we need to do is flush out our assumptions on this mail list and see where we all stand.  

/jim

> -----Original Message-----
> From: Jun-ichiro itojun Hagino [mailto:[email-masked]]
> Sent: Wednesday, September 04, 2002 11:22 PM
> To: Bound, Jim
> Cc: Pekka Savola; Brian E Carpenter; Fred L. Templin; 
> [email-masked]
> Subject: Re: WG Review: IPv6 Operations (v6ops) 
> 
> 
> >Your just plain wrong.  Do you think users are stupid?  Do you think
> >they even care about what we say here in the IETF work?  No 
> they do not.
> > What they want are IPv6 solutions.  And they will all want different
> >ones.
> 
> 	(chair hat off)
> 
> 	the comments i get from the people most is that, they 
> have big trouble
> 	picking which ngtrans mechanisms to pick (for instance, 
> which one
> 	to implement on their router, which one to deploy to 
> their network).
> 	so what we need to do is cut down number of deployment 
> mechanisms,
> 	and help people deploy network in actual use.
> 
> 	as i said in IETF54 plenary, there's no need to deploy 
> fancy IPv6
> 	network.  keep it simple, stupid and robust.
> 
> itojun
>

---

From: Pekka Savola <[email-masked]>
Date: Thu, 5 Sep 2002 14:30:56 +0300 (EEST)

On Wed, 4 Sep 2002, Bound, Jim wrote:
> I don't hear that from any user in that way.  What I hear is there are
> several good mechanisms they like and want to apply for different
> reasons.

For (over?) 95% of folks, they're just distraction.  And what we want here
is to get deployments going.  There's little need for anything fancy if
you don't require it.  

I don't think all of these non-basic, complex, fringe(?) mechanisms should
be discarded -- quite the contrary.  But this is probably(?) not the right 
place.

Waiting for nice mechanism "X" is also a good excuse to delay transition
btw.

> Also the one we are missing in our thinking is the user who will deploy
> a dominant IPv6 backbone where the only access to IPv4 is simply to
> reach legacy systems.  They are also the ones deploying trial Mobile
> IPv6 networks with Mobile IPv6 handhelds.  For them Ipv4 is to be
> treated as-needed basis.  They don't even want to use 6to4.  They will
          ^^^^^^^^^^^^^^^
> use ISATAP to jump-start installed base.  They will use DSTM to give out
> addresses in ad-hoc manner.  [...]
               ^^^^^^^^^^^^^

I could say probably over 99% of folks doing this are not living in 
today's world.

IPv4 just isn't ready to be "as-needed" at the moment, or you're probably
using it in very simple ways (e.g. www browsing only which works quite
well with NAT too :-).  It's IMO very questionable to approach IPv4 
needs with an "ad-hoc" ways when clearly the requirements for IPv4 are 
not, in reality, ad-hoc.

But this is one approach for enterprise transition.  I've been asked about
it myself a few times: organization which would want to start deploying
IPv6 internally, perhaps do some translation or proxying to reach IPv4
sites and just wait for an usable IPv6 Internet to emerge in xxx years.
The problem with this is, really, that unless you can convince (lie :-)  
very well that xxx is not much more than 1-2, IS managers discard this
approach as it generates no added value in the short term.  Most don't
want to be the test-bunnies for fancy technology.

> But the key missing point in our collective thinking is assuming this
> type of network for IPv6 will only happen later during IPv6 adoption.  
> That is plain wrong.  Many of the users of IPv6 are building new and
> emerging systems that will be IPv6 out of the box and the networks for
> first deployment.

I'd like to see this on real world (and not on fancy .ppt).  People always
seem to forget that they do happen to need IPv4 for something (e.g. in the
case of routers, SNMP monitoring, RADIUS authentication for logins etc.)
 
-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords