Subject: RE: ocean: do not boil

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 25 Sep 2002 05:51:51 +0200

> 	it's just like we have transitioned from closed TSS systems like
  > 	compuserve to IP.  we will eventually see services 
  > available only
  > 	over IPv6, IPv4 services (as a collective means) become 
  > less attractive,
  > 	and people will less motivated to maintain their IPv4 
  > connection.
  > 	then IPv4 will gradually cease.
  > 	so yes, IPv4/v6 dual stack age could be very long.  it will take
  > 	a long time until all IPv4-capable-and-configured 
  > devices go away.
  > 
  > 	(speaking of codebase, IPv4 code will stay forever in 
  > the kernel.
  > 	in fact, we still have ISO/CCITT protocol stack in 
  > NetBSD and such...)
  > 

=> I think we're drifting from the main issue 
a little bit. Here is a scenario that I'd like
to understand how it would work:
What do we recommend a new small 3g operator who only
has 10 million subscribers (just a small town
in china!) and wants to allow people to run p2p apps:

a. Run a dual network with 1918 addresses
b. Just run an IPv6 network

If people want to do a), do you really think
this would be simpler than b) ? Easier to manage
and operate? 

Hesham

---

From: [email-masked]
Date: Wed, 25 Sep 2002 14:35:57 +0900

>this would be simpler than b) ? Easier to manage

	"10 million subscriber" scenario is nontrivial by nature.

	for (a), 10.0.0.0/8 space only servers 17 million subscribers
	(theoretical maximum), and since address alloation efficiency is not
	that good, you can't have a single NAT cloud.  you need to split
	customers into multiple NAT clouds (also I don't think any single
	NAT box can take traffic from 10 million subscribers).

	even for (b), I don't think single NAT-PT box (Alain, forget about
	DNSSEC for now) can take traffic from 10 million subscribers, so we
	at least need to split NAT-PT load to multiple NAT-PT box somehow.
	(i assume the customers will want to use IPv4-only yahoo.com.cn, right?)

	so if we need to take a pick, it is between (a) IPv4 multiple NAT cloudm	and global IPv6, or (b) global IPv6 and multiple NAT-PT.

itojun

---

From: Keith Moore <[email-masked]>
Date: Wed, 25 Sep 2002 05:35:17 -0400

> I think we're drifting from the main issue

I think they're going to want to run a dual network for the
near future at least.  but the dual network isn't going to
help with most p2p apps - for the most part it's only going 
to work with two-party (client-server) apps.  if a few
p2p apps can make use of the dual network, so much the better,
but p2p will use IPv6 as soon as it becomes a realistic option...

which I think will be the case when either -
hosts ship with 6to4 and Teredo, or 
the vendor can ship a driver for the above along with the app

Keith