Subject: RE: ocean: do not boil

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 24 Sep 2002 16:41:35 +0200

> 
  > >   > p2p applications can be designed to use intermediaries,
  > >   > just like SMTP and HTTP. If I was designing an apps
  > >   > protocol today, I would definitely make sure it could
  > >   > be relayed between address spaces at applications level.
  > >
  > >=> Are we in a position to mandate this?
  > 
  > We're not in a position to _mandate_ anything.  However, we are
  > in a position to make recommendations about the best way to resolve
  > certain scenarios.

=> I'm not trying to be -ve, but unless we mandate
that all applications will use this model, or alternatively
assume that HTTP and SMTP are the only important applications
for the medium term there is no point eliminating the 
v6 -> v4 scenarios. 
Clearly (at least to me), it would be pointless to start
making "recommendation for application layer protocol
developers" in this group. This _is_ boiling the
ocean IMHO. 

  > Say we have a scenario that runs like this:
  > 
  >          HostA is an IPv6-only node in an IPv6-only network 
  > in SiteA.
  >          HostA wants to reach ServiceB which runs on HostB 
  > in SiteB, an
  >          IPv4-only service on an IPv4-only node in an 
  > IPv4-only network.
  > 
  > Now what are the possible solutions to that scenario?
  > 
  > We could say that the best solution for this scenario is to install
  > a NAT-PT-like box at the border of SiteA, modify the resolver in
  > HostA (or the DNS server for SiteA) so that HostA will 
  > receive special
  > IPv4-mapped addresses instead of A records for IPv4-only hosts,
  > insert special routes to send packets to those addresses to the
  > NAT-PT-like box, and translate traffic to those addresses from
  > IPv6->IPv4 at the border of SiteA.
  > 
  > We could say that the NAT-PT-like box should be installed at the
  > border of SiteB, AAAA DNS entries should be advertised for the
  > IPv4-only hosts within SiteB, routes should be advertised to cause
  > IPv6 traffic to those addresses to come to NAT-PT-like box on the
  > border of SiteB, and packets will be translated from IPv6->IPv4
  > at that border.
  > 
  > Or, we could simply suggest that, if people want to reach IPv4-only
  > services from a given host, they should support IPv4 connectivity to
  > that host.  This would mean installing a dual-stack on HostA and
  > providing IPv4 connectivity (perhaps via NAT if IPv4 
  > address space is
  > an issue) within SiteA.

=> This is a separate discussion from the "recommendations
for applications" discussion I think. 

  > 
  > We can suggest any one of these solutions, and people are, 
  > of course,
  > entitled to ignore us.  Given the choice between these 
  > three, though,
  > the third one seems simpler 

=> Can you please explain why it is "simpler" ? 

and less prone to introducing new
  > architectural and application-level issues, 

=> What does this mean?`what architectural issues
are reduced by v4 NATs? 

since the IPv4 
  > infrastructure
  > would be exactly the same as what many people are using today.

=> Margaret, please consider my concern: I am not talking 
about networks with _existing_ IPv4 infrastructures/NATs.
I hope my intention is clear. I know that many  ISPs 
already have v4 NATs and this is not the case I'm bringing
up.

Hesham

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Sep 2002 17:15:06 +0200

> for the medium term there is no point eliminating the

I didn't suggest eliminating them. But since they will be even worse
to manage than IPv4 NAT, we should use them only when forced to.

   Brian