Subject: RE: ocean: do not boil

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 23 Sep 2002 22:26:08 +0200

I should clarify that my comment was 
in the context of new applications (other than
HTTP and email, i.e. p2p).

Hesham

  > -----Original Message-----
  > From: Hesham Soliman (EAB) [mailto:[email-masked]]
  > Sent: Monday, September 23, 2002 9:43 PM
  > To: 'Bob Hinden'; Margaret Wasserman
  > Cc: Randy Bush; Bob Fink; Jun-ichiro itojun Hagino; 
  > [email-masked]
  > Subject: RE: ocean: do not boil
  > 
  > 
  > 
  >   > >>i don't think we should try to solve the problem of 
  > an arbitrary
  >   > >>user/service on a pure v6 site/host trying to 
  > communicate with a
  >   > >>user/service on a pure v4 site/host or vice versa.
  >   > >
  >   > >I agree with this.
  >   > 
  >   > I don't agree with one case of this.  I think there is a 
  >   > need to have IPv6 
  >   > only hosts that are able to reach the same IPv4 services 
  >   > that an IPv4 host 
  >   > behind a NAT today can reach.  This will make IPv6 only 
  >   > hosts much more 
  >   > attractive than if they can only reach IPv6 services.  This 
  >   > will make IPv6 
  >   > only a real possibility for new deployments of new types of 
  >   > devices.  If we 
  >   > don't support this case, then these devices (and resulting 
  >   > infrastructure) 
  >   > will have to be dual stack.
  > 
  > => I completely agree with Bob. I don't understand how we 
  > can rule out the v6only => v4 only communication. 
  > What do we say to operators who can't get enough
  > v4 addreses? Deploy a v4 NAT as well as IPv6? 
  > 
  > I can understand that communication between a v4only
  > host initiating a connection with a v6 only host
  > is too difficult and probably should not be a priority.
  > 
  > Hesham 
  >

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Sep 2002 11:51:46 +0200

p2p applications can be designed to use intermediaries,
just like SMTP and HTTP. If I was designing an apps 
protocol today, I would definitely make sure it could
be relayed between address spaces at applications level.

   Brian