Subject: RE: ocean: do not boil

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 23 Sep 2002 21:42:59 +0200

> >>i don't think we should try to solve the problem of an arbitrary
  > >>user/service on a pure v6 site/host trying to communicate with a
  > >>user/service on a pure v4 site/host or vice versa.
  > >
  > >I agree with this.
  > 
  > I don't agree with one case of this.  I think there is a 
  > need to have IPv6 
  > only hosts that are able to reach the same IPv4 services 
  > that an IPv4 host 
  > behind a NAT today can reach.  This will make IPv6 only 
  > hosts much more 
  > attractive than if they can only reach IPv6 services.  This 
  > will make IPv6 
  > only a real possibility for new deployments of new types of 
  > devices.  If we 
  > don't support this case, then these devices (and resulting 
  > infrastructure) 
  > will have to be dual stack.

=> I completely agree with Bob. I don't understand how we 
can rule out the v6only => v4 only communication. 
What do we say to operators who can't get enough
v4 addreses? Deploy a v4 NAT as well as IPv6? 

I can understand that communication between a v4only
host initiating a connection with a v6 only host
is too difficult and probably should not be a priority.

Hesham

---

From: Margaret Wasserman <[email-masked]>
Date: Mon, 23 Sep 2002 16:46:18 -0400

>v4 addreses? Deploy a v4 NAT as well as IPv6?

Why not?  How do we think that our attempts at v6->v4
translation will be better than deploying an IPv4 NAT?

>is too difficult and probably should not be a priority.

So, perhaps we are all in agreement on that.

Margaret

---

From: Rob Austein <[email-masked]>
Date: Mon, 23 Sep 2002 17:34:28 -0400

> translation will be better than deploying an IPv4 NAT?

Bingo.

> So, perhaps we are all in agreement on that.

I mostly agree.

- I think it's not too hard to add magic translating routers (or
  whatever) that let IPv4-only boxes at an edge site speak a limited
  form of IPv6 as well (been there, done that, at the detail level
  it's no worse than IPv4 NAPT and in some ways it's not as bad).

- The exactly parallel case of IPv6-only boxes at an edge site is not
  very hard either, but it's also not very interesting, since
  deploying small IPv6-only edge sites onto a dual-service network is
  not likely to be a particularly useful thing to do any time soon.

- The interesting IPv6-only translation case is a big IPv6-only cloud,
  and that one -is- hard, because the translators don't scale well.

- I think that we have enough important work to do that does not
  require translation that I think we should focus on the
  non-translation cases (see, I said I mostly agreed).