Subject: RE: ocean: do not boil

From: "Bound, Jim" <[email-masked]>
Date: Thu, 26 Sep 2002 22:53:33 -0400

most will for sure. what I am concerned about is that we don't have mechanisms for those who want to not do nat at all.  I think I am hearing from margaret and randy they don't want to work on that aspect of v6ops.  I have a problem with that if that is the case and I would ask the working group to support me.

/jim

> -----Original Message-----
> From: Keith Moore [mailto:[email-masked]]
> Sent: Thursday, September 26, 2002 9:25 AM
> To: Bound, Jim
> Cc: [email-masked]; Stewart Tansley; [email-masked]
> Subject: Re: ocean: do not boil 
> 
> 
> > every input I get is that they don't want NAT and want it 
> to go away as 
> > soon as possible.  for "some" (I say some) I am being told 
> how fast can 
> > I get rid of IPv4 period at least on my site.
> 
> that's quite interesting, and encouraging.  what it indicates to me is
> that people need a way to disable IPv4-NAT and still leave 
> IPv6 running.
> I don't think that's rocket science.  
> 
> and I understand why sites might want to get rid of IPv4 as 
> much as possible,
> as soon as possible. but it's hard to believe that most sites 
> won't need at 
> least some IPv4-NAT in addition to IPv6 during a transition phase,
> at least for awhile.   if nothing else many locally-used apps 
> will have IPv4 
> wired into them, and it will take time to upgrade all of those apps. 
> 
> Keith
>

---

From: Keith Moore <[email-masked]>
Date: Thu, 26 Sep 2002 23:05:04 -0400

> what I am concerned about is that we don't have mechanisms 
> for those who want to not do nat at all.

that's a rather odd statement, or at least I don't understand it.
surely we have such mechanisms in native v4 and native v6?

the only legitimate reason to use nat is to compensate for a shortage
of IPv4 addresses.  if a site can get enough IPv4 addresses to not
use NAT for v4, or if the site can avoid using v4 altogether, it 
should never need to use a NAT.

and anyone who makes a NAT for v6 should be fed to piranha fish.

Keith