Subject: RE: ocean: do not boil

From: "Bound, Jim" <[email-masked]>
Date: Mon, 30 Sep 2002 10:40:07 -0400

Rod,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, September 30, 2002 3:03 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: ocean: do not boil 
> 
> 
> Margaret,
> 
> That's a pretty summary.  Thanks.
> 
> Speaking only for myself, not Nokia, I'm of the
> opinion that DSTM doesn't add anything to the 3GPP
> equation.  It's logically equivalent to having
> an IPv6 PDP context always up, and bringing up
> a v4 PDP context on demand.

If one wants security to work e2e for handheld NAT must be avoided.
If there are only X Ipv4 global address space by a provider then 
the provider must manage their usage.
If the provider service is dominant IPv6 usage then the only
reason to use Ipv4 are for services that have not been
migrated to IPv6.  This is where DSTM brings its value.

It permits a network operator to:

1: conserve and manage its precious IPv4 global address space
2: control the use of IPv4 global address space per usage/service
3: identify a migration of services and apps that must move to IPv6
4: avoid the use of any NAT paradigm at the GGSN
5. Use e2e security (e.g. IPsec) inherent on the handheld.
6. Use IPv6 as the dominant routing protocol.

The above cannot be done with NAT-PT.  In addition
DSTM as a solution can be used only when needed and
does not require the routing complexity (except coming back
into the GGSN) that 6to4 does.  But a variation of DSTM is 
also proposed that will use 6to4 if it is part of the DSTM.

DSTM not only is useful for 3G but 802.11 LANs, LMMs,
and WANs which I  see being deployed much faster and 
in fact currently and I see NO 3G deployment at this time.
So I am testing this with 802.11 as  a note and with handheld
devices.  

> 
> The v4 address you get when you bring up that
> PDP context may in fact be allocated via DHCP, of
> course.

See my note to Margaret we also defined this so 
dhcpv6 can be used so no dhcpv4 client must be 
running on the handheld to support the assumption
that the goal is to reduce the reliance on IPv4 
anything in the network or by the node.

Of course 3G has really only done Ipv6 for 
the IM subsystem and still does not even use
MIPv6.  So until 3G evolves further with IPv6 
it is potential that 3G users cannot live with the
DSTM assumptions that the network is 
dominant IPv6 network  which is not the  case 
for 3G current releases.

But for 802.11 this can be the case and actually
to me more important than 3G as it is installing 
as I speak to  you with IPv6.

regards,
/'jim

---

From: "Tony Hain" <[email-masked]>
Date: Mon, 30 Sep 2002 09:02:52 -0700

Jim Bound wrote:
> ...

Rod was correct, in the sense that for a basic 3G network a demand IPv4
PDP context provides the same functionality that DSTM provides to a
routed IPv6 network. The point I think you are trying to make is that
DSTM also works in wireless hot-spot networks, and for an operator that
is interested in a unified mechanism for handsets that roam between the
802.11 & 3G radios, DSTM may be the best approach. If they really are
locked into the point-to-point association between the GGSN & the
handset, they could use L2TP as a companion mechanism when the radio
drops the IPv4 PDP context. 

Tony

---

From: "Jim Fleming" <[email-masked]>
Date: Mon, 30 Sep 2002 11:27:21 -0500

----- Original Message ----- 
From: "Bound, Jim" <[email-masked]>

======

Dual or MULTI Address Space does not require a change in protocol to go end-to-end.

How many addresses does one really need for "handhelds" ?

Do those handhelds set the SNOOPY bit ?

128-bit DNS AAAA Record Flag Day Formats
2002:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent Address]
[YMDD]:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent Address]
1-bit to set the Reserved/Spare ("SNOOPY") bit in Fragment Offset [S]
1-bit to set the Don't Fragment (DF) bit [D]
2-bits to select 1 of 4 common TTL values (255, 128, 32, 8) [LL]
1-bit for Options Control [O]
7-bits to set the Identification Field(dst) [FFFFFFF]
4-bits to set the TOS(dst) Field [TTTT]
Default SDLL.OFFF.FFFF.TTTT = 0000.0000.0000.0000
FFF.FFFF.TTTT = GGG.SSSS.SSSS
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt

Whitehouse Ready to Release Next Generation Internet Plan
http://news.com.com/2100-1023-958159.html?tag=politech
http://www.politechbot.com/p-03994.html
http://www.uscryptomail.org/cybersecurity/
Note: The new plan calls for the same architecture used with IPv8 and IPv16,
whereby, users do not have direct access to the (out-of-band) IPv16 network.

Jim Fleming
2002:[IPv4]:000X:03DB:...IPv8 is closer than you think...IPv16 is even closer...
http://ipv8.dyndns.tv
http://ipv8.yi.org
http://ipv8.dyns.cx
http://ipv8.no-ip.com
http://ipv8.no-ip.org
http://ipv8.no-ip.biz
http://ipv8.no-ip.info
http://ipv8.myip.us
http://ipv8.dyn.ee
http://ipv8.community.net.au
http://ipv8.ods.org