Subject: RE: ocean: do not boil

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 30 Sep 2002 11:30:10 +0200

Hi Margaret, 

Excellent start to the discussion, thanks.

  > I've been thinking about this question and trying to
  > come up with a good answer...
  > 
  > I'm actually thinking of this question a bit differently,
  > so please tell me if it matches what you are asking:
  > 
  > What is the best way to set-up a network of 10 million
  > nodes that all to need access both IPv6-only and IPv4-only
  > services?
  > 
  > There are two thoughts that I have about this question:

=> Good questions, I suggest we focus on those 
first then look at the different solutions.

  > 
  >          (1) It isn't a fully qualified question.
  >                  Further information is needed to
  >                  for a complete answer, such as:
  > 
  >                  - Do these nodes need continuous access
  >                          to IPv4 and IPv6 services, or only
  >                          occasional access?

=> I believe continuous access is needed. a PDP
context will be up when the device is turned
on and remain up pretty much the whole time. 
Some operators will configure things differently
(e.g. if idle for x hours remove PDP context), but
I believe people want to be "always on and connected"
(not meant to be a mrketing stunt!). This is simply
because once you lose your PDP context you're not
reachable.

  >                  - How many simultaneous IPv4 & IPv6
  >                          connections are expected?

=> Depends on the user, this is orthogonal to the 
PDP context(s).

  >                  - What is the planned internal structure
  >                          of the network?  Obviously you aren't
  >                          planning to bridge 10 million nodes
  >                          on a single subnet.

=> No.

  > 
  >          (2) Neither IPv4 nor NAT-PT will handle a 10 million
  >                  node network as a single address space.

=> NAT-PT can handle them in a single address space. Of course
not in a single box. 

  >                  The limitation of 32-bit addressing in IPv4
  >                  is a red herring, since the real limitations
  >                  on the size of a NAT based network is probably
  >                  much lower (a few hundred thousand simultaneous
  >                  connection?).

=> It's a 24-bit address space :) 

  > 
  > But, given that you've said this is a 3GPP network, I can
  > make some (perhaps flawed) assumptions about how this network
  > will be structured:
  > 
  >          (1) There will be internal routers (GGSNs) at a
  >                  density of one per ~100,000-500,000 nodes.

=> Correct.

  >          (2) All nodes will have point-to-point connections
  >                  to a single router (PDP Contexts to the GGSN).

=> correct.

  >          (3) The nodes will only need occasional access to
  >                  IPv4 & IPv6 services.

=> I think continuous accessibility is required.
We don't want to tear down PDP contexts and start
them again too often. 

  >          (4) IPv4 address configuration (and IPv6 address
  >                  configuration) of the nodes will
  >                  be performed on an as-needed basis
  >                  via the establishment of PDP contexts.

=> No, see above.

I will wait with the replies for the second part
of your email until we agree on the assumptions/scenario
first. I think this is very important and a great start
for detailed scenarios. 

Hesham

---

From: "Jim Fleming" <[email-masked]>
Date: Mon, 30 Sep 2002 05:56:54 -0500

----- Original Message ----- 
From: "Hesham Soliman (EAB)" <[email-masked]>
> because once you lose your PDP context you're not

The DNS can help keep things connected...at least the modern DNS can...

http://www.directupdate.net/

Top 10...IPv8 Compatible Dynamic DNS Services
Vote Early and Often...
http://www.kvtek.com/ddnsservices.asp

Other links...

      DynDNS www.dyndns.org 
      Yi www.yi.org 
      DtDNS www.dtdns.com 
      HammerNode www.hn.org 
      EyeP www.eyep.net 
      DynU www.dynu.com 
      easyDNS www.easydns.com 
      No-IP www.no-ip.com 
      dyns.cx www.dyns.cx 
      dnsQ.org www.dnsq.org 
      myIP.org www.myip.org 
      ns1.net www.ns1.net 
      ZoneEdit www.zoneedit.com 
      dyn.ee www.dyn.ee 
      www.centralinfo.net 
      NOLS www.nols.com 
      dhs.org www.dhs.org 
      YYweb.com www.yyweb.com 
      dyn.ca www.dyn.ca 
      DDNS.nu www.ddns.nu 
      miniDNS www.minidns.net 
      DynDNS.dk www.dyndns.dk 
      changeIP www.changeip.com 
      dnsArt www.dnsart.com 
      DSL Reports www.dslreports.com 
      GetmyIP.com www.getmyip.com 

http://www.cafax.se/cgi-bin/where.pl

C@t