Subject: RE: ocean: do not boil

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 1 Oct 2002 14:17:15 +0200

> "Reachable" in what sense?  I can see this argument for
  > the IPv6 PDP Context, since you might run a peer-to-peer
  > service over IPv6 for messaging, or whatever...
  > 
  > But, what advantage is there to having an IPv4 PDP
  > Context up all of the time?  If you are behind any type
  > of NAT (IPv4 NAT or NAT-PT), you won't be reachable
  > from the outside, anyway.

=> I wasn't referring to any particular solution
or type of address. The point I am making is that
regardless of the type of address you have, if you
do not have a PDP context up then you are not reachable.

Even if you have private v4 addresses and you need to
be reachable by someone else inside the same domain
they cannot reach you if you don't have a PDP
context. BTW if you do have an IPv6 address you 
are reachable from the outside (by other v6 hosts).

So you should always have a PDP context and be assigned
at least one address.

  > 
  > 
  > >   >                  - How many simultaneous IPv4 & IPv6
  > >   >                          connections are expected?
  > >
  > >=> Depends on the user, this is orthogonal to the
  > >PDP context(s).
  > 
  > Right, but this is key to the scaling issues for any NAT
  > solution.  The "10 million" nodes (or 100,000-500,000 nodes)
  > number is much less interesting, from a NAT scaling perspective,
  > then the number of simultaneous communication sessions for
  > which the NAT box will need to maintain state.

=> Sure but this is something that network designers will
have to consider, in light of the types of devices/services
that they expect to support.

  > We're in agreement, though, that a single NAT box won't be able
  > to handle 10 million nodes.  Given that fact, I'm not sure that it
  > matters whether the end-hosts behind the NATs are numbered in
  > different ranges of the same address space (as they could be with
  > NAT-PT), or in private address spaces (as with IPv4 NAT).  Both
  > address spaces would be private from the point of view of the
  > IPv4 Internet, requiring translation into globally routable IPv4
  > addresses.

=> Yes, but the different I mentioned earlier
was that there is no overlapping address spaces
in the v6 network. But there will be for large or expanding
private v4 networks.

  > >   >          (3) The nodes will only need occasional access to
  > >   >                  IPv4 & IPv6 services.
  > >
  > >=> I think continuous accessibility is required.
  > >We don't want to tear down PDP contexts and start
  > >them again too often.
  > 
  > Do you know how potential 3GPP operators think about this?  I have
  > heard different things from different equipment manufacturers...

=> I think some would agree with my opinion above, but I 
really can't speak for them. 

  > 
  > However, I'll accept that we want a solution that can handle
  > always-on IPv4 and IPv6 access to every end-node, even if that
  > isn't how all of the networks are deployed.
  > 

=> ok.

  > Are you willing to accept that it would probably make sense, in
  > the 3GPP topology to position the NATs (or either type) in or
  > just behind the GGSNs, rather than having a single (set of) NAT
  > box(es) between the full 10 million node network and the rest of
  > the Internet?

=> You really want to discuss solutions at the same time :)
ok, I accept that it is certainly possible and I don't
rule out that option. In fact I haven't ruled out any option.
But I'm not confident enough to say that this is _the_ way
to do it before I can study current scenarios and rollouts. 
Each operator has different requirements/addresses/plans
...etc and I don't know yet if we can cover all cases with
this approach.

Hesham

---

From: "Jim Fleming" <[email-masked]>
Date: Tue, 1 Oct 2002 08:22:08 -0500

----- Original Message ----- 
From: "Hesham Soliman (EAB)" <[email-masked]>
> So you should always have a PDP context and be assigned

Assigned at least one "address" or "domain name" ?

Dynamic DNS helps to solve the mobility binding problem...
Vote early and often...
http://www.kvtek.com/ddnsservices.asp

Other links...

      DynDNS www.dyndns.org 
      Yi www.yi.org 
      DtDNS www.dtdns.com 
      HammerNode www.hn.org 
      EyeP www.eyep.net 
      DynU www.dynu.com 
      easyDNS www.easydns.com 
      No-IP www.no-ip.com 
      dyns.cx www.dyns.cx 
      dnsQ.org www.dnsq.org 
      myIP.org www.myip.org 
      ns1.net www.ns1.net 
      ZoneEdit www.zoneedit.com 
      dyn.ee www.dyn.ee 
      www.centralinfo.net 
      NOLS www.nols.com 
      dhs.org www.dhs.org 
      YYweb.com www.yyweb.com 
      dyn.ca www.dyn.ca 
      DDNS.nu www.ddns.nu 
      miniDNS www.minidns.net 
      DynDNS.dk www.dyndns.dk 
      changeIP www.changeip.com 
      dnsArt www.dnsart.com 
      DSL Reports www.dslreports.com 
      GetmyIP.com www.getmyip.com