Subject: Re: New draft on embedding the RP address in IPv6 multicast address

From: Greg Shepherd <[email-masked]>
Date: Thu, 10 Oct 2002 19:12:48 -0700 (PDT)

[ post by non-subscriber.  with the massive amount of spam, it is easy to
  miss and therefore delete mis-posts.  so fix subscription addresses! ]

On Thu, 10 Oct 2002, Marshall Eubanks wrote:

> On Thu, 10 Oct 2002 15:07:58 -0700 (PDT)
>  Leonard Giuliano <[email-masked]> wrote:
> >
> > Most PIM implementations switch to the SPT, and stay on it, so you are
> > always going to have this problem.
> >
>
> Yes, but in the ASM service model, there is no need to find the
> addresses etc. of all of the source members, and pass this information around.
>
> In PIM-SM ASM _as practiced_ basically the RP's handle source discovery in a
> distributed fashion. It would not be a bad idea to make this explicit, and I am
> a firm believer in the separation of control and data.
>
> > I think it was Dave M who said that years of concern about state has
> > solved the state problem- there's no mcast traffic.  Let's have a state
> > problem first, then worry about fixing it.
> >
>
> The biggest use of multicast at present, by an order of magnitude or more, is
> the distribution of financial data. Has any of this migrated to SSM ? It could,
> maybe, but will it ?
>
> The amount of money that rides on these multicast packets to me provides a very
> good indication that ASM will stick around.

Not a fair comparison. Financial networks are walled-gardens. In the core
distribution layer of the network, all S,Gs are well-known and in many
casses are ~gauranteed to be delivered too the edge layers by static
S,G-joins - VERY SSM-like.

The growth in many-to-many at the edge networks is beginning to highlight
the need for BiDir - over the next 2 years.

Greg

> Marshall
>
> >
> > On Thu, 10 Oct 2002, Marshall Eubanks wrote:
> >
> > -) 2000 member multi-player games come to mind. I believe that these have
> > -) been done (as military simulations).
> > -)
> > -) SSM will have state and flows that goes as N^2 in this case - the
> > -) real question is, can there be multi-domain solutions that only require
> > -) state and flows of order N.
> > -)
> > -) Regards
> > -) Marshall
> > -)
> > -) Leonard Giuliano wrote:
> > -) > -) >
> > -) > -) > However, you might be able to make ASM "SSM like" in that, if you
> > -) > -) > find the group address by some means out of band, you can join to
> > the RP
> > -) > -) > and either send or receive.
> > -) > -)
> > -) > -) This is actually what is expected to happen.  The steps look like:
> > -) > -)
> > -) >
> > -) > Going back a bit, if this ASM mechanism will rely on SSM-like group
> > -) > discovery, why not just use SSM in the first place?
> > -) >
> > -) > The main problem with SSM in IPv4 is that ASM was already in use, and
> > -) > there aren't enough implementations/deployments of SSM yet.  But v6 need
> > -) > not carry the same albatross of legacy mechanisms around it's neck.
> > It's
> > -) > a chance to do things right from the start.
> > -) >
> > -) > Does anyone actually see any real cases where SSM won't be at least
> > "good
> > -) > enough?"  Is all the complexity of ASM, and the duct tape solutions
> > being
> > -) > discussed worth it just so that SDR will work?
> > -) >
> > -) >
> > -) > -Lenny
> > -) >
> > -)
> > -)
> > -) --
> > -)                                   Regards
> > -)                                   Marshall Eubanks
> > -)
> > -)
> > -) T.M. Eubanks
> > -) Multicast Technologies, Inc
> > -) 10301 Democracy Lane, Suite 410
> > -) Fairfax, Virginia 22030
> > -) Phone : 703-293-9624       Fax     : 703-293-9609
> > -) e-mail : [email-masked]
> > -) http://www.multicasttech.com
> > -)
> > -) Test your network for multicast :
> > -) http://www.multicasttech.com/mt/
> > -)   Status of Multicast on the Web  :
> > -)   http://www.multicasttech.com/status/index.html
> > -)
> >
> >
>
>

---

From: "Marshall Eubanks" <[email-masked]>
Date: Thu, 10 Oct 2002 22:34:21 -0400

On Thu, 10 Oct 2002 19:12:48 -0700 (PDT)
> S,G-joins - VERY SSM-like.

Hi Greg;

I do not disagree - its just that I think that they will resist change.

> the need for BiDir - over the next 2 years.

Good point.

Marshall

---

From: Brian Haberman <[email-masked]>
Date: Fri, 11 Oct 2002 09:54:39 -0400

>>On Thu, 10 Oct 2002, Marshall Eubanks wrote:

[major snip]

>>>The biggest use of multicast at present, by an order of magnitude or more,
>>
>>is
>>
>>>the distribution of financial data. Has any of this migrated to SSM ? It
>>
>>could,
>>
>>>maybe, but will it ?
>>>
>>>The amount of money that rides on these multicast packets to me provides a
>>
>>very
>>

Not only is it ASM, some financial data distributors are still using
DVMRP.  They like it and they know it.

>>S,G-joins - VERY SSM-like.

And because the S's are known, they can use dynamic filters to switch
to backup sources when connectivity goes down.

>>the need for BiDir - over the next 2 years.

So, back to an interesting discussion point.  Do we need to worry about
ASM in v6?  Should we as the multicast standards community try and
move things toward SSM?

Brian