Subject: RE: 6to4 usage scenarios

From: "Bound, Jim" <[email-masked]>
Date: Sat, 23 Nov 2002 22:27:11 -0500

It should be used as Brian stated and with the intention brian stated.
This is a gigantic rathole with no need to be here.

/jim
[Honor, Commitment, Integrity]

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Thursday, November 21, 2002 9:14 PM
> To: [email-masked]
> Subject: 6to4 usage scenarios
> 
> 
> Hello,
> 
> It seems like the 6to4 security discussion degenerated into 
> argument on 
> how it was meant to be used.
> 
> There are two basic models of connecting 6to4 routers to relays:
> 
> 1) simple static route to your relay
> 2) BGP sessions to your relay and all the other relays where 
> you want to 
> receive native IPv6 packets from
> 
> I know of _no_ deployments of 2) even though Brian insists on 
> that being the only "real" 6to4 usage scenario.  Does anyone 
> know this being used?
> 
> If not, I think we must acknowledge that 2) is not really 
> right-tool-for-the-job (think of 6over4 **), and that 1) is 
> the primary
> (only?) applicability target of 6to4.
> 
> The alternative is that we have gaping holes in Home/SOHO and 
> partially 
> maybe enterprise transition scenarios, and nothing to fill 
> them at the 
> moment.
> 
> **) 6over4 is a nice technique, and we could even use it -- 
> but we don't 
> want stuff like that.  The same IMO applies to 6to4+BGP.  
> There is no use 
> specifying mechanisms for the audience who does not want them.
> 
> P.S. I only came to the wg after 6to4 had just gone RFC, this 
> internal bickering really took me off surprise and made me 
> both frustrated and angry about refusing to accept the reality.
> 
> -- 
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> 
> 
> 
> 
> 
>

---

From: Pekka Savola <[email-masked]>
Date: Sun, 24 Nov 2002 11:20:57 +0200 (EET)

> This is a gigantic rathole with no need to be here.

Do you have an idea what to use instead of 6to4 for smaller deployments?

Tunnel brokers are a possibility, about the only one I think.  But those 
require more configuration and aren't really that commonplace today 
either.

> > -----Original Message----- From: Pekka Savola
> > [mailto:[email-masked]] Sent: Thursday, November 21, 2002 9:14 PM
> > To: [email-masked] Subject: 6to4 usage scenarios
> > 
> > 
> > Hello,
> >