Subject: RE: 3gpp transition solutions, revision -02

From: <[email-masked]>
Date: Thu, 7 Nov 2002 17:42:42 -0800

Hi,

sorry to step into the discussion so late. (I had computer trouble for a while!)

I would like to remind everybody that as IMS is _exclusively_ IPv6, and the NAT-PT (or a flavor of that) is just an interworking solution to a non-IMS network that supports IMS like services. (Confusing enough?;)

This means that IMS itself has no interworking problems, no NATs, no NAT-PTs, and no IPv4 - it is only IPv6. Thus, there are no problems inside the IMS. The NAT-PT would come to the picture if, for instance, you have to place a call to another "system" that does not support v6. (It may be that you have to do another kind of translation as well, e.g. SIP to H.323, or SIP to ISUP, or whatever.) The NAT-PT would be an interworking function to an outside world - not an internal part!

People seem to write all the time that with dual-stack you can fix the interworking problems of IMS. That however is not true, because you end up with normal NAT for your IPv4 connections. You cannot get (at least in certain areas of the world) enough IPv4 addresses to even support it as an interworking method and to have global addresses. In addition, you end up having a dual-stack in your phones until the end of time or to the point where the last _possible_ IPv4 device in the world would be extinct! These are just some of the reasons why 3GPP decided to have IPv6 only IMS.

Anyways, the 3GPP specifications (as Hesham pointed out) now say that this network/system, the IMS, is exclusively IPv6. We cannot change the specs, and there is no reason for changing them - the contrary. I would propose that we concentrate now on solving the problem instead of changing the problem.

Cheers,

Jonne.

> -----Original Message-----
> From: ext Keith Moore [mailto:[email-masked]]
> Sent: Thursday, November 07, 2002 9:21 AM
> To: BELOEIL Luc FTRD/DMI/CAE
> Cc: Brian E Carpenter; Hesham Soliman (EAB); [email-masked]
> Subject: Re: 3gpp transition solutions, revision -02 
> 
> 
> > For SIP-based services an application proxy is not sufficient.
> 
> and NAT-PT is sufficient?  from my limited knowledge of SIP I 
> find this 
> surprising.
> 
> however I don't see a huge problem with using NAT-PT only for 
> a specific
> set of well-defined services on networks with known characteristics; 
> presumably it can be adapted as needed to accomodate those services.  
> 
> the imposition of NAT-PT on other services is of course a 
> separate question.
> 
>

---

From: Keith Moore <[email-masked]>
Date: Thu, 07 Nov 2002 21:32:49 -0500

thanks for the explanation.  the approach makes sense to me.

Keith

> I would like to remind everybody that as IMS is _exclusively_ IPv6, and the
> NAT-PT (or a flavor of that) is just an interworking solution to a non-IMS
> network that supports IMS like services. (Confusing enough?;)

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 08 Nov 2002 11:12:03 +0100

[email-masked] wrote:
> This means that IMS itself has no interworking problems, no NATs, no NAT-PTs, and no IPv4 - it is only IPv6. Thus, there are no problems inside the IMS. The NAT-PT would come to the picture if, for instance, you have to place a call to another "system" that does not support v6. (It may be that you have to do another kind of translation as well, e.g. SIP to H.323, or SIP to ISUP, or whatever.) 

(BC) And if that is the case, the IWU that does this translation can be dual
stacked, with its IPv6 stack talking to IMS and its IPv4 stack talking
to the legacy system. If you do that, NAT-PT isn't needed.

> The NAT-PT would be an interworking function to an outside world - not an internal part!

(BC) Agreed. So let's try to get rid of it by using dual stack IWUs instead.
> 
> People seem to write all the time that with dual-stack you can fix the interworking problems of IMS. That however is not true, because you end up with normal NAT for your IPv4 connections. You cannot get (at least in certain areas of the world) enough IPv4 addresses to even support it as an interworking method and to have global addresses. 

(BC) Agreed. That's why I think you should dual stack the IWUs only.

> In addition, you end up having a dual-stack in your phones until the end of time or to the point where the last _possible_ IPv4 device in the world would be extinct! These are just some of the reasons why 3GPP decided to have IPv6 only IMS.

(BC) Which was an excellent decision.

> Anyways, the 3GPP specifications (as Hesham pointed out) now say that this network/system, the IMS, is exclusively IPv6. We cannot change the specs, and there is no reason for changing them - the c…

(BC) Indeed. And given that the set of applications on 3G devices is likely to be
constrained, we can concentrate on the IWUs.

Now, what's the answer to Keith's point below? 

  Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland