Subject: Another issue !!

From: "Thakur, Anand" <[email-masked]>
Date: Thu, 19 Dec 2002 10:12:26 +0530

Hi all,
I have another issue in mind.
Let's say a dual stack UE establishes a V6 pdp context with it's GGSN. But
the destination node is V4 and the intermediate network (internet) is also
V4. Assuming that the GPRS operator's network supports both IPV6 and V4, is
there any way the GGSN and UE can mutually agree to replace the active V6
pdp context by a V4 one and thus avoid any unnecessary translation?

regards
Anand Thakur
HCL Perot Systems (A SEI CMM Level 5 Company)
Plot No 3, Sector 125, NOIDA (UP)-201301, India
* Tel  +91 120 4432755-79, X3348 (EPABX)
mobile:9811748512

> -----Original Message-----
> From:	Pekka Savola [SMTP:[email-masked]]
> Sent:	Thursday, December 19, 2002 4:17 AM
> To:	Karim El-Malki (EAB)
> Cc:	[email-masked] '; [email-masked] ';
> [email-masked] '; [email-masked] ';
> [email-masked] '
> Subject:	RE: FW: 3gpp scenario 2
> 
> On Wed, 18 Dec 2002, Karim El-Malki (EAB) wrote:
> > This is exactly the case. The tunnelling mechanisms paragraph
> > mentions explicitly the case where it applies:
> >
> >     In a 3GPP
> >     network, one IPv6 island could contain the GGSN while another
> >     island contains the operator's IPv6 application servers....
> 
> I disagree: it _could_ be a case.
> 
> It also reads:
> 
>     Encapsulating node can be e.g. the GGSN or the edge router between
>     the border of the operator's IPv6 network and the public Internet.
> 
> this makes it very apparent to me that main focus was tunneling in the 
> internet -approach.
> 
> 
> > >But if this is important, here something like [BGP][IGP] could be
> > >usable.  
> > 
> > OK, so I think we agree that this scenario makes sense.
> 
> As currently written, I totally disagree.
> 
> IGP/BGP tunneling and mechanisms like these are _additional complexity_.
> 
> Such mechanisms should not be advocated -- in the face of configured
> tunneling which is far superior for a small-to-moderate number of islands 
> -- without a lot of care.
> 
> IMO there's something really wrong in the 3GPP operator's network if it
> needs to have e.g. more than 10-15 isolated IPv6 islands there (~ reaching
> one limit where in some cases configured tunneling could become more
> difficult to maintain).
> 
> btw. the ridiculously long paragraph should be split in about 5.
> 
> -- 
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> 
>

---

From: <[email-masked]>
Date: Thu, 19 Dec 2002 07:15:16 +0200

Anand,

in my opinion this is not an issue. I suppose that in the case you describe below, IPv4 PDP context would have been used anyway. Of course, we do not unnecessarily want to use translation. And PDP contexts can be activated / de-activated based on the (application) need.

Another issue is that is there enough public IPv4 addresses? If a private IPv4 address is allocated to the terminal, IPv4 NAT would be needed...

BR,
	-Juha-

-----Original Message-----
From: ext Thakur, Anand [mailto:[email-masked]]
Sent: 19 December, 2002 06:42

regards
Anand Thakur