Subject: FW: 3gpp scenario 2

From: <[email-masked]>
Date: Tue, 17 Dec 2002 14:38:07 +0200

Hi, Luc!

Our proposed solution concluding that "In most 3GPP scenarios it is preferred to use manually configured tunnels or EGP/IGP based tunneling mechanisms." is written in "3GPP analysis" chapter 3.2. 

In my comment below I just refer to using "IPv6 in IPv4" tunnels from the operator's network to other IPv6 islands - configured tunneling makes sense, if there is a limited number of other IPV6 islands you need to connect to. Note that we also state 

   "However, manually 
    configured tunnels can be an administrative burden when the number 
    of islands and therefore tunnels rises. Therefore it is also 
    possible to use dynamic tunneling mechanisms such as "6to4" 
    [RFC3056] and IGP/EGP routing protocol based tunneling mechanisms 
    [BGP][IGP]."

in our analysis doc.

BR,
	-Juha-

-----Original Message-----
From: ext BELOEIL Luc FTRD/DMI/CAE [mailto:[email-masked]]
Sent: 17 December, 2002 13:52

Can you clarify: "What if we already have some static "IPv6 in IPv4" tunnels configured from the operator's network to, say, IPv6 internet / 6bone and there is IPv6 connection to node B?"
My small experience shows that configuring static tunnels becomes quickly boring. I would prefer a 6to4-based solution. But it seems that security issues are remaining... I have to check that.
Luc

-------- Message d'origine-------- 
De: [email-masked] [mailto:[email-masked]] 
Date: mar. 17/12/2002 12:23 
À: [email-masked] 
Cc: [email-masked] 
Objet: RE: 3gpp scenario 2

Anand,

I assume that this is a very common problem / environment in initial IPv6 deployment, i.e. two separate IPv6 islands connected by IPv4 network using "IPv6 in IPv4" tunneling and solutions have already been thought by several (DNS) experts.

What if we already have some static "IPv6 in IPv4" tunnels configured from the operator's network to, say, IPv6 internet / 6bone and there is IPv6 connection to node B?

I am very happy to receive more comments on this issue.

Thanks,
        -Juha-

-----Original Message-----
From: ext Thakur, Anand [mailto:[email-masked]]
Sent: 17 December, 2002 13:01
To: Wiljakka Juha (NMP/Tampere)
Cc: V6ops (E-mail)
Subject: 3gpp scenario 2

hi huha,
i was just wondering about the scenario in which 2 IPV6 UEs communicate over
an IPV4 network. In this scenario won't initial DNS resolution be a very
difficult job (if not impossible)?
If you have not understood my question read this example:
Let Host A be on IPV6 netork X and Host B on IPV6 network Y. Now, if A makes
a DNS query ("A") for B, none of the name resolvers in network X will have
an entry for B . How will this query finally reach network Y, assuming all
intermediate routers are IPV4 only? Will A have to explicitly tunnel this
request to network Y? I am also assuming that DNS servers in the IPV4
internet don't support "AAAA".

regards
Anand Thakur
HCL Perot Systems (A SEI CMM Level 5 Company)
Plot No 3, Sector 125, NOIDA (UP)-201301, India
* Tel  +91 120 4432755-79, X3348 (EPABX)
mobile:9811748512

---

From: Pekka Savola <[email-masked]>
Date: Tue, 17 Dec 2002 21:09:46 +0200 (EET)

On Tue, 17 Dec 2002 [email-masked] wrote:
> Our proposed solution concluding that "In most 3GPP scenarios it is
> preferred to use manually configured tunnels or EGP/IGP based tunneling
> mechanisms." is written in "3GPP analysis" chapter 3.2.
> 
> In my comment below I just refer to using "IPv6 in IPv4" tunnels from
> the operator's network to other IPv6 islands - configured tunneling
> makes sense, if there is a limited number of other IPV6 islands you need
> to connect to. Note that we also state
> 
>    "However, manually 

I think one should keep in mind that it's not necessary to reach every 
IPv6 island directly (a usual justification for e.g. IGP/EGP tunneling).

I think we can pretty much discard [BGP][IGP] from scenario 2 too -- 
they're applicable for smaller-than-Internet scopes, which scenario 2 does 
not seem to be at all.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords