Subject: 3gpp scenario 2

From: "Thakur, Anand" <[email-masked]>
Date: Tue, 17 Dec 2002 16:31:00 +0530

hi huha,
i was just wondering about the scenario in which 2 IPV6 UEs communicate over
an IPV4 network. In this scenario won't initial DNS resolution be a very
difficult job (if not impossible)? 
If you have not understood my question read this example:
Let Host A be on IPV6 netork X and Host B on IPV6 network Y. Now, if A makes
a DNS query ("A") for B, none of the name resolvers in network X will have
an entry for B . How will this query finally reach network Y, assuming all
intermediate routers are IPV4 only? Will A have to explicitly tunnel this
request to network Y? I am also assuming that DNS servers in the IPV4
internet don't support "AAAA".

regards
Anand Thakur
HCL Perot Systems (A SEI CMM Level 5 Company)
Plot No 3, Sector 125, NOIDA (UP)-201301, India
* Tel  +91 120 4432755-79, X3348 (EPABX)
mobile:9811748512

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 17 Dec 2002 13:26:46 +0100

"Thakur, Anand" wrote:
...
> I am also assuming that DNS servers in the IPV4

What makes you think so? Here is the output from nslookup
inside a network that I promise you is IPv4 only. AAAA records
travel just fine over an IPv4 network.

> set querytype=ANY
> ns3.surfnet.nl
Server:  <private>.ibm.com
Address:  9.<private>

Non-authoritative answer:
ns3.surfnet.nl  IPv6 address = 2001:610:1:800b:a00:20ff:fe9a:16eb
ns3.surfnet.nl  internet address = 195.169.124.71

Authoritative answers can be found from:
(root)  nameserver = J.ROOT-SERVERS.NET
(root)  nameserver = K.ROOT-SERVERS.NET
(root)  nameserver = L.ROOT-SERVERS.NET
(root)  nameserver = M.ROOT-SERVERS.NET
(root)  nameserver = A.ROOT-SERVERS.NET
<etc>

    Brian