Subject: RE: on NAT-PT

From: "Thakur, Anand" <[email-masked]>
Date: Fri, 6 Dec 2002 09:48:41 +0530

i agree.
 what if we do the following:
whatever the incoming response, the dns_alg will forward 2 responses to the
client:
1)if the response is v4 only, then the dns_alg along with the v4 response
will forward a mapped v6 response.
2)vice-versa if the response is v6 only
3)if 2 responses are received then forward them both to the client

a simple functionality in the client may be able to discard the not-required
result. though this will require a bit of effort on the part of the dns_alg,
but is nothing as compared to the effort that excessive translation will
cause.

regards
Anand Thakur
HCL Perot Systems
A-14 Sector-57,Noida
tel ext. - 3257
mobile:9811748512

> -----Original Message-----
> From:	Ronald van der Pol [SMTP:[email-masked]]
> Sent:	Thursday, December 05, 2002 6:37 PM
> To:	Thakur, Anand
> Cc:	Christian Huitema; [email-masked]; [email-masked];
> [email-masked]
> Subject:	Re: on NAT-PT
> 
> On Thu, Dec 05, 2002 at 13:13:24 +0530, Thakur, Anand wrote:
> 
> > 
> > hi christian,
> > i don't think this a problem in na(p)t-pt, but more a problem in the way
> > dns-alg works. for instance, if we could configure the dns-alg in such a
> way
> > that it does the following:
> 
> Suppose a dual-stack client asks for an AAAA.
> 
> > 1)maintain a table which maps the source ip address of the dns query and
> the
> > type of query ("A" or "AAAA")
> 
> Map that dual-stack client has asked for AAAA.
> 
> > 2)generate a dual-query ("A" + "AAAA") every time a dns query is
> detected.
> 
> Send A+AAAA queries. Suppose you receive A response only.
> 
> > 3)when it intercepts a dns response it should 
> > ->translate the "A" response to "AAAA" response if the original quey was
> > "AAAA" and the response is "A" only
> 
> So, the A response is mapped to AAAA and send to the dual-stack client.
> That's not what you want. You want the dual-stack client to communicate
> over v4 transport with the destination. So, should not send a mapped
> AAAA to the dual-stack client. The dual-stack client should retry and
> ask for A.
> 
> 	rvdp

---

From: Senthil Sivakumar <[email-masked]>
Date: Thu, 05 Dec 2002 22:48:36 -0800

>will forward a mapped v6 response.

How does the dns alg know that there won't be a v6 response for the same query.

>but is nothing as compared to the effort that excessive translation will

Most of the clients only care about the first response and discard others. 
Now you
are suggesting that the client to be changed which does not sound very 
appealing.

Senthil