Subject: RE: REVIEW NEEDED: draft-ietf-v6ops-ent-analysis-00.txt (UNCLASSI FIED) (UNCLASSIFIED)

From: "Klynsma, Steven L Mr CIO/G6/MITRE" <[email-masked]>
Date: Thu, 14 Oct 2004 09:36:20 -0400

Classification:  UNCLASSIFIED 
Caveats: NONE

Brian,

I'm sure you're aware that the military has much to gain by taking on a "commercial" flavor.  By that I mean reducing our dependence on government-developed equipment and using the stuff already available in commercial sector.  Therefore, we take great pains to use commercial terminology (as opposed to military) and would hope that a separate solution for our environment can be avoided.

Steve 

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Thursday, October 14, 2004 9:02 AM
To: Klynsma, Steven L Mr CIO/G6/MITRE
Cc: 'Bound, Jim'; [email-masked]
Subject: Re: REVIEW NEEDED: draft-ietf-v6ops-ent-analysis-00.txt (UNCLASSI FIED)

Steve,

Yes, I am fully aware of Network Centric Operations requirements.
Somehow I don't think of the DoD as an "enterprise" and my comments are all in the context of my understanding of enterprises.
Obviously, a solution is needed in the scenario you describe, but I'd like to think of it as separable.

    Brian

Klynsma, Steven L Mr CIO/G6/MITRE wrote:
> Classification:  UNCLASSIFIED
> Caveats: NONE
> 
> Brian,
> 
> I work for the military and would dearly love to go to a dual-stack everywhere, but as Jim mentioned, that's simply not feasible.  Unlike commercial users, we typically must develop our own unique comms networks that support unique military requirements (i.e. extremely constrained bandwidth (we feel lucky to have 16KBPS "pipes"), unpredictable, but inevitable and often lengthy, disconnects from network services, and a need for both host and routing infrastructure to be mobile).  In such an environment, operating two routing protocols, as you must with dual-stack becomes quite problematic.  In addition, because of the lengthy life cycles of weapon systems (15-20 years), you find yourself working with processors that are overloaded already.  Throw a dual-stack requirement on this tactical environment and you break the camels back.  
> 
> So we are typically looking at replacing the entire tactical comms infrastructure.  Given the other constraints on bandwidth, mobility, etc., it becomes very attractive to make the leap from IPv4 directly to IPv6 without a lengthy dual-stack transition period.  However, that essentially creates an IPv6-only ISP supporting our weapon systems on the battlefield.  Of course, this, in turn, comes with another set of problems, primarily for interoperablity with IPv4-based current systems and allies, but we hope by aggressively migrating the force to IPv6-dominance that these additional problems become manageable.
> 
> Vr,
> 
> Steve

<snip>
Classification:  UNCLASSIFIED 
Caveats: NONE

---

From: Pekka Savola <[email-masked]>
Date: Thu, 14 Oct 2004 21:20:21 +0300 (EEST)

On Thu, 14 Oct 2004, Klynsma, Steven L Mr CIO/G6/MITRE wrote:
> I'm sure you're aware that the military has much to gain by taking
> on a "commercial" flavor.  By that I mean reducing our dependence on
> government-developed equipment and using the stuff already available
> in commercial sector.  Therefore, we take great pains to use
> commercial terminology (as opposed to military) and would hope that
> a separate solution for our environment can be avoided.

I'm not sure how to read this.  This could be read as: 'so, if we want
to use a "commercial flavour" but have already decided on which model
we want to adopt, we need to push our deployment model to the
commercial sector, so that they'll have something in common with us,
and we don't need any special software or hardware'.

That would seem to be .. rather questionable, but here are probably
other interpretations as well.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 15 Oct 2004 14:28:36 +0200

Fully understand in terms of solutions. I meant "separable" for
the purposes of analysis.

    Brian

---

From: Tim Chown <[email-masked]>
Date: Fri, 15 Oct 2004 15:30:04 +0100

I see no reason why the scenario should not be included in ent-analysis,
after all it is Scenario 3 of the ent-scenarios document.

See page 7 of:
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-ent-scenarios-05.txt

Thus my view is it must be in this analysis.

Tim

On Fri, Oct 15, 2004 at 02:28:36PM +0200, Brian E Carpenter wrote:
> >I'm sure you're aware that the military has much to gain by taking on a 
> >"commercial" flavor.  By that I mean reducing our dependence on 
> >government-developed equipment and using the stuff already available in 
> >commercial sector.  Therefore, we take great pains to use commercial 
> >terminology (as opposed to military) and would hope that a separate 
> >solution for our environment can be avoided.
> >
> >Steve 
> >
> >Somehow I don't think of the DoD as an "enterprise" and my comments are 
> >all in the context of my understanding of enterprises.
> >>I work for the military and would dearly love to go to a dual-stack 
> >>everywhere, but as Jim mentioned, that's simply not feasible.  Unlike 
> >>commercial users, we typically must develop our own unique comms networks 
> >>that support unique military requirements (i.e. extremely constrained 
> >>bandwidth (we feel lucky to have 16KBPS "pipes"), unpredictable, but 
> >>inevitable and often lengthy, disconnects from network services, and a 
> >>need for both host and routing infrastructure to be mobile).  In such an 
> >>environment, operating two routing protocols, as you must with dual-stack 
> >>becomes quite problematic.  In addition, because of the lengthy life 
> >>cycles of weapon systems (15-20 years), you find yourself working with 
> >>processors that are overloaded already.  Throw a dual-stack requirement 
> >>on this tactical environment and you break the camels back.  
> >>So we are typically looking at replacing the entire tactical comms 
> >>infrastructure.  Given the other constraints on bandwidth, mobility, 
> >>etc., it becomes very attractive to make the leap from IPv4 directly to 
> >>IPv6 without a lengthy dual-stack transition period.  However, that 
> >>essentially creates an IPv6-only ISP supporting our weapon systems on the 
> >>battlefield.  Of course, this, in turn, comes with another set of 
> >>problems, primarily for interoperablity with IPv4-based current systems 
> >>and allies, but we hope by aggressively migrating the force to 
> >>IPv6-dominance that these additional problems become manageable.
> >>
> >>Vr,
> >>
> >>Steve
> >
> >
> >
> ><snip>

-- 
Tim

North American IPv6 Task Force Technologist Seminar
More info at http://www.ipv6seminar.com/