Subject: Re: Draft on ISP broad-band deployment scenarios

From: Gert Doering <[email-masked]>
Date: Thu, 7 Oct 2004 18:48:56 +0200

Hi,

answering a specific bit out of this...

On Fri, Sep 24, 2004 at 10:32:22AM +0300, Pekka Savola wrote:
> > This is true but we have observed many of the BB ISPs are interested in 
> > deploying native IPv6, driven by new services such as VoD using Multicast 
> > and etc.  Some of the examples for these BB ISPs, who are deploying IPv6 
> > are NTT in Japan, Spacenet in Germany, Dolphin in Switzerland, Nerim in 
> > France, XS4ALL in The Netherlands and etc.
> 
> Sure.  But do these ISPs use a link-layer which supports multicast,
> e.g., bridged-mode DSL (I think it does..)?
> 
> That is, if you do something like L2TPoE (which I think many are 
> doing), doesn't that require that multicast transmission be 
> duplicated (on a lower layer) in any case, causing equal amount of 
> traffic as a tunneling based distribution?

Our (SpaceNet's) DSL stuff is either PPPoE/L2TP based or ATM-PVC-based
(bridged or routed mode).

Neither has native support for Multicast (in the sense of "the network
duplicates the packets"), so the benefits of multicasts are only
in the uplink towards the DSL aggregation routers, and possibly if
multiple users behind the same DSL line (small offices) are receiving
the same multicast data stream.

[..]
> Extra investment is always possible, and many will certainly do it.  
> The question is just how the ISPs would transition from "v4-only" to 
> "v4+v6 natively".  My argument is that it would be easier for the ISPs 
> to start with tunneling and native v6 where possible, than to require 
> through-out upgrade to native v6.

Full ACK here.  Some parts are just hard/expensive to get v6 on, 
while others can be done fairly easily.  So you end up tunneling
around those "difficult" bits, even if the rest of the network is
already native.

Gert Doering
        -- NetMaster
-- 
Total number of prefixes smaller than registry allocations:  66629  (65398)

SpaceNet AG                 Mail: [email-masked]
Joseph-Dollinger-Bogen 14   Tel : +49-89-32356-0
80807 Muenchen              Fax : +49-89-32356-299

---

From: Alexander Koch <[email-masked]>
Date: Thu, 7 Oct 2004 19:57:11 +0200

All,

> answering a specific bit out of this...

that applies for me, too.

> the same multicast data stream.

That being said, take also into consideration that bitstream
access is not widely available yet in Europe or the invests
are just not worth it. so the next option would be to get the
traffic via L2TP, and the multicast buys you absolutely nothing
as too many DSL providers effectively do not save a penny. And
of course this applies to IPv4, and I do not see it changing
anytime soon. (Despite the effort by BBC, for example, or AMT
which is promising, all v4 though)

> around those "difficult" bits, even if the rest of the network is

Take the Juniper ERX for an example. J's licensing model is
a major showstopper for several operators to even consider
providing IPv6 to their end users. ;-\ With the typical end
user setup if the typical vendors (J, Redback, Cisco, you
name it) get this working normally that will be the main
driving factor in my view for operators to actually try it
at all.

Mind you, my 2 cents worth, we run IPv6 natively for some
time now in all our core, and that is what we encounter when
trying to convince the powers that be. AS-TISCALI-V6PEERS. :-)

Regards,
Alexander

-- 
Alexander Koch <[email-masked]> / ako4-ripe
Tiscali Int., Peering Coordination
Phone +49 6103 916 480, Fax +49 6103 916 464

---

From: Salman Asadullah <[email-masked]>
Date: Mon, 11 Oct 2004 11:26:25 -0700

Thanks for your feedback Gert.

We are working on the second version of our draft and integrating all the 
feedback we have received.

Regards,
Salman

---

From: Salman Asadullah <[email-masked]>
Date: Mon, 11 Oct 2004 11:29:07 -0700

Thanks for your feedback Alexander.

Regards,
Salman