Subject: Re: I-D ACTION:draft-yamamoto-v6tc-security-considerations-00.txt

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 14 Jul 2005 11:44:37 +0200

Hi Shu,

I don't agree either. I mean, there is no cost for changing any servers,
there is no cost for replacing any routers.

There may be some minor cases where your infrastructure is so old, and not
kept updated, that IPv6 might imply a cost, but the cost is not because IPv6
per-se, but because you don't have a good supplier or an out-dated
equipment, etc.

My experience show that a good ISP and corporate will have usually their
infrastructure up-dated, even with some kind of maintenance contract, which
will support IPv6 as an added value, not as a dedicated cost.

The only cost that some times it can brought to the table is the expertise
for doing it: Training for the people who manages the network basically.

Regards,
Jordi

> De: Shu Yamamoto <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Thu, 14 Jul 2005 16:33:01 +0900
> Para: <[email-masked]>, "[email-masked]" <[email-masked]>
> Asunto: Re: I-D ACTION:draft-yamamoto-v6tc-security-considerations-00.txt
> 
> Hi Jordi;
> 
> Thank you for the comment and correcting the word.
> We meant the cost for the replacement of IPv4 network facilities
>  such as routers, servers etc to IPv6 facilities. But the
> technical complexity should not be stated as you pointed out.
> 
> Best Regards,
> Shu
> 
>  <[email-masked]> の、
>    "Re: I-D ACTION:draft-yamamoto-v6tc-security-considerations-
> 00.txt" において、
>    "JORDI PALET MARTINEZ <[email-masked]>"さんは書き
> ました：
> 
>> Hi,
>> 
>> A couple of comments about this document.
>> 
>> 1. Intro. I don't think is correct to say that a major impediment is the
>> high cost and technical complexity. Sorry, but isn't the case, and we must
>> not give this message. In some cases it might be the case, but not in
>> general. I'm working everyday in moving real customers to support native
>> IPv6, and haven't found this situation yet, and not talking about just a
>> dozen of customers.
>> Actually I'm starting to feel that most of the people is afraid of IPv6
>> because they got this impression.
>> 
>> 3 ... It may be better to use instead of adversary "malicious user" or
>> something else ? I mean adversary may seem as "business competitor" or have
>> other connotations, which I guess are not the intended ones ?
>> 
>> Regards,
>> Jordi
>> 
>> 
>> 
>> 
>>> De: "[email-masked]" <[email-masked]>
>>> Responder a: "[email-masked]" <[email-masked]>
>>> Fecha: Tue, 12 Jul 2005 15:50:03 -0400
>>> Para: <[email-masked]>
>>> Asunto: I-D ACTION:draft-yamamoto-v6tc-security-considerations-00.txt
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts
>>> directories.
>>> 
>>> 
>>> Title  : Security Considerations for the Tunnel Broker
>>>                           Model
>>> Author(s) : S. Yamamoto, et al.
>>> Filename : draft-yamamoto-v6tc-security-considerations-00.txt
>>> Pages  : 9
>>> Date  : 2005-7-12
>>> 
>>>    Tunnel brokers must implement protections against a wide variety of
>>>    threats.  This draft discusses the security considerations for a
>>>    configured tunneling configuration mechanism such as that described
>>>    by the Tunnel Broker.  The emphasis in this document is on
>>>    protocol-related security issues.
>>> 
>>> A URL for this Internet-Draft is:
>>> http://www.ietf.org/internet-drafts/draft-yamamoto-v6tc-security-
> consideration
>>> s-00.txt
>>> 
>>> To remove yourself from the I-D Announcement list, send a message to
>>> [email-masked] with the word unsubscribe in the body of the
>>> message.  
>>> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
>>> to change your subscription settings.
>>> 
>>> 
>>> Internet-Drafts are also available by anonymous FTP. Login with the
> username
>>> "anonymous" and a password of your e-mail address. After logging in,
>>> type "cd internet-drafts" and then
>>> "get draft-yamamoto-v6tc-security-considerations-00.txt".
>>> 
>>> A list of Internet-Drafts directories can be found in
>>> http://www.ietf.org/shadow.html
>>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>> 
>>> 
>>> Internet-Drafts can also be obtained by e-mail.
>>> 
>>> Send a message to:
>>> [email-masked].
>>> In the body type:
>>> "FILE /internet-drafts/draft-yamamoto-v6tc-security-considerations-00.txt".
>>> 
>>> NOTE: The mail server at ietf.org can return the document in
>>> MIME-encoded form by using the "mpack" utility.  To use this
>>> feature, insert the command "ENCODING mime" before the "FILE"
>>> command.  To decode the response(s), you will need "munpack" or
>>> a MIME-compliant mail reader.  Different MIME-compliant mail readers
>>> exhibit different behavior, especially when dealing with
>>> "multipart" MIME messages (i.e. documents which have been split
>>> up into multiple messages), so check your local documentation on
>>> how to manipulate these messages.
>>> 
>>> 
>>> Below is the data which will enable a MIME compliant mail reader
>>> implementation to automatically retrieve the ASCII version of the
>>> Internet-Draft.
>>> Content-Type: text/plain
>>> Content-ID: <[email-masked]>
>>> 
>>> _______________________________________________
>>> I-D-Announce mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/i-d-announce
>> 
>> 
>> 
>> 
>> ************************************
>> The IPv6 Portal: http://www.ipv6tf.org
>> 
>> Barcelona 2005 Global IPv6 Summit
>> Information available at:
>> http://www.ipv6-es.com
>> 
>> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of
> the individual
> (s) named above. If you are not the intended recipient be aware
> that any 
> disclosure, copying, distribution or use of the contents of this
>  information, 
> including attached files, is prohibited.
>> 
>> 
>> 
>> 
> 
> 
> --
> Shu Yamamoto
> [email-masked]

************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Information available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Gert Doering <[email-masked]>
Date: Thu, 14 Jul 2005 12:14:28 +0200

Hi,

> will support IPv6 as an added value, not as a dedicated cost.

Unfortunately, more and more vendors think that they can make much money
out of IPv6, and as such, getting IPv6 enabled in the boxes requires
an additional license.  Which needs to be paid for.

Gert Doering
        -- NetMaster
-- 
Total number of prefixes smaller than registry allocations:  71007  (66629)

SpaceNet AG                    Mail: [email-masked]
Joseph-Dollinger-Bogen 14      Tel : +49-89-32356-0
D- 80807 Muenchen              Fax : +49-89-32356-234

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 14 Jul 2005 12:33:33 +0200

Hi Gert,

Change your vendor !

This is not fair, and should not be like that. Fortunately other vendors
still keep offering IPv6 at no cost when you buy a box with IPv4.

In any case, is not ALL, so the wording in the document is not accurate ;-)

Regards,
Jordi

> De: Gert Doering <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Thu, 14 Jul 2005 12:14:28 +0200
> Para: JORDI PALET MARTINEZ <[email-masked]>
> CC: "[email-masked]" <[email-masked]>

---

From: Fred Baker <[email-masked]>
Date: Thu, 14 Jul 2005 08:19:38 -0700

> there is no cost for replacing any routers.

That depends on your router. In the case of a company I happen to have 
some familiarity with, some of the products we have that switch traffic 
in hardware require a change of card (not the entire router, unless it 
is old enough that it is no longer supported). The new card is 
IPv4+IPv6 and has a 64 or 128 bit wide word width and may have a larger 
TCAM where the old was IPv4 only and had a 32 bit word width. Even a 
software router may require additional memory to hold a larger program 
and parallel RIBs and FIBs.

A new memory stick is a cost, and sending someone out to inventory the 
equipment and see if one might be needed (and testing the software 
before basing one's business on it) is a cost.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 18 Jul 2005 12:16:44 +0200

Hi,

Yes, of course, its up to each router (model/config), but what is clear to
me is that the real situation is more in the side of no cost or almost no
cost, specially if your network is under maintenance.

A good quality ISP is continuously upgrading the network, taking care of new
firmware versions, etc. IPv6 is coming there as a value added. Some times
you may need a hardware part replacement, right, but this is only required
if you have a lot of IPv6 traffic, and in that case, it pays for it.

Unless you need to actually do a hardware upgrade of the router, most of the
time you will be able to take care of the new firmware and config remotely
...

So most of the cost, in a correctly maintained network will not be just
because IPv6 (if done with some planning), except may be training, and in
any case will not be a "very high cost".

If you want to do it overnight, and have no expertise, not correct planing,
etc., yes, then it can cost a lot !

Regards,
Jordi

> De: Fred Baker <[email-masked]>
> Fecha: Thu, 14 Jul 2005 08:19:38 -0700
> Para: <[email-masked]>