Subject: Re: I-D ACTION:draft-yamamoto-v6tc-security-considerations-00.txt

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 13 Jul 2005 22:37:52 +0200

Hi,

A couple of comments about this document.

1. Intro. I don't think is correct to say that a major impediment is the
high cost and technical complexity. Sorry, but isn't the case, and we must
not give this message. In some cases it might be the case, but not in
general. I'm working everyday in moving real customers to support native
IPv6, and haven't found this situation yet, and not talking about just a
dozen of customers.
Actually I'm starting to feel that most of the people is afraid of IPv6
because they got this impression.

3 ... It may be better to use instead of adversary "malicious user" or
something else ? I mean adversary may seem as "business competitor" or have
other connotations, which I guess are not the intended ones ?

Regards,
Jordi

> De: "[email-masked]" <[email-masked]>
> Responder a: "[email-masked]" <[email-masked]>
> Fecha: Tue, 12 Jul 2005 15:50:03 -0400
> Para: <[email-masked]>
> Asunto: I-D ACTION:draft-yamamoto-v6tc-security-considerations-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
> Title  : Security Considerations for the Tunnel Broker
>                           Model
> Author(s) : S. Yamamoto, et al.
> Filename : draft-yamamoto-v6tc-security-considerations-00.txt
> Pages  : 9
> Date  : 2005-7-12
> 
>    Tunnel brokers must implement protections against a wide variety of
>    threats.  This draft discusses the security considerations for a
>    configured tunneling configuration mechanism such as that described
>    by the Tunnel Broker.  The emphasis in this document is on
>    protocol-related security issues.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-yamamoto-v6tc-security-consideration
> s-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of the
> message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-yamamoto-v6tc-security-considerations-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-yamamoto-v6tc-security-considerations-00.txt".
> 
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Information available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: [email-masked]
Date: Thu, 14 Jul 2005 03:31:48 -0400 (EDT)

Hi Jordi,

> other connotations, which I guess are not the intended ones ?

The best definition of security I have seen in this context is due to Oded
Goldreich, who says, roughly, that, "Security is about making protocols
robust against anyone who tries to make them deviate from their intended
behavior."

"Malicious," to me, means bad or evil, which involves a value judgment. It
could be that the one running the protocol is bad, and the one disrupting
the protocol is good, or there may be legitimate difference of opinion
about which party is good or bad.

"Malicious" also has an unfortunate connotation in some security
literature, whereby a "passive adversary" only observes the protocol and a
"malicious adversary" actively disrupts it. I dislike this usage, but it
nevertheless exists.

So IMHO, "malicious" has more connotative baggage than "adversary." If you
don't like "adversary," then maybe "attacker?"

Regards, Richard

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 14 Jul 2005 09:43:21 +0200

Hi Richard,

Yes totally agree with you ... Attacker seems to fit much better ;-)

Regards,
Jordi

> De: <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Thu, 14 Jul 2005 03:31:48 -0400 (EDT)
> Para: <[email-masked]>
> CC: "[email-masked]" <[email-masked]>
> Asunto: Re: I-D ACTION:draft-yamamoto-v6tc-security-considerations-00.txt
> 
> Hi Jordi,
>