Subject: How to differentiate traffic in NAT-PT box?

From: haofeng Zhang <[email-masked]>
Date: Fri, 10 Feb 2006 11:16:01 +0800

Dear all,

I have a problem regarding to NAT-PT and ALG.
In the RFC2766(NAT-PT spec), nat-pt box cooperates with ALG to deal with
some application carrying IP addresses in payload. But for the operation of
nat-box box, how can the box differentiate which kind of traffic needs to be
processed by ALG and others needn't? Or the nat-pt box just send all traffic
to ALG module and leave the differentiation problem to ALG?
I don't find the clarification in the spec. So if answer is the latter, does
it means a big waste of device resource? After all, usually only the
signaling traffic needs to be processed by ALG.
So any kind of help is appreciated.

--
Best regards,
Zhang haofeng

---

From: xiao bin <[email-masked]>
Date: Fri, 10 Feb 2006 11:49:11 +0800

For some packet, the device can judge whether a packet need ALG by the protocol number in the packet header.
  ----- Original Message ----- 
  From: haofeng Zhang 
  To: [email-masked] 
  Sent: Friday, February 10, 2006 11:16 AM
  Subject: How to differentiate traffic in NAT-PT box?

  Dear all,

  I have a problem regarding to NAT-PT and ALG. 
  In the RFC2766(NAT-PT spec), nat-pt box cooperates with ALG to deal with some application carrying IP addresses in payload. But for the operation of nat-box box, how can the box differentiate which kind of traffic needs to be processed by ALG and others needn't? Or the nat-pt box just send all traffic to ALG module and leave the differentiation problem to ALG? 
  I don't find the clarification in the spec. So if answer is the latter, does it means a big waste of device resource? After all, usually only the signaling traffic needs to be processed by ALG.
  So any kind of help is appreciated.

  -- 
  Best regards,
  Zhang haofeng

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Feb 2006 13:03:32 +0100

One of the many reasons for killing NAT-PT.

     Brian

---

From: Elwyn Davies <[email-masked]>
Date: Fri, 10 Feb 2006 13:50:55 +0000

Indeed so.

Have you read draft-ietf-v6ops-natpt-to-exprmntl-03.txt?

The Abstract says:
>    This document discusses issues with the specific form of IPv6-IPv4
>    protocol translation mechanism implemented by the Network Address
>    Translator - Protocol Translator (NAT-PT) defined in RFC 2766.  These
>    issues are sufficiently serious that recommending RFC 2766 as a
>    general purpose transition mechanism is no longer desirable, and this
>    document recommends that the IETF should reclassify RFC 2766 from
>    Standards Track to Experimental status
You should think very carefully before spending a lot of time on this work.

Regards,
Elwyn

---

From: Soohong Daniel Park <[email-masked]>
Date: Mon, 13 Feb 2006 11:41:24 +0900

Withour DNS-ALG, we can live with NAT-PT as well.
http://www.watersprings.org/pub/id/draft-daniel-natpt-bis-01.txt 

Don't say "Killing NAT-PT". It seems a harmful opinion against
NAT-PT developer, although they are still weak status. Just saying 
"Clarifying NAT-PT". No technology can be a perfect level. 

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.

---

From: Vincent Jardin <[email-masked]>
Date: Mon, 13 Feb 2006 09:37:32 +0100

Hi,

 From our experience and implementation into the 6WINDGate software, you 
should not try to link the DNS ALG with NAT-PT. Moreover, DNS ALG and 
NAT-PT could be into 2 different routers:
1- one module or router is used in order to process the DNS AAAA 
requrests and it provides a reply with a NAT-PT::/96 prefix in order to 
route the packets to a NAT-PT translator (router, module, etc.)
2- another module or router is just an IPv6/IPv4 translator based on the 
NAT-PT::/96 prefix

Instead of 1, for some services, you can replace dynamic DNS ALG by 
static IPv6 intries into your IPv6 DNS, these entries are just 
NAT-PT::A.B.C.D.

Regards,
Vincent

xiao bin wrote:

>     *From:* haofeng Zhang <mailto:[email-masked]>
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Sent:* Friday, February 10, 2006 11:16 AM
>     *Subject:* How to differentiate traffic in NAT-PT box?
>
>     Dear all,
>     In the RFC2766(NAT-PT spec), nat-pt box cooperates with ALG to
>     deal with some application carrying IP addresses in payload. But
>     for the operation of nat-box box, how can the box differentiate
>     which kind of traffic needs to be processed by ALG and others
>     needn't? Or the nat-pt box just send all traffic to ALG module and
>     leave the differentiation problem to ALG?
>     I don't find the clarification in the spec. So if answer is the
>     latter, does it means a big waste of device resource? After all,
>     usually only the signaling traffic needs to be processed by ALG.