Subject: RE: Teredo spec has been published!

From: "Dave Thaler" <[email-masked]>
Date: Mon, 6 Feb 2006 11:23:16 -0800

I'm told by the devs that the prefix is already configurable on Windows XP.

The Teredo prefix can be configured by adding/altering the following REG_DWORD value: \HKLM\System\CurrentControlSet\Services\Tcpip6\Parameters\GlobalParams\TeredoPrefix.  The DWORD value is interpreted as a 32 bit prefix, in network byte order.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Vincent Jardin
> Sent: Sunday, February 05, 2006 6:03 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Teredo spec has been published!
> 
> Jordi,
> 
> Even if you remove the constraint on the hard-coded prefix, the Teredo
> clients "can talk peer-to-peer"; it does not break any compatibility,
> please can you explain why it would be broken ?
> 
> The requirement of being able to configure the Teredo prefix is:
>   - control the transition from the previous prefix to the new one,
>   - be able to support some private usages of the Teredo prefix
> (development, testing, etc.).
> 
> I don't say that 2001:0000::/32 should not be the default value, as
> recommended by the IANA, but it should be configure-able. It is more a
> implementation constraint rather than a standardization constraint.
> 
> Regards,
>   Vincent
> 
> Le dimanche 05 février 2006 à 13:14 +0100, JORDI PALET MARTINEZ a
> écrit :
> > I don't agree.
> >
> > If you do so, you break one of the principles of Teredo, and then you do
> not
> > longer need an IANA assigned prefix.
> >
> > The idea is to ensure that all the Teredo clients can talk peer-to-peer.
> >
> > Regards,
> > Jordi
> >
> >
> >
> >
> > > De: Vincent Jardin <[email-masked]>
> > > Organización: http://www.6wind.com/
> > > Responder a: <[email-masked]>
> > > Fecha: Sun, 05 Feb 2006 13:01:58 +0100
> > > Para: haofeng Zhang <[email-masked]>
> > > CC: Christian Huitema <[email-masked]>,
> "[email-masked]"
> > > <[email-masked]>
> > > Asunto: Re: Teredo spec has been published!
> > >
> > > Le dimanche 05 février 2006 à 10:56 +0800, haofeng Zhang a écrit :
> > >> Great News.
> > >> I am expecting the next version of Windows will support Teredo
> service
> > >> proposed by RFC4380.
> > >> Also, I think it will be more flexible if a Teredo Client accepts any
> > >> reasonable global IPv6 prefix, not only 2001:0000::/32 defined in the
> > >> sepcification.
> > >
> > > Yes, it would be very usefull with we can configure the Teredo prefix
> on
> > > the next update of Windows, instead of having a hard-coded
> > > 2001:0000::/32.
> > >
> > > Regards,
> > >   Vincent
> > >
> > >>
> > >>
> > >> 2006/2/4, Christian Huitema <[email-masked]>:
> > >>         The Teredo spec has been published as an individual
> > >>         submission:
> > >>
> > >>                RFC4380
> > >>                Teredo: Tunneling IPv6 over UDP through Network
> > >>         Address
> > >>                Translations (NATs)
> > >>                C. Huitema February 2006 ASCII
> > >>                PROPOSED STANDARD
> > >>
> > >>         Thanks to the many NGTRANS and V6OPS working group members
> who
> > >>         reviewed
> > >>         the spec!
> > >>
> > >>         -- Christian Huitema
> > >>
> > >>
> > >>
> > >>
> > >> --
> > >> Best regards,
> > >> Zhang haofeng
> > >
> > >
> >
> >
> >
> >
> > **********************************************
> > The IPv6 Portal: http://www.ipv6tf.org
> >
> > Barcelona 2005 Global IPv6 Summit
> > Slides available at:
> > http://www.ipv6-es.com
> >
> > This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be aware
> that any disclosure, copying, distribution or use of the contents of this
> information, including attached files, is prohibited.
> >
> >
> >
> >
> >
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 06 Feb 2006 20:41:40 +0100

Thanks Dave,

That's a good option (instead of needing a hack for those that want to make
use of a different prefix for an experiment).

The point is still that will be good to know if there are any specific
transition plans from Microsoft, so we can all try to coordinate ...

Regards,
Jordi

> De: Dave Thaler <[email-masked]>
> Fecha: Mon, 6 Feb 2006 11:23:16 -0800
> Para: Vincent Jardin <[email-masked]>, <[email-masked]>
> CC: <[email-masked]>
> Conversación: Teredo spec has been published!
> Asunto: RE: Teredo spec has been published!
> 
> The Teredo prefix can be configured by adding/altering the following REG_DWORD
> value: 
> \HKLM\System\CurrentControlSet\Services\Tcpip6\Parameters\GlobalParams\TeredoP
> refix.  The DWORD value is interpreted as a 32 bit prefix, in network byte
> order.
> 
> -Dave
> 

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.