Subject: RE: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the Addressing Plans

From: "Durand, Alain" <[email-masked]>
Date: Wed, 1 Mar 2006 04:28:51 -0500

Jordi,

This draft makes the assumption that all point-to-point links are
connecting
ISP to Customer.

This is obviously not true.

   - Alain.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
> Sent: Wednesday, March 01, 2006 3:56 AM
> To: [email-masked]
> Subject: Guidelines for Numbering IPv6 Point-to-Point Links 
> and Easing the Addressing Plans
> 
> Hi all,
> 
> We have submitted before yesterday a new draft, it seems is 
> still not available at the IETF repository, but meanwhile, 
> the document can be reached
> at:
> http://www.consulintel.euro6ix.org/ietf/draft-palet-v6ops-poin
t2point-00.txt
> 
> Comments welcome !
> 
> Regards,
> Jordi
> 
> 
> 
> 
> 
> 
> **********************************************
> The IPv6 Portal: http://www.ipv6tf.org
> 
> Barcelona 2005 Global IPv6 Summit
> Slides available at:
> http://www.ipv6-es.com
> 
> This electronic message contains information which may be 
> privileged or confidential. The information is intended to be 
> for the use of the individual(s) named above. If you are not 
> the intended recipient be aware that any disclosure, copying, 
> distribution or use of the contents of this information, 
> including attached files, is prohibited.
> 
> 
> 
> 
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 01 Mar 2006 17:50:41 +0800

Hi Alain,

May be some text need to be fixed, but the idea behind the document is still
correct, and will work the same regardless of being ISP-customer or
something different.

I will take care about this clarification in a new version. Thanks !

Regards,
Jordi

> De: "Durand, Alain" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Wed, 1 Mar 2006 04:28:51 -0500
> Para: <[email-masked]>, <[email-masked]>
> Conversación: Guidelines for Numbering IPv6 Point-to-Point Links and Easing
> the Addressing Plans
> Asunto: RE: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the
> Addressing Plans
> 
> Jordi,
> 

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Vincent Jardin <[email-masked]>
Date: Wed, 01 Mar 2006 11:30:38 +0100

Hi,

Please, this draft should metion:
  - the cases when there are only link-local addresses

  - because it is mainly focus on ISPs cases, it should describe too how 
it fits with Prefix Delegation: my recommandation would be not to put 
any addresses ont the point to point interface (there is already 
link-local addresses which are enough for routing protocols).

  - there are some drawbacks of putting an IPv6 /64 on the provider side,
       + because you will create loops if redirection is not properly 
implemented on point to point interfaces (I mean a good implementation 
and configuration should never send redirect packets)
       + because you will loose the support of the anycast address 
sub-network. It means that the LNS or BAS will answer instead of the CPE.

  - what's about the support of the anycast address sub-network ?

  - what's about multi-links to a same site ? For instance, we know some 
cases where you have 2 point to point links with ECMPv6 for load 
balancing. Section 4 cannot be applied in that case.

FYI and from my experience, for ISPs, it is useless to number the IPv6 
links. Only link local is enough.  From an implementation point of view, 
you just need to add a reject (or blackhole) /48 route for each users 
through each interface. Because you have a same route through many 
interfaces, you will have the benefit of ECMPv6 support.

Maybe, it could be useful (and I do doubt), to number only the IPv6 
point to point links that are more used for infrasturcture (GRE, 6in6, 
L2TP/VPN, etc.).

Regards,
  Vincent

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 03 Mar 2006 01:19:13 +0800

Hi Vincent,

See below, in-line.

Regards,
Jordi

> De: Vincent Jardin <[email-masked]>
> Organización: http://www.ipv6.6WIND.com/
> Fecha: Wed, 01 Mar 2006 11:30:38 +0100
> Para: <[email-masked]>
> CC: "[email-masked]" <[email-masked]>
> Asunto: Re: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the
> Addressing Plans
> 
> Hi,
> 

I disagree regarding using link-local addresses, is very confusing when you
do a traceroute and you can even see the same addresses in different
customers in different links (if de ISP decides to use a fix IID for each
side).

This has been also the feedback that we got from different ISPs.

>   - what's about the support of the anycast address sub-network ?

The /64 is in the customer side, not the provider one, which uses /48.

> balancing. Section 4 cannot be applied in that case.

Not sure what do you mean with ECMPv6. I will check it out tomorrow, I'm off
line now.

> interfaces, you will have the benefit of ECMPv6 support.

I think this is what actually I'm proposing then ;-)