Subject: AW: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the Addressing Plans

From: "Bonness, Olaf" <[email-masked]>
Date: Wed, 1 Mar 2006 12:21:16 +0100

Yes, this  could be one nice approach - but is normally not necessary since the operation and maintenance procedures are mostly automated and db based.

Olaf

> -----Ursprungliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]Im
> Auftrag von Tim Chown
> Gesendet: Mittwoch, 1. Marz 2006 12:02
> An: [email-masked]
> Betreff: Re: Guidelines for Numbering IPv6 Point-to-Point Links and
> Easing the Addressing Plans
> 
> 
> On Wed, Mar 01, 2006 at 11:41:59AM +0100, Bonness, Olaf wrote:
> > > 
> > >    4.  Routing Aggregation of the Point-to-Point Links
> > > 
> > >    Following this approach and assuming that a shorter prefix is
> > >    typically delegated to a customer, in general a /48 [4], it is
> > >    possible to simplify the routing aggregation of the 
> point-to-point
> > >    links.  Towards this, the point-to-point link may be 
> numbered using
> > >    the first /64 of a given /48.
> > > 
> > > using the first (or any) subnet of a larger prefix, breaks the
> > > conceptual model of DHCP prefix delegation. the prefix is 
> delegated to
> > > the requesting router and cannot be used to number the 
> link between
> > > the delegating and requesting router.
> > 
> > My assumption from a service provider point of view would 
> be to use a dedicated sub-preaefix (e.g. /48)of my own 
> aggregate to address the point-to-point links (e.g. /64)  to 
> the custumers (in the case I have to do this).
> 
> And if the customer prefix being 'easy' to relate to the 
> point-to-point
> link address is important (though one assumes this is all tucked away
> nicely in some db :) you could presumably look at doing something like
> using the 16 bits assigned for the customer /48 as the 16 bits used 
> to identify the /64 under your carved out /48 for 
> point-to-point links?
> 
> -- 
> Tim/::1
> 
> 
>

---

From: [email-masked]
Date: Wed, 1 Mar 2006 11:31:54 +0000

so, the presumption is that unless you automate the process and 
put a db behind the assignments, that other processes are superfuluous?
not everyone has or wants to have yet another dependency in the loop.
(... sorry, can't get routing to work since the db is down... and its behind
a router ... er... sorry...)

--bill

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 03 Mar 2006 01:23:52 +0800

I will much prefer "keep it simple and stupid", no database, if you don't
need it for it, no unnecessary calculations of the IID, etc.

Regards,
Jordi

> De: "Bonness, Olaf" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Wed, 1 Mar 2006 12:21:16 +0100
> Para: <[email-masked]>, "[email-masked]" <[email-masked]>
> Asunto: AW: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the
> Addressing Plans
> 
> Yes, this  could be one nice approach - but is normally not necessary since
> the operation and maintenance procedures are mostly automated and db based.
> 
> Olaf
> 

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.