Subject: AW: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the Addressing Plans

From: "Bonness, Olaf" <[email-masked]>
Date: Wed, 1 Mar 2006 11:41:59 +0100

> 
>    4.  Routing Aggregation of the Point-to-Point Links
> 
>    Following this approach and assuming that a shorter prefix is
>    typically delegated to a customer, in general a /48 [4], it is
>    possible to simplify the routing aggregation of the point-to-point
>    links.  Towards this, the point-to-point link may be numbered using
>    the first /64 of a given /48.
> 
> using the first (or any) subnet of a larger prefix, breaks the
> conceptual model of DHCP prefix delegation. the prefix is delegated to
> the requesting router and cannot be used to number the link between
> the delegating and requesting router.

My assumption from a service provider point of view would be to use a dedicated sub-preaefix (e.g. /48)of my own aggregate to address the point-to-point links (e.g. /64)  to the custumers (in the case I have to do this).

cu
	Olaf

---

From: Tim Chown <[email-masked]>
Date: Wed, 1 Mar 2006 11:02:10 +0000

> My assumption from a service provider point of view would be to use a dedicated sub-preaefix (e.g. /48)of my own aggregate to address the point-to-point links (e.g. /64)  to the custumers (in the c…

And if the customer prefix being 'easy' to relate to the point-to-point
link address is important (though one assumes this is all tucked away
nicely in some db :) you could presumably look at doing something like
using the 16 bits assigned for the customer /48 as the 16 bits used 
to identify the /64 under your carved out /48 for point-to-point links?

-- 
Tim/::1

---

From: Fred Baker <[email-masked]>
Date: Wed, 1 Mar 2006 11:30:09 -0500

My assumption as a routing geek is that the only reasonable use of a  
numbered point to point link is to address an end station; it needs  
an address to be useful in the network. But any router/router point- 
to-point interface should be supportable using link-local addresses.  
A router needs one address reachable by its administration (eg non- 
link-local), to be a member of any prefix on a LAN that it is  
serving, and to be able to reach p/p-connected end stations it serves.

On Mar 1, 2006, at 5:41 AM, Bonness, Olaf wrote:

> My assumption from a service provider point of view would be to use  
> a dedicated sub-preaefix (e.g. /48)of my own aggregate to address  
> the point-to-point links (e.g. /64)  to the custumers (in the case  
> I have to do this).
>
> cu
> 	Olaf

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 03 Mar 2006 01:28:18 +0800

Yes, but then we are creating a kind of non-reachability to the router from
outside the network by using only link-local.

If I'm an user and I want to address my router from outside my network, this
is an easy way. Same for the ISP, if he need to address this router and is
outside his network.

Regards,
Jordi

> De: Fred Baker <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Wed, 1 Mar 2006 11:30:09 -0500
> Para: "Bonness, Olaf" <[email-masked]>
> CC: <[email-masked]>, <[email-masked]>, "[email-masked]"
> <[email-masked]>
> Asunto: Re: AW: Guidelines for Numbering IPv6 Point-to-Point Links and Easing
> the Addressing Plans
> 

**********************************************
The IPv6 Portal: http://www.ipv6tf.org

Barcelona 2005 Global IPv6 Summit
Slides available at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 03 Mar 2006 01:21:10 +0800

Hi Olaf,

I guess is a question of taste, I've seen this opinion from some ISPs, but
also the contrary one from many others.

Both models are valid. May be the document will be more complete describing
both choices, and up to each one to decide which he/she prefers.

Regards,
Jordi

> De: "Bonness, Olaf" <[email-masked]>
> Fecha: Wed, 1 Mar 2006 11:41:59 +0100
> Para: <[email-masked]>, <[email-masked]>
> CC: "[email-masked]" <[email-masked]>
> Asunto: AW: Guidelines for Numbering IPv6 Point-to-Point Links and Easing the
> Addressing Plans
> 
>> 
> My assumption from a service provider point of view would be to use a
> dedicated sub-preaefix (e.g. /48)of my own aggregate to address the
> point-to-point links (e.g. /64)  to the custumers (in the case I have to do
> this).
> 
> cu
> Olaf
>

---

From: Daniel Roesen <[email-masked]>
Date: Mon, 6 Mar 2006 09:19:47 +0100

> to-point interface should be supportable using link-local addresses.  

And my experience as a routing operator/geek says that traceroute must
work. "unnumbered" links are a pain to no end in day-to-day ops.

When I was last working for a large ISP we had one in-country sub-ISP in
Sweden who used unnumbered p2p links to customer CPEs. No end of pain
with monitoring and troubleshooting.

Regards,
Daniel

-- 
CLUE-RIPE -- Jabber: [email-masked] -- dr@IRCnet -- PGP: 0xA85C8AA0