Subject: Re: draft-ietf-v6ops-addr-select-ps-01.txt and draft-ietf-v6ops-addr-select-req-02.txt WGLC

From: "haofeng Zhang" <[email-masked]>
Date: Tue, 3 Jul 2007 16:25:35 +0800

Should we consider another problem relating to IPv6 address selection in
this draft?

Think about this scenario in IPv6 network when SIP protocol is used:
                                   _______________
                                  |  IPv6 network|________ SIP Server
                                  |______________|
                                    /           \
                                   /             \
                                  /               \
                              Router 1        Router 2
                                 |                 |
                                 |                 |
                           SIP Phone tiger      SIP Phone  Deer
                                 |                 |
                                 |_________________|
                                          |
                                       Router 3

In this situation, SIP Phone Tiger and Deer both have multiple addresses,
E.g for tiger, both R1 and R3 will assign address to it, and so as sip phone
Deer.

Considering a sip request message initiated by tiger to sip server,
according to RFC3484, most likely the IPv6 address assigned by Router 1 will
be used as the source, since the destination is sip server.  And it's
perfectly fine  for all the signaling message between  tiger/sip server, and
deer/sip server pairs.

But it's not the case for the media traffic. Obviously, for both tiger and
deer, the addresses assigned by R3 should be used for media traffic since
they belong to the same subnet. So the problem is, should tiger's SDP
message carry all the IPv6 addresses it has to deer so that deer can make
the right decision; or, should a mechanism be used between tiger and deer to
exchange the address selection information for SDP message?

RFC3266(IPv6 support of SDP) doesn't address this. So I am not sure whether
this problem should be addressed in this draft or another. Or have we
already had a solution?

2007/6/21, Fred Baker <[email-masked]>:
>
> This is to initiate a two week working group last call of draft-ietf-
> v6ops-addr-select-ps-01.txt and draft-ietf-v6ops-addr-select-
> req-02.txt. Please read these now. If you find nits (spelling errors,
> minor suggested wording changes, etc), comment to the authors; if you
> find greater issues, such as disagreeing with a statement or finding
> additional issues that need to be addressed, please post your
> comments to the list.
>
> We are looking specifically for comments on the importance of the
> documents as well as its content. If you have read the documents and
> believe them to be of operational utility, that is also an important
> comment to make. If you have read them and think they miss an
> important consideration, that is very important.
> <?xml version="1.0" encoding="UTF-8"?>
>
>

---

From: Arifumi Matsumoto <[email-masked]>
Date: Tue, 03 Jul 2007 20:22:09 +0900

Hi, Zhang.

I guess the e-mail from Jean just before your e-mail to v6ops ML
is the solution for this problem, isn't it ?

IMHO, this SIP address selection issue is application specific,
in that SIP treats IP addresses on its layer. We rather focus on
system-wide address selection problems. I suppose application
specific address selection issues should be treated separately
and individually when it is necessary.

-- 
Arifumi Matsumoto
    IP Technology Expert Team
    Secure Communication Project
    NTT Information Sharing Platform Laboratories
    E-mail: [email-masked]

---

From: "haofeng Zhang" <[email-masked]>
Date: Tue, 3 Jul 2007 22:46:13 +0800

You are right. This problem falls into the scope of ICE protocol proposed by
Jean. Sorry I missed this mail.

Thanks Arifumi to point out this to me. Your both drafts will be
complementary to Jean's draft.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 Jul 2007 16:48:35 +0200

Haofeng,

Why is this problem specific to IPv6? I currently have two
IPv4 addresses and can run a SIP phone on my machine. I'm sure
the same optimization problem can arise.

    Brian

---

From: "haofeng Zhang" <[email-masked]>
Date: Tue, 3 Jul 2007 23:13:02 +0800

Brian,

Sure, this problem exists for both IPv4/IPv6 protocols. Well, it's just... I
found it in IPv6 environment firstly. :)

I used to conduct an SIP call experiment in IPv6 network, with a SIP UA
under Linux. What trouble me is that the UA gave different IPv6 addresses in
SDP message for different calls. Sometimes the link-local address was
included in SDP message!

Maybe it's bad SIP implementation. But the nature of multiple allowable
IPv6 addresses per interface can cause confusion in IPv6 SIP implementation.
Again, it falls into the scope of draft ICE (
http://tools.ietf.org/html/draft-ietf-mmusic-ice-16), propsed by Jean.

2007/7/3, Brian E Carpenter <[email-masked]>:
> > 2007/6/21, Fred Baker < [email-masked]>:
> >>
> >> <?xml version=" 1.0" encoding="UTF-8"?>
> >>
> >>
> >
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 3 Jul 2007 10:20:53 -0700

> the same optimization problem can arise.

I don't think the question is whether it is IPv6-specific; it is  
whether it is a good thing to address in IPv6.

---

From: Fred Baker <[email-masked]>
Date: Tue, 3 Jul 2007 10:26:22 -0700

I have asked Arifumi to update the drafts per the comments on the  
mailer. That will either happen this week or after the IETF meeting.  
Please continue the review, and comment on the new draft when it  
comes as to whether it has addressed your issues.

On Jun 20, 2007, at 4:35 PM, Fred Baker wrote:
> This is to initiate a two week working group last call of draft- 
> ietf-v6ops-addr-select-ps-01.txt and draft-ietf-v6ops-addr-select- 
> req-02.txt. Please read these now. If you find nits (spelling  
> errors, minor suggested wording changes, etc), comment to the  
> authors; if you find greater issues, such as disagreeing with a  
> statement or finding additional issues that need to be addressed,  
> please post your comments to the list.
>
> documents as well as its content. If you have read the documents  
> and believe them to be of operational utility, that is also an  
> important comment to make. If you have read them and think they  
> miss an important consideration, that is very important.