Subject: Fwd: An Internet IPv6 Transition Plan

From: Fred Baker <[email-masked]>
Date: Tue, 24 Jul 2007 09:12:28 -0500

Begin forwarded message:

> From: John Curran <[email-masked]>
> Date: July 23, 2007 10:56:04 PM CDT
> To: nanog <[email-masked]>
> Subject: An Internet IPv6 Transition Plan
>
>
> Folks -
>
>     There's quite a few IPv6 transition technologies, each with its
>     own camp of supporters based on particular world view of the
>     hardest & easiest system elements to change.  One of the
>     challenges this poses is that it's very easy to get caught up
>     in the various transition approaches and miss the high-level
>     view of what needs to be accomplished.
>
>     In an effort to communicate one possible transition plan in a
>     technology agnostic manner, I've written an Internet draft
>     which highlights the expectations that organizations could
>     face over the next few years:
>
>     http://www.ietf.org/internet-drafts/draft-jcurran- 
> v6transitionplan-00.txt
>
>     I'd be interested in hearing any and all feedback from the
>     NANOG community on this draft;  feel free to send such
>     privately if you'd prefer a degree of anonymity, or have
>     the urge to use language inappropriate in public...  ;-)
>
> Thanks!
> /John

---

From: james woodyatt <[email-masked]>
Date: Tue, 24 Jul 2007 09:50:51 -0500

On Jul 24, 2007, at 09:12, Fred Baker forwarded:
>> 2.2  Transition Phase - January 2009 to December 2010
>>  [...]
>>  During the Post-Transition Phase, the following principles apply:
>>  [...]
>>  2.3.4 Service Providers area MAY continue to offer IPv4-based  
>> Internet
>>        connectivity to their customers.  Organizations MAY  
>> continue to
>>        use IPv4-based Internet connectivity.  Organizations MAY  
>> remove
>>        IPv4-based Internet connectivity from Internet-facing servers.

The final sentence here is the point where the principles seem to  
move from describing the transition toward IPv6-based service to  
describing the process of deprecating IPv4.  While I'm all in favor  
of deprecating IPv4 over time, I think it deserves to be the topic of  
a separate draft.

I would recommend dropping that last sentence, or perhaps changing it  
to this: "Organizations MAY treat Internet-facing IPv4 servers as not  
production."

--
james woodyatt <[email-masked]>
member of technical staff, communications engineering

---

From: John Curran <[email-masked]>
Date: Tue, 24 Jul 2007 13:54:34 -0400

FYI - I'm on v6ops, although generally just lurking.

Excellent suggestion; I'll likely go with the change to that
"Organizations MAY treat Internet-facing IPv4 servers as not production."

This gets the point across without entering the deprecation realm.

Thanks again,
/John

At 9:50 AM -0500 7/24/07, james woodyatt wrote:
>>    http://www.ietf.org/internet-drafts/draft-jcurran-v6transitionplan-00.txt
>>
>>> 2.3.4 Service Providers area MAY continue to offer IPv4-based Internet
>>>       connectivity to their customers.  Organizations MAY continue to
>>>       use IPv4-based Internet connectivity.  Organizations MAY remove
>The final sentence here is the point where the principles seem to move from describing the transition toward IPv6-based service to describing the process of deprecating IPv4.  While I'm all in favor of deprecating IPv4 over time, I think it deserves to be the topic of a separate draft.
>
>I would recommend dropping that last sentence, or perhaps changing it to this: "Organizations MAY treat Internet-facing IPv4 servers as not production."
>
>
>--