Subject: Fwd: I-D Action:draft-jcurran-v6transitionplan-02.txt

From: Fred Baker <[email-masked]>
Date: Wed, 30 Jan 2008 10:59:09 -0800

FYI

Begin forwarded message:

> From: [email-masked]
> Date: January 30, 2008 10:20:01 AM PST
> To: [email-masked]
> Subject: I-D Action:draft-jcurran-v6transitionplan-02.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
> 	Title           : An Internet Transition Plan
> 	Author(s)       : J. Curran
> 	Filename        : draft-jcurran-v6transitionplan-02.txt
> 	Pages           : 8
> 	Date            : 2008-01-30
>
> This memo provides one possible plan for transitioning the Internet
>   from a predominantly IPv4-based connectivity model to a  
> predominantly
>   IPv6-based connectivity model.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-jcurran- 
> v6transitionplan-02.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> 	"get draft-jcurran-v6transitionplan-02.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-jcurran-v6transitionplan-02.txt".
>
> NOTE:   The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <2008-01-30131603.I-D\@ietf.org>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

---

From: John Curran <[email-masked]>
Date: Wed, 30 Jan 2008 15:29:43 -0500

>At 10:59 AM -0800 1/30/08, Fred Baker wrote:
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>  from a predominantly IPv4-based connectivity model to a predominantly

Thanks Fred...   For the curious, here's the extract from the change log:

>Changes from -01 version to -02 version:
>
> o  Clarification of pilot nature of IPv6 services prior to
>    start of Transition Phase.
> 
> o  Strengthen use of native IPv6 in Post-Transition Phase.

Basically, I updated it to clarify that in "Preparation" phase, use
of IPv6 services (even "beta/pilot/pre-production" IPv6 services)
is recommended.  I also received comments that we should more
strongly recommend native IPv6 in the Post-Transition stage, and
updated accordingly.

FYI,
/John

---

From: Fred Baker <[email-masked]>
Date: Wed, 30 Jan 2008 16:37:24 -0800

Thanks for this note, John. May I humbly request that, if you update  
it further, that you tag it draft-jcurran-v6ops-*? I tend to notice  
those a lot more easily than I do documents that don't reference the  
working group.

One question. I agree that the roll-out should be phased, and that  
providers world-wide need to take matters seriously, which I think is  
the high-order bit of your message. However, you provide very  
concrete dates on which cut-over events should take place, based on  
data which is the best available but is none-the-less somewhat  
approximate. We estimate that the IANA will hand out the last IPv4  
prefix in the neighborhood of the end of 2009; one could easily  
imagine the actual event happening either a bit earlier or a bit  
later, or some RIR policy changing that makes it a lot earlier or a  
lot later. For example, Geoff suggests that the ISPs will simply  
start buying and selling addresses out of their allocations. If they  
are contemplating doing that, given that the RIRs allocate them based  
on a detailed assertion that the organization allocated to really  
needs more addresses to run its business, I should think that the  
RIRs could get pretty fussy about that analysis.

So I wonder if the dates should be more approximate, or if operator  
fora such as NANOG or RIPE should be left room to diddle with them  
somehow.

---

From: John Curran <[email-masked]>
Date: Thu, 31 Jan 2008 07:03:10 -0500

At 4:37 PM -0800 1/30/08, Fred Baker wrote:
>Thanks for this note, John. May I humbly request that, if you update it further, that you tag it draft-jcurran-v6ops-*? I tend to notice those a lot more easily than I do documents that don't reference the working group.

I'm more than willing to tag it in that manner.   I intentionally did
not originally, as it would have been presumptuous on my part to
assume that v6ops wanted to be associated with it in any manner...

>One question. I agree that the roll-out should be phased, and that providers world-wide need to take matters seriously, which I think is the high-order bit of your message. However, you provide very concrete dates on which cut-over events should take place, based on data which is the best available but is none-the-less somewhat approximate. We estimate that the IANA will hand out the last IPv4 prefix in the neighborhood of the end of 2009; one could easily imagine the actual event happening either a bit earlier or a bit later, or some RIR policy changing that makes it a lot earlier or a lot later. For example, Geoff suggests that the ISPs will simply start buying and selling addresses out of their allocations. If they are contemplating doing that, given that the RIRs allocate them based on a detailed assertion that the organization allocated to really needs more addresses to run its business, I should think that the RIRs could get pretty fussy about that analysis.
>
>So I wonder if the dates should be more approximate, or if operator fora such as NANOG or RIPE should be left room to diddle with them somehow.

Here's my take...   The exact dates that the IANA or the RIR's is
going to start turning down requests for lack of availability simply
does not matter.   We're not going to see an IPv4 "Free Pool"
countdown clock on the bottom of CNN for final 6 months, and
even now the vast majority of Internet connected organizations
have no idea what Geoff's numbers say today.

However, we're going to need to change global expectations on
what's required now, during transition, and post-transition to be
"connected" to the Internet.  Since the requirements change by
the particular phase, and we need to educating a global audience
about these phases, with materials in dozens of languages and in
nearly every fora on the planet, being able to declare the official
start and end of each phase (and not having these dates move
about without great fanfare) is actually a necessary prerequisite
for having a consistent global message and effective results.

So, the ID contains hard dates, since they maximize our chance
(however great or small) of overall success.

/John

---

From: Fred Baker <[email-masked]>
Date: Thu, 31 Jan 2008 11:43:08 -0800

> (however great or small) of overall success.

ack. so be it.