Subject: Re: NAT64 and IPsec support

From: marcelo bagnulo <[email-masked]>
Date: Wed, 02 Apr 2008 18:09:12 +0200

Michael Richardson escribió:
>>>>>> "Pekka" == Pekka Savola <[email-masked]> writes:
>>>>>>             
>     Pekka> On Sun, 30 Mar 2008, Yaron Sheffer wrote:
>     >> I think we are bundling several different cases together. I will try to
>     >> enumerate the use cases, to clarify the situation a bit:
>
>     Pekka> What about IPsec in Alain Durand's scenario:
>
>     Pekka> v4-only host == NAT64 === v6-only network ==== NAT64 === v4-only network === v4-only host
>
>   That just looks like multiple layers of NATv4 to IPsec.
>   that's the whole point of v4v6v4, right?
>
>   
FWFI, I am not considering the v4v6v4 case in this analysis so far, 
cause this seems like a clear candidate for tunneling which is a far 
better solution imho

we are concerned about the case of a communication IPv6<->IPv4

Regards, marcelo

---

From: Michael Richardson <[email-masked]>
Date: Tue, 01 Apr 2008 20:57:22 -0400

-- 
]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [