Subject: translator friendly DNS Proxy

From: <[email-masked]>
Date: Thu, 7 Aug 2008 17:34:42 +0900

Hi, all

I submitted this document.

In this document, I proposed DNS proxy that is separated from NAT-PT.
This document describes about relationship DNS proxy and sNATPT[1].
I think that this DNS proxy can collabolate with other translation technologies.

I know that this working group isn't appropriate to discuss such kind items,
but I informed this document bacause many people that are interested in subscribed this mailing list.
And, if there is more suitable working group to discuss it, please tell me that.

[1] sNATPT: Miyata, H., "Simplified Network Address Translation - Protocol Translation"
                   draft-miyata-v6ops-snatpt-00

Thanks your comments.
Best Regards,

--------------------------
A new version of I-D, draft-endo-v6ops-dnsproxy-00.txt has been successfuly submitted by Masahito Endo and posted to the IETF repository.

Filename:        draft-endo-v6ops-dnsproxy
Revision:        00
Title:           Translator Friendly DNS Proxy
Creation_date:   2008-08-07
WG ID:           Independent Submission
Number_of_pages: 24

Abstract:
This document describes the DNS Proxy that is separated from NAT-PT [RFC2766].  NAT-PT was designed to work with DNS Application Level Gateway.  However [RFC4966] pointed out DNS related issues, and [RFC2766] was changed to historical state.  This document attempts to DNS Proxy specification, removing dependency on NAT-PT as well as resolving problems pointed in [RFC4966].

// masaxmasa

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 7 Aug 2008 10:42:34 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Thursday, August 07, 2008 1:35 AM
> To: [email-masked]
> Subject: translator friendly DNS Proxy
> 
> Hi, all
> 
> but I informed this document bacause many people that are 
> interested in subscribed this mailing list.

The Behave working group would be best,
<http://www.ietf.org/html.charters/behave-charter.html>.  I just forwarded
your announcement to the Behave mailing list.

>                    draft-miyata-v6ops-snatpt-00

I read your draft, and it seems like the Translator Interface
is the key -- it is the interface between the DNS Proxy (which
synthesizes AAAA records) you describe, and the NAT-PT itself
(which NATs between v6 and v4).  

Do I understand correctly?

-d

> A new version of I-D, draft-endo-v6ops-dnsproxy-00.txt has 
> been successfuly submitted by Masahito Endo and posted to the 
> IETF repository.
> 
> This document describes the DNS Proxy that is separated from 
> NAT-PT [RFC2766].  NAT-PT was designed to work with DNS 
> Application Level Gateway.  However [RFC4966] pointed out DNS 
> related issues, and [RFC2766] was changed to historical 
> state.  This document attempts to DNS Proxy specification, 
> removing dependency on NAT-PT as well as resolving problems 
> pointed in [RFC4966].
> 
> // masaxmasa
>

---

From: <[email-masked]>
Date: Fri, 8 Aug 2008 12:02:26 +0900

Hi, Dan

> > I know that this working group isn't appropriate to discuss
> such kind
> > items, but I informed this document bacause many people that are
> <http://www.ietf.org/html.charters/behave-charter.html>.  I
> just forwarded your announcement to the Behave mailing list.

Thanks for your information.
I just subscribed :)

> is the key -- it is the interface between the DNS Proxy
> (which synthesizes AAAA records) you describe, and the NAT-PT
> itself (which NATs between v6 and v4).
>

Yes.
But actual key point is that the translator interface can separate DNS Proxy from NAT-PT.

If a translator has NAPT-PT rule for IPv6 to IPv4 translation, the translator interface is not required.
In this case, a translator maps a lot of IPv6 source addresses to one IPv4 source address,
so DNS Proxy doesn't need to care an IPv4 source address.

best regards,

// masaxmasa

> > A new version of I-D, draft-endo-v6ops-dnsproxy-00.txt has been
> > successfuly submitted by Masahito Endo and posted to the IETF
> > repository.
> >
> > This document describes the DNS Proxy that is separated from NAT-PT
> > [RFC2766].  NAT-PT was designed to work with DNS Application Level
> > Gateway.  However [RFC4966] pointed out DNS related issues, and
> > [RFC2766] was changed to historical state.  This document
> attempts to
> > DNS Proxy specification, removing dependency on NAT-PT as well as
> > resolving problems pointed in [RFC4966].
> >
> > // masaxmasa
> >
>
>