Subject: FW: New Version Notification for draft-ietf-v6ops-ipv6-cpe-router-01

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Tue, 18 Aug 2009 17:19:20 -0400

Folks,

This is the last version of the IPv6 CPE Router Recommendations with I and Wes as authors.  The next revision will include Ole Troan and Chris Donley as co-authors.
Since San Francisco IETF in Spring 2009, a decision was made to split up the document into two.  The second document has also been posted today as draft-wbeebee-v6ops-ipv6-cpe-router-bis-00.txt.

Hemant

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Tuesday, August 18, 2009 5:05 PM
To: Hemant Singh (shemant)
Cc: Wes Beebee (wbeebee)
Subject: New Version Notification for draft-ietf-v6ops-ipv6-cpe-router-01 

A new version of I-D, draft-ietf-v6ops-ipv6-cpe-router-01.txt has been successfuly submitted by Hemant Singh and posted to the IETF repository.

Filename:	 draft-ietf-v6ops-ipv6-cpe-router
Revision:	 01
Title:		 IPv6 CPE Router Recommendations
Creation_date:	 2009-08-18
WG ID:		 v6ops
Number_of_pages: 21

Abstract:
This document recommends IPv6 behavior for Customer Premises
Equipment (CPE) routers in Internet-enabled homes and small offices.
The CPE Router may be a standalone device.  The CPE Router may also
be embedded in a device such as a cable modem, DSL modem, cellular
phone, etc.  This document describes the router portion of such a
device.  The purpose behind this document is to provide minimal
functionality for interoperability and create consistency in the
customer experience and satisfy customer expectations for the device.
Further, the document also provide some guidance for implementers to
expedite availability of IPv6 CPE router products in the marketplace.
It is expected that standards bodies other than the IETF developing
standards for specific products in this area (e.g.  CableLabs
eRouter, Broadband Forum, Home Gateway Initiative, etc.) may
reference this work for basic functionality and provide value-added
or linktype-specific customizations and enhancements which are beyond
the scope of this document.

The IETF Secretariat.

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 19 Aug 2009 17:49:40 +0300

Hi Hemant,

I took a quick look at the BIS document, and it is not self explanatory. What does "DEV" mean? What does "MEDIUM" mean? A terminology section would be appreciated.

Do we really consider packet filtering (a technology older than IPv6 :-) to be "under development"? How does this document relate to the "simple security" draft?

Thanks,
	Yaron

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Hemant Singh (shemant)
> Sent: Wednesday, August 19, 2009 0:19
> To: [email-masked]
> Cc: Hemant Singh (shemant); Wes Beebee (wbeebee)
> Subject: FW: New Version Notification for draft-ietf-v6ops-ipv6-cpe-
> router-01
> 
> Folks,
> 
> This is the last version of the IPv6 CPE Router Recommendations with I and
> Wes as authors.  The next revision will include Ole Troan and Chris Donley
> as co-authors.
> Since San Francisco IETF in Spring 2009, a decision was made to split up
> the document into two.  The second document has also been posted today as
> draft-wbeebee-v6ops-ipv6-cpe-router-bis-00.txt.
> 
> Hemant
> 
> A new version of I-D, draft-ietf-v6ops-ipv6-cpe-router-01.txt has been
> successfuly submitted by Hemant Singh and posted to the IETF repository.
> 
> �jy�u����$>���:-jT�r��!���

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Wed, 19 Aug 2009 11:05:03 -0400

Yaron,

This BIS document is part 2 of the IPv6 CPE Router Recommendations document.  The first document is at

http://www.ietf.org/id/draft-ietf-v6ops-ipv6-cpe-router-01.txt

Please see last paragraph in section 1 of the draft above for explanation of the DEV and MEDIUM terms. 

This document does not try to define any new IPv6 security and instead points to the IPv6 simple security document.   The only reason packet filtering has been defined as DEV is because it is described in more detail in the simple security document but the simple security document is Work in Progress (not an RFC yet).  In general I agree with you that packet filtering is older than IPv6.  Do appreciate one fact that given tunneled IPv6 data and new drafts in the area of changing IPv6 standards for firewall traversal has not agreed upon how to filter relevant IPv6 data.  That is where some more of DEV behavior gets into packet filtering for IPv6.

Hemant

-----Original Message-----
From: Yaron Sheffer [mailto:[email-masked]] 
Sent: Wednesday, August 19, 2009 10:50 AM
To: Hemant Singh (shemant); [email-masked]
Cc: Wes Beebee (wbeebee)
Subject: RE: New Version Notification for draft-ietf-v6ops-ipv6-cpe-router-01 

Hi Hemant,

Thanks,
	Yaron

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 19 Aug 2009 18:26:25 +0300

Yes, I found that document myself, but the document should clarify its terminology, or at least have a terminology section pointing to that other doc.

But I'm worried about the practical implications. *Any* IPv4 CPE today has some form of packet filtering, even if it's all mixed up with NAT. If we now declare it "advanced" and move it to a separate RFC, we will be signaling the industry that packet filtering on the CPE is "nice to have". IMHO that would be a big mistake. Big enough to slow down ISP adoption of IPv6.

Thanks,
	Yaron

> From: Hemant Singh (shemant) [mailto:[email-masked]]
> Sent: Wednesday, August 19, 2009 18:05
> To: Yaron Sheffer; [email-masked]
> Cc: Wes Beebee (wbeebee)
> This document does not try to define any new IPv6 security and instead
> points to the IPv6 simple security document.   The only reason packet
> filtering has been defined as DEV is because it is described in more
> detail in the simple security document but the simple security document is
> Work in Progress (not an RFC yet).  In general I agree with you that
> packet filtering is older than IPv6.  Do appreciate one fact that given
> tunneled IPv6 data and new drafts in the area of changing IPv6 standards
> for firewall traversal has not agreed upon how to filter relevant IPv6
> data.  That is where some more of DEV behavior gets into packet filtering
> for IPv6.
> 
> Hemant
> 
> I took a quick look at the BIS document, and it is not self explanatory.
> What does "DEV" mean? What does "MEDIUM" mean? A terminology section would
> be appreciated.
> 
> Do we really consider packet filtering (a technology older than IPv6 :-)
> to be "under development"? How does this document relate to the "simple
> security" draft?
> 
> Thanks,
> 	Yaron
> 
> IƧ��[�(^rC�{S�֥I�.�+r�^��

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Wed, 19 Aug 2009 12:17:23 -0400

Yaron,

Sure, we can make the terminology available in the bis version too.  There is no RFC on packet filtering nor any widely deployed IPv6 CPE Router that performs packet filtering.  That is why this topic is under DEV.

Hemant

-----Original Message-----
From: Yaron Sheffer [mailto:[email-masked]] 
Sent: Wednesday, August 19, 2009 11:26 AM
To: Hemant Singh (shemant); [email-masked]
Cc: Wes Beebee (wbeebee)
Subject: RE: New Version Notification for draft-ietf-v6ops-ipv6-cpe-router-01 

Thanks,
	Yaron

---

From: james woodyatt <[email-masked]>
Date: Wed, 19 Aug 2009 15:57:50 -0700

On Aug 19, 2009, at 09:17, Hemant Singh (shemant) wrote:
>
> ...nor any widely deployed IPv6 CPE Router that performs packet  
> filtering.

I would humbly disagree with this statement.

--
james woodyatt <[email-masked]>
member of technical staff, communications engineering

---

From: Antonio Querubin <[email-masked]>
Date: Fri, 21 Aug 2009 10:45:42 -1000 (HST)

On Wed, 19 Aug 2009, james woodyatt wrote:

>> ...nor any widely deployed IPv6 CPE Router that performs packet filtering.
>

I concur.  The Airport's IPv6 behaviour is becoming well-known to some in 
our tech support department, particularly when it sits several routers 
deep into a customer's NAT'ed, IPv4-only network :)

Antonio Querubin
808-545-5282 x3003
e-mail/xmpp:  [email-masked]

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Fri, 21 Aug 2009 18:03:48 -0400

-----Original Message-----
From: Antonio Querubin [mailto:[email-masked]] 
Sent: Friday, August 21, 2009 4:46 PM
To: james woodyatt
Cc: Hemant Singh (shemant); Yaron Sheffer; [email-masked]; Wes
Beebee (wbeebee)
Subject: Re: New Version Notification for
draft-ietf-v6ops-ipv6-cpe-router-01

>deep into a customer's NAT'ed, IPv4-only network :)

Fine, Antonio and James.  Wes and I were thinking once the cpe simple
security draft becomes an RFC, we'd be happy to move the packet
filtering from DEV to MEDIUM.  In the meantime, we are still humbly open
to any input.

Hemant