Subject: Re: [v6ops] draft-andrews-v6ops-6to4-router-option-00.txt

From: Cameron Byrne <[email-masked]>
Date: Wed, 11 May 2011 18:25:36 -0700

On May 11, 2011 6:14 PM, "Mark Andrews" <[email-masked]> wrote:
>
>
> In message <[email-masked]>, Lorenzo
Colitti writes:
> > On Wed, May 11, 2011 at 4:39 PM, Mark Andrews <[email-masked]> wrote:
> >
> > > Not always but there are plenty of network admins that would like
> > > to have a switch they could use to turn off 6to4 on machines
> > > connecting to their networks.  They would set the switch even if
> > > it only stopped a single machine they would think that the 3 seconds
> > > it took to install the option was worth it.
> > >
> >
> > Actually, if I were such a network admin, I think I would prefer my
machines
> > to turn off 6to4 unconditionally, not based on some DHCP option. Either
way
> > it's a code upgrade...
>
> It's minor configuration changes in many cases.  Real life configs.
> The "default 6to4rro 192.88.99.1;" isn't strictly needed as this
> is a outbound 6to4 interface for return traffic, however if you
> were using 6to4 for forward traffic it sets the address of the
> anycast relay.
>
> Old:
> interface "sis0" {
>        request subnet-mask, broadcast-address, time-offset, routers,
>                domain-name, domain-name-servers, ntp-servers;
>        require subnet-mask, domain-name-servers;
>        supersede domain-name "dv.isc.org isc.org rc.vix.com";
>        prepend domain-name-servers 127.0.0.1;
>        send dhcp-lease-time 7200;
> }
>
> octets=`echo $new_ip_address | sed 's/\./ /g'`
> ifconfig stf0 inet6 2002:`printf %02x%02x:%02x%02x $octets`:: \
>        prefixlen 16 alias anycast link0
> route add -inet6 2002:: -prefixlen 16 ::1
> route change -inet6 2002:: -prefixlen 16 ::1 -ifp stf0
>
> New:
> option 6to4rro code <tbd> ip-address;
> interface "sis0" {
>        request subnet-mask, broadcast-address, time-offset, routers,
>                domain-name, domain-name-servers, ntp-servers, 6to4rro;
>        require subnet-mask, domain-name-servers;
>        supersede domain-name "dv.isc.org isc.org rc.vix.com";
>        prepend domain-name-servers 127.0.0.1;
>        send dhcp-lease-time 7200;
>        default 6to4rro 192.88.99.1;
> }
>
> if [ -n "$new_6to4rro" -a "$6to4rro" != 0.0.0.0 ]
> then
>        octets=`echo $new_ip_address | sed 's/\./ /g'`
>        ifconfig stf0 inet6 2002:`printf %02x%02x:%02x%02x $octets`:: \
>                prefixlen 16 alias anycast link0
>        route add -inet6 2002:: -prefixlen 16 ::1
>        route change -inet6 2002:: -prefixlen 16 ::1 -ifp stf0
> elif [ "$6to4rro" = 0.0.0.0 ]
> then
>        route delete -inet6 2002:: -prefixlen 16
>        ifconfig stf0 down
> fi
>
> --
> Mark Andrews, ISC
> 1 Seymour St., Dundas Valley, NSW 2117, Australia
> PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
>

I am lost.

I click on the windows button in bottom left and then?

Cb _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Mark Andrews <[email-masked]>
Date: Thu, 12 May 2011 12:19:16 +1000

In message <BANLkTikKNO4bJH47kkQ1=[email-masked]>, Cameron Byrne writes:
> --e0cb4e43d0b7fb292a04a30a10ab
> Content-Type: text/plain; charset=ISO-8859-1
> 

You need to ask a Window guy about a Windows box.  The above works
with most Linux and BSD boxes with minor tweaks.  The actual example
was from a FreeBSD box.  I haven't delved deep enough into MacOS
to know whether you can do this with end user changes or not.

Before some else points it out the two "$6to4rro" should be
"$new_6to4rro". 

Mark