Subject: [v6ops] New Version Notification for draft-sarikaya-v6ops-prefix-delegation-05.txt

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 May 2011 09:59:25 -0700 (PDT)

> A new version of I-D, draft-sarikaya-v6ops-prefix-delegation-05.txt has been  
>successfully submitted by Behcet Sarikaya and posted to the IETF  repository.
> 
> Filename:      draft-sarikaya-v6ops-prefix-delegation
> Revision:      05
> Title:         DHCPv6 Prefix Delegation as  IPv6 Migration Tool in Mobile 
>Networks
> Creation date:      2011-05-26
> WG ID:         Individual  Submission
> Number of pages: 12
> 
> Abstract:
>    As interest on  IPv6 deployment is increasing in cellular networks
>    several migration  issues are being raised and IPv6 prefix management
>    is the one  addressed in this document.  Based on the idea that DHCPv6
>     servers can manage prefixes, we address prefix management issues such
>     as the access router offloading delegation and release tasks of the
>     prefixes to a DHCPv6 server using DHCPv6 PD.  The access router  first
>    requests a prefix for an incoming mobile node from the DHCPv6  server.
>    The access router may next stateless or stateful address  allocation
>    to the mobile node, e.g. with a Router Advertisement or  using DHCP.
>    We also describe prefix management using Authentication  Authorization
>    and Accounting servers.
> 
>                                                                                 
>      
>
> 
> 
> The IETF Secretariat
>

---

From: huang cancan <[email-masked]>
Date: Tue, 31 May 2011 15:27:26 +0800

I have briefly read your draft.I think it is well written and much better
than the former version.

On Fri, May 27, 2011 at 12:59 AM, Behcet Sarikaya
<[email-masked]>wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: GangChen <[email-masked]>
Date: Tue, 31 May 2011 23:52:49 +0800

Hello Behcet,

I think that is a valid scenario in mobile network.
Also, your revision looks good for me.

BRs

Gang

---

From: jouni korhonen <[email-masked]>
Date: Wed, 1 Jun 2011 00:45:46 +0300

I think the question laid by Ole is still valid i.e. whether this I-D is the "best practice" or good guidance for mobile networks. Clearly the I-D has now turned to mostly about 3GPP system. And I seriously think the clarification 3GPP needs for its prefix delegation belongs to TS29.061. For example, it would be beneficial to state there that all prefixes delegated for PDN Connections are /64 (obvious) unless the UE is the requesting router, IAIDs could map to TEIDs etc. Then if we face a problem that requires IETF involvement, we can deal with it here. 

- Jouni

---

From: Jason Lin <[email-masked]>
Date: Wed, 1 Jun 2011 11:44:16 +0800

I think this draft is useful for mobile networks. But I still have some
questions and comments:
    - What is this draft's final goal?
    - Whether the term 'MN' is the same as 'UE'? If yes, it is better to
modify the figure 1.
    - It is better to provide the full name of abbreviations.
    - In the figure 3, there should be a DHCP client element in ‘MN’ and a
DHCP Server element in AR. Is it better to show them in the figure?
    - What are the Solicit message and Advertise message shown in figure 3
used for? It seems also need to be briefly explained in section 3.2.

Best Regards,

Jinyan Lin
China Telecom

On Wed, Jun 1, 2011 at 5:45 AM, jouni korhonen <[email-masked]>wrote:

>
> I think the question laid by Ole is still valid i.e. whether this I-D is
> the "best practice" or good guidance for mobile networks. Clearly the I-D
> has now turned to mostly about 3GPP system. And I seriously think the
> clarification 3GPP needs for its prefix delegation belongs to TS29.061. For
> example, it would be beneficial to state there that all prefixes delegated
> for PDN Connections are /64 (obvious) unless the UE is the requesting
> router, IAIDs could map to TEIDs etc. Then if we face a problem that
> requires IETF involvement, we can deal with it here.
>
> - Jouni
>
>