Subject: [v6ops] IPv6 Diagnostic Option

From: [email-masked]
Date: Thu, 21 Jul 2011 21:38:52 -0700 (PDT)

Hello Folks,

Would love to get feedback on an Internet Draft we have submitted.  The issue we are addressing is that the IP Identification field which was available with IPv4 in the main header is available with IPv6 only in the Fragment Header.

Please see:

http://tools.ietf.org/id/draft-elkins-6man-ipv6-diagnostic-header-00.txt

We do have a revision (version 01) which is attached and also a submission to the v6ops group.  The submission system is closed so we will update it formally when it reopens on July 25th.  

Thanks!
Nalini Elkins
Inside Products, Inc.

---

From: Roland Bless <[email-masked]>
Date: Fri, 22 Jul 2011 07:41:45 +0200

Hi,

On 22.07.2011 06:38, [email-masked] wrote:
> Would love to get feedback on an Internet Draft we have submitted.

> The issue we are addressing is that the IP Identification field which
> was available with IPv4 in the main header is available with IPv6
> only in the Fragment Header.

I don't think that your proposed solution is necessary, since
IPv6 has the Flow Label, that - if set by the source - may be
very well suited for your purpose (tracking flows along a path).
Please see http://datatracker.ietf.org/doc/draft-ietf-6man-flow-3697bis/
for more details.

Kind regards,
 Roland

---

From: Erik Kline <[email-masked]>
Date: Fri, 22 Jul 2011 15:35:37 +0900

> Please see http://datatracker.ietf.org/doc/draft-ietf-6man-flow-3697bis/

Agreed.

I also think use of the flowlabel will prove operationally simpler.
Some devices drop IPv6 packets that have any kind of headers, even
fragment headers, since they lack the ability to look beyond these
headers at line rate.

---

From: Roland Bless <[email-masked]>
Date: Fri, 22 Jul 2011 09:59:46 +0200

Hi Erik,

> I also think use of the flowlabel will prove operationally simpler.

Yes, fully agree since
a) the Flow Label is part of the standard common IPv6 header, thus
   always present and easier to process (even in the fast path) as
   you also pointed out.
b) Useful Flow Label support in end-systems (i.e., setting the Flow
   Label correctly) is more likely than support for this newly
   suggested additional option, once it would have been adopted.
c) it is really unclear how you would enable the use of the proposed
   option in end-systems on demand. In case of debugging a network
   problem you need to enable this option later, if not too late.

Regards,
 Roland

---

From: Arturo Servin <[email-masked]>
Date: Fri, 22 Jul 2011 08:37:06 -0300

Nalini

	Basically I agree with what others said.

	If there were any reason for not using the flow label, I think you should state it very clearly in the document. 

Regards,
.as

On 22 Jul 2011, at 04:59, Roland Bless wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: [email-masked]
Date: Fri, 22 Jul 2011 09:03:06 -0700 (PDT)

Thanks to all for your comments.  But, there may be some confusion as to what we are trying to achieve.  The Proposed Flow Label field, in our opinion, does not meet our requirements. The reasons are as follows:

1.  The Flow Label, as defined, is a unique and (generally speaking) static identifier per flow.  Its purpose is to distinguish one flow from another.  

2.  Our proposed field increments per packet WITHIN a flow.  The intended purpose is to distinguish one packet from another not one flow from another.

3.  The Flow Label is only 20 bits which is not sufficient to hold even the existing 32 bit ID.  We are proposing a 64-bit ID. 

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

--- On Thu, 7/21/11, Roland Bless <[email-masked]> wrote:

> From: Roland Bless <[email-masked]>
> Subject: Re: [v6ops] IPv6 Diagnostic Option
> To: [email-masked]
> Cc: [email-masked]
> Date: Thursday, July 21, 2011, 10:41 PM
> Hi,
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>