Subject: Re: [v6ops] Draft on email transition to IPv6 from IPv4 for sevice providers and other communities

From: Ray Hunter <[email-masked]>
Date: Sat, 23 Jul 2011 10:44:25 +0200

>
> Subject:
> Re: [v6ops] Draft on email transition to IPv6 from IPv4 for sevice 
> providers and other communities
> From:
> "John R. Levine" <[email-masked]>
> Date:
> 23 Jul 2011 07:49:16 +0200
>
> To:
> "Ted Lemon" <[email-masked]>
> CC:
> Joe St Sauveur <[email-masked]>, "[email-masked]" 
> <[email-masked]>, Keith Moore <[email-masked]>, Dave 
> Crocker <[email-masked]>
>
> Precedence:
> list
> MIME-Version:
> 1.0
> References:
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <[email-masked]> 
> <CADrOfL+fb5UMihx6=[email-masked]> 
> <[email-masked]> 
> <[email-masked]>
> In-Reply-To:
> <[email-masked]>
> Message-ID:
> <[email-masked]>
> Content-Type:
> TEXT/PLAIN; charset=US-ASCII; format=flowed
> Message:
> 5
>
>
>
> I gather that you don't know anyone whose mail servers get a billion 
> connections per day, over 90% of which is spam.  I do.
>
> It's hard to avoid the impression that few people in this discussion 
> are familiar with the operation of large mail systems.  If your system 
> gets 100K connections per day, any half-assed design will do.  If it 
> gets 100M connections per day, you have to know what you're doing.
>
> Regards,
> John Levine, [email-masked], Primary Perpetrator of "The Internet for 
> Dummies",
> Please consider the environment before reading this e-mail. http://jl.ly

With all due respect, people operating mega MTA's will probably learn 
little from any draft produced by v6ops.
If anything, shouldn't they be contributing to it?

Rather than a "mine's bigger than yours" discussion, aren't the 
following questions things we should be asking on v6ops:

Why is there any need for such mega MTA's?

Did X400 have it right in the first place, and email is so difficult to 
do well that it's best left to a few large Telco/ISP providers?

Is it because these millions of email users have some requirement in 
common and thus cannot run their own distributed MTA's?

Or is it the fact that it's just so hard and time-consuming for the 
average IT savvy end-user to run their own MTA today, due to all sorts 
of barriers, and that this will only get worse with IPv6?

If it is the last option, isn't this exactly why the email transition 
draft should be a v6ops WG item to provide useful information or BCP, 
and that the target reader should be the average IT-savvy IPv4 MTA operator?

[Disclaimer: this email comes from someone who runs their own ipv6 
capable MTA on the Internet, but who is apparently disqualified from 
contributing because the volume is so low]

regards,
RayH

---

From: Philip Homburg <[email-masked]>
Date: Sat, 23 Jul 2011 12:42:39 +0200

>contributing because the volume is so low]

I guess you and I are in the easy part of the MTA spectrum. 

At the very low end, consumers can only run their own mail server is it is
just a single button click to turn it on. That's a hard problem.

Then we get to the small scale mail servers. That is easy. Somebody who knows
a little bit about DNS, configuring software, etc. can easily set up a
mailserver.

Then you get to bigger organization, thousands of users. There you need
qualified people who know about scaling. Many of those organizations got rid
of everybody who actually knows how stuff works and replaced them with 
consultants who are better at billing then actually making things work.

So, both individuals who want to be independent of their ISPs and bigger 
organizations outsource their e-mail to big e-mail providers.

---

From: Ted Lemon <[email-masked]>
Date: Sat, 23 Jul 2011 13:52:48 +0000

On Jul 23, 2011, at 4:44 AM, Ray Hunter wrote:
Or is it the fact that it's just so hard and time-consuming for the average IT savvy end-user to run their own MTA today, due to all sorts of barriers, and that this will only get worse with IPv6?

If it is the last option, isn't this exactly why the email transition draft should be a v6ops WG item to provide useful information or BCP, and that the target reader should be the average IT-savvy IPv4 MTA operator?

One of the reasons I'm keen on seeing MTAs at least *deliver* to IPv6 addresses is that I think in principle IPv6 ought to make it possible for people to move away from the million-plus-user MTA model.   However, I think it's a big leap from it being possible to it happening.   Right now I'm just interested in it being possible.

---

From: Philip Homburg <[email-masked]>
Date: Sat, 23 Jul 2011 16:05:23 +0200

In your letter dated Sat, 23 Jul 2011 13:52:48 +0000 you wrote:
>One of the reasons I'm keen on seeing MTAs at least *deliver* to IPv6 addre=
>sses is that I think in principle IPv6 ought to make it possible for people=
> to move away from the million-plus-user MTA model.   However, I think it's=
> a big leap from it being possible to it happening.   Right now I'm just in=
>terested in it being possible.

One thing to make this possible would a 'secondary MX' service that
accepts mail over IPv4, spam filters it and then delivers it over IPv6 to the
customer.

---

From: Keith Moore <[email-masked]>
Date: Sat, 23 Jul 2011 10:20:54 -0400

> One of the reasons I'm keen on seeing MTAs at least *deliver* to IPv6 addresses is that I think in principle IPv6 ought to make it possible for people to move away from the million-plus-user MTA mo…

Me too.  But as far as I can tell, the biggest barrier to running your own MTA, or a small enterprise running its own MTA, is spam filtering.  I've advised several small business clients to migrate their own in house mail services to a large commercial provider, because there's no way that a small enterprise can mange an effective, locally-run spam filtering operation anywhere nearly as cheaply as a large MSP can provide an equivalent service.  

(YMMV, in fact it almost certainly does vary.   People's experience of spam varies widely.  But my clients were getting a fair amount of spam and it was interfering with their ability to do billable work.)

Keith

---

From: Ted Lemon <[email-masked]>
Date: Sat, 23 Jul 2011 16:20:50 +0000

On Jul 23, 2011, at 10:20 AM, Keith Moore wrote:
Me too.  But as far as I can tell, the biggest barrier to running your own MTA, or a small enterprise running its own MTA, is spam filtering.  I've advised several small business clients to migrate their own in house mail services to a large commercial provider, because there's no way that a small enterprise can mange an effective, locally-run spam filtering operation anywhere nearly as cheaply as a large MSP can provide an equivalent service.

Sad, but true.   I get some mileage out of free RBLs, but it's still pretty bad.   Needs further work.

---

From: "John R. Levine" <[email-masked]>
Date: 23 Jul 2011 18:41:23 +0200

> With all due respect, people operating mega MTA's will probably learn little 
> from any draft produced by v6ops.

You might be interested in draft-oreirdan-rosenwald-ipv6mail-transition-00
which is written by two tech guys at Comcast.

> Why is there any need for such mega MTA's?

I don't understand this question.  If you are Hotmail or Comcast, with 
millions of users, you need a mail system that can handle your users' 
mail.  If you're arguing that mail systems shouldn't have that many users, 
we're definiting out of scope.

> Is it because these millions of email users have some requirement in common 
> and thus cannot run their own distributed MTA's?

Based on my experience (you might want to ask Google about the books I've 
written), the vast majority of users have no interest whatsoever in 
running any mail software at all.  They don't want to run an MUA, much 
less an MTA.  That's why web mail is so popular.

> [Disclaimer: this email comes from someone who runs their own ipv6 capable 
> MTA on the Internet, but who is apparently disqualified from contributing 
> because the volume is so low]

In case it's not clear, my mail system isn't very big either, with maybe 
100K connections on a normal day and 400K on a busy one.  I'm not saying 
that people shouldn't contribute, but I am saying that it is not useful to 
assume that what works on our toy systems will work on the kinds of large 
systems that the majority of Internet users use.

There's plenty of room for systems of all sizes, but if we're going to 
offer advice for running them, we really need to understand what the 
issues are at different scales, and have a reasonable understanding of 
what the issues are likely to be, most notably, the ways that spammers, 
who are totally anti-social, are likely to attack whatever is built.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

---

From: "John R. Levine" <[email-masked]>
Date: 23 Jul 2011 19:05:38 +0200

> Me too.  But as far as I can tell, the biggest barrier to running your 
> own MTA, or a small enterprise running its own MTA, is spam filtering.

Quite right.  If an enterprise wants to run its own mail service (which in 
my experience is relatively rare, not because it's so hard, but because 
it's one more damned thing not directly related to their actual business), 
you can outsource it to companies like Messagelabs or MX Logic who run 
filtering proxies in front of your MTA.

There are also on-site filtering proxies like Barracuda, but I've never 
seen one I would recommend.

Obv6: Some of these companies are thinking about inbound v6 but I don't 
know any who are offering it yet.  Perhaps someone interested in v6 mail 
could poke around their web sites and see what they're currently saying.

Regards,