Subject: [v6ops] draft-moore-6to4-experimental-00.txt

From: Keith Moore <[email-masked]>
Date: Sun, 10 Jul 2011 16:34:10 -0400

Apparently, the draft got hung up in the submission process.  The secretariat said they'd post it if I emailed them a copy with the correct boilerplate, which I believe I did, but they may still be backlogged.  Anyway, it can be downloaded here:

http://home.earthlink.net/~heretic/data/draft-moore-6to4-experimental-00.txt

I'm not asking that v6ops take this on, but I'd appreciate any comments from v6ops participants in private mail.    After I get some feedback, I'll revise the draft and circulate it more widely.

Keith

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Mon, 18 Jul 2011 16:28:53 +0200

Imho the concept fight "Historical vs Experimental" does not make sense
and seems a religious discussion... 

6to4 was used in production and helped many people when v6 was not
ubiquitous, so experimental 

makes no sense to me as that is a state of a protocol when it was
developed and had no real production 

examples beyond a lab or simple linux implementation. Imho 6to4 should
be deprecated to avoid people 

will do further standardization (or even use the technology) and hence
historical status seems best fit.

G/

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Keith Moore
Sent: 10 July 2011 22:34
To: [email-masked] WG
Subject: [v6ops] draft-moore-6to4-experimental-00.txt

Apparently, the draft got hung up in the submission process.  The
secretariat said they'd post it if I emailed them a copy with the
correct boilerplate, which I believe I did, but they may still be
backlogged.  Anyway, it can be downloaded here:

http://home.earthlink.net/~heretic/data/draft-moore-6to4-experimental-00
.txt

I'm not asking that v6ops take this on, but I'd appreciate any comments
from v6ops participants in private mail.    After I get some feedback,
I'll revise the draft and circulate it more widely.

Keith

---

From: Keith Moore <[email-masked]>
Date: Mon, 18 Jul 2011 10:41:03 -0400

I probably should make this clearer in the next version of -experimental.  But I believe specifically that 6to4 can be useful to experiment with better ways of traversing the v4/v6 boundary (e.g. to avoid path asymmetry) and that such experimentation can help produce transition mechanisms that are better than any of 6to4, Teredo, and statically configured tunnels.

Keith

On Jul 18, 2011, at 10:28 AM, Gunter Van de Velde (gvandeve) wrote:

> Imho the concept fight “Historical vs Experimental” does not make sense and seems a religious discussion…
>  
> 6to4 was used in production and helped many people when v6 was not ubiquitous, so experimental
> makes no sense to me as that is a state of a protocol when it was developed and had no real production
> examples beyond a lab or simple linux implementation. Imho 6to4 should be deprecated to avoid people
> will do further standardization (or even use the technology) and hence historical status seems best fit.
>  
> G/
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Keith Moore
> Sent: 10 July 2011 22:34
> To: [email-masked] WG

---

From: Mark Townsley <[email-masked]>
Date: Thu, 21 Jul 2011 00:19:20 +0200

> I probably should make this clearer in the next version of -experimental.  But I believe specifically that 6to4 can be useful to experiment with better ways of traversing the v4/v6 boundary (e.g. t…

OK, what better ways are you proposing that are not already well explored in 6rd, 6a44, etc? 

- Mark

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Keith Moore <[email-masked]>
Date: Wed, 20 Jul 2011 18:31:16 -0400

> OK, what better ways are you proposing that are not already well explored in 6rd, 6a44, etc? 

I'm not going to detail them publicly just yet.  I know better than to invite people to take pot shots at a proposal before it's worked out in sufficient detail.    I hope that next week will present some opportunities to discuss the ideas informally with other people who are interested in solving this problem.   Maybe somebody will identify a way to strengthen the proposal, or maybe somebody will identify a fatal flaw.  Either way, I should have a better sense in a week or two about how workable these ideas are.

Keith