Subject: [v6ops] Comments for draft-keranen-ipv6day-measurements-01

From: Hui Deng <[email-masked]>
Date: Sat, 23 Jul 2011 07:14:03 +0800

Hello authors

This work has gathered the useful information, appreciate the work.
Several comments below:
1) Have you done the delay test for the case host which doesn't have IPv6
connection, have to fall back
to IPv4 connection? does this prove dual stack website not feasible during
the IPv6 transition stage?

2) could you predict how many website sitting behind of NAT64?

3) Does the measure tool is a open source for download?

4) There are 13 top 100 support AAAA which is less than 14 before IPv6 day,
who is that website?

Best regards,

-Hui

---

From: Ari Keranen <[email-masked]>
Date: Tue, 26 Jul 2011 15:15:25 -0400

Hi,

> This work has gathered the useful information, appreciate the work.

Thanks!

> Several comments below:
> 1) Have you done the delay test for the case host which doesn't have
> IPv6 connection, have to fall back
> to IPv4 connection? does this prove dual stack website not feasible
> during the IPv6 transition stage?

Our tests did not include a fall back possibility. But I'd say a 
dual-stack websites is in fact desirable during the transition stage.

> 2) could you predict how many website sitting behind of NAT64?

Not from these tests, but I'd be a bit surprised if there were any in 
the top 10k web sites.

> 3) Does the measure tool is a open source for download?

Unfortunately not; having the tool open sourced would require going 
through a non-trivial amount of bureaucracy. If you're really 
interested, contact me off-list and I can see if we can work out something.

> 4) There are 13 top 100 support AAAA which is less than 14 before IPv6
> day, who is that website?

ipv6.baidu.com had an AAAA record until the 65th test run.

Cheers,
Ari

---

From: Mark Andrews <[email-masked]>
Date: Wed, 27 Jul 2011 12:09:04 +1000

What we need is Radware, F5 and other load balancer vendors to send
out instructions to their customer on how to correctly configure
their load balancers to serve A records at the top of a zone rather
that one label deep in a zone.  This misconfiguration is responsible
for +90% of AAAA lookup failures.

Lots of load balancers are delegated to as "www.example.com" but
the load balancer is configured to serve "example.com" rather than
the zone that is *actually* delegated to it.  This results in invalid
negative responses being sent (the SOA record returned in the
negative response is for "example.com" rather than "www.example.com")
which is then rejected by the recursive nameserver.

Radware and F5 are mention because I've chased down actual failures,
in the last 3 months, and these were the reported products involved.
I'm sure there will be other vendor that also have similar issues.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: "George, Wesley" <[email-masked]>
Date: Thu, 28 Jul 2011 19:10:38 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark Andrews
Sent: Tuesday, July 26, 2011 10:09 PM
To: Ari Keranen
Cc: [email-masked]
Subject: Re: [v6ops] Comments for draft-keranen-ipv6day-measurements-01

[WEG] Should this perhaps be incorporated into the v6day call-to-arms draft or some other draft? Not the vendor specific fixes, but perhaps a discussion about this issue that people should consider. Is it also documented in the appropriate IPv6 Wikis (ARIN, etc)?

Thanks
Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Ari Keranen <[email-masked]>
Date: Fri, 29 Jul 2011 14:53:06 -0400

Hi Mark,

> for +90% of AAAA lookup failures.

This sounds interesting (and disturbing). Is the "+90%" your personal 
estimate or are there actual measurements done with this? Any publications?

Cheers,
Ari

---

From: Mark Andrews <[email-masked]>
Date: Sat, 30 Jul 2011 15:34:17 +1000

> estimate or are there actual measurements done with this? Any publications?

Go look at the Alexa top million sites.  The is a couple of percent failure
rate on AAAA lookup.  Then examine those failures.