Subject: [v6ops] Lion/Snow Leaopard side-by-side on an IPv6 enabled ADSL2+ home line..

From: George Michaelson <[email-masked]>
Date: Mon, 1 Aug 2011 11:20:02 +1000

I had a moment in time to test a Snow Leopard, and Lion OSX setup @home, before completing my upgrade to Lion on all boxes.

I tested http://www.apnic.net/ http://ipv6actnow.org/ and http://www.ripe.net/

All three connect on IPv6 for Snow Leopard.

All three connect on IPv4 for Lion.

The ping6/ping delay differences:

                              IPv6                     IPV4
www.apnic.net:    29.668/ 30.224/ 30.511/ 0.305 ms   27.484/ 33.900/ 55.400/ 9.697 ms 
www.ripe.net:    384.082/427.672/474.278/32.085 ms  345.837/379.814/450.711/37.940 ms
ipv6actnow.org:  371.395/409.083/457.154/29.726 ms  346.257/384.443/434.757/30.477 ms

I think that from a difference/variance point of view, all three sites were rationally 'better' on IPv4

So, in that sense "it worked". -The selection alg as encoded in Lion, is doing a reasonable job.

-George

---

From: Daniel Roesen <[email-masked]>
Date: Mon, 1 Aug 2011 07:37:19 +0200

> All three connect on IPv4 for Lion.

Excellent, so operators have to make sure that their LSN setups will
artificially introduce some delay to bias clients to use IPv6 to
offload the expensive NATs. We shall raise feature requests with the
vendors.

Best regards,
Daniel

-- 
CLUE-RIPE -- Jabber: [email-masked] -- dr@IRCnet -- PGP: 0xA85C8AA0