Subject: [v6ops] Request for WG Adoption of draft-xli-v6ops-ivi-icmp-address-00

From: Xing Li <[email-masked]>
Date: Tue, 26 Jul 2011 22:36:32 +0800

Hi V6ops Chairs,

The authors of draft-xli-v6ops-ivi-icmp-address-00 would like to request that the V6ops WG adopt draft-xli-v6ops-ivi-icmp-address-00.txt as a WG adoption.

The draft describes the operational considerations of mapping ICMPv6 packets through an RFC6145 gateway where the IPv6 address is not directly translatable into an IPv4 address, and requests an IANA Special Purpose IPv4 address allocation to allow this address mapping to take place using a protocol-specific designated address block in IPv4.

The authors are hopeful that this will not require any valuable face-to-face WG time at IETF 81 and the WG's consideration of this document can be undertaken entirely on the mailing list.

regards,

Xing Li

---

From: Fred Baker <[email-masked]>
Date: Wed, 27 Jul 2011 14:40:59 -0400

Folks: the chairs are in receipt of this note. Please read the draft and comment.

In short, the draft requests an IPv4 prefix to be used in ICMPv4 to refer to IPv6 routers on the far side of a translator. In the reverse case, ICMPv6 would translate the address to an IPv4-embedded address as defined in RFC 6145 (an IPv6 address containing and statelessly translatable to an IPv4 address). If we buy off on it - and that's a discussion we should have on this list - Ron can walk it through the IESG and get the assignment.

Begin forwarded message:

> From: Xing Li <[email-masked]>
> Date: July 26, 2011 10:36:32 AM EDT
> To: [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: Request for WG Adoption of draft-xli-v6ops-ivi-icmp-address-00
> 
> Hi V6ops Chairs,
>