Subject: Re: [v6ops] [pcp] WG last call on draft-ietf-pcp-base-16.txt

From: james woodyatt <[email-masked]>
Date: Thu, 27 Oct 2011 16:32:15 -0700

On Oct 27, 2011, at 3:39 AM, RJ Atkinson wrote:
> On 26  Oct 2011, at 00:44 , Paul Selkirk wrote:
>> 
>> OTOH, a) if we define it for IPv4 multicast, someone will surely
>> and immediately request it for IPv6 multicast;
> 
> If true, that's a trivial edit that could be made within a day.  
> The IPv6 all-nodes link-local multicast address was defined 
> over a decade ago and is widely supported in environments 
> where native IPv6 is deployed.

I will stand up right now and say this is issue yet another reason for me to complain that PCP is not ready to meet requirements derived from REC-48 of RFC 6092 for IPv6 residential gateway simple security functions.

If responding to the "significant pressure" from V6OPS to publish a PCP base specification, so that RFC 6204bis can cite it, is a priority for the PCP working group, then that argues for stopping the current WGLC until the Rapid Recovery capability in I-D.cheshire-pcp-recovery is restored to the PCP base specification.

On the other hand, another option is for PCP to be withdrawn as a candidate for meeting REC-48 of RFC 6092, which would free V6OPS to consider another protocol for that purpose in RFC 6204bis instead.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: Keith Moore <[email-masked]>
Date: Thu, 27 Oct 2011 20:02:18 -0400

> On the other hand, another option is for PCP to be withdrawn as a candidate for meeting REC-48 of RFC 6092, which would free V6OPS to consider another protocol for that purpose in RFC 6204bis inste…

I don't think we need two different protocols.  But IMO the emphasis in PCP on accommodating LSNs is misplaced.   Long term, the more important use of PCP is to interface between hosts/applications and IPv6 firewalls... and NATs should be eradicated.  That's not to say that I object to including IPv4/LSN support in PCP, but that feature should not be the primary driver of PCP's design.  PCP should be designed first for v6 and other uses considered secondary.

Keith

---

From: Francis Dupont <[email-masked]>
Date: Fri, 28 Oct 2011 16:20:33 +0200

In your previous mail you wrote:

   On the other hand, another option is for PCP to be withdrawn as a
   candidate for meeting REC-48 of RFC 6092, which would free V6OPS to
   consider another protocol for that purpose in RFC 6204bis instead.
   
-> do you mean UPnP-gw-WANIPv6FirewallControl-v1-Service-20101210.pdf?
(part of UPnP IGD v2)

Regards

[email-masked]

---

From: Francis Dupont <[email-masked]>
Date: Fri, 28 Oct 2011 16:23:46 +0200

But IMO the emphasis in PCP on accommodating LSNs is misplaced.

=> there is a simple reason for this: the CPE control is
more than dominated in the current world by UPnP IGD...

Regards

---

From: james woodyatt <[email-masked]>
Date: Fri, 28 Oct 2011 09:49:59 -0700

On Oct 28, 2011, at 7:20 AM, Francis Dupont wrote:
> 
> do you mean UPnP-gw-WANIPv6FirewallControl-v1-Service-20101210.pdf?
> (part of UPnP IGD v2)

RFC 6092 includes a list of marginally viable alternatives, including but not limited to UPnP IGD, which were current at the time of its publication.