Subject: Re: [v6ops] Fwd: 82nd IETF DRAFT Agenda

From: 孟少卿 <[email-masked]>
Date: Sun, 30 Oct 2011 18:32:11 +0800

Hi all
       I also support draft-xli-v6ops-ivi-icmp-address-00.txt  to be adopted as a WG document in V6ops. A special block of IPv4 address mapping for  the non-directly translatable IPv6 address will  helpful for us to troubleshoot. We have deployed the stateless translator for about two years in the campus networks.

Best Regards
Shaoqing Meng
Tianjin University Information and Network Center

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Xing Li
发送时间: 2011年10月24日 18:37
收件人: V6ops Chairs
抄送: [email-masked] WG
主题: Re: [v6ops] Fwd: 82nd IETF DRAFT Agenda

Hi, Fred and All,

于 2011/10/14 5:52, Fred Baker 写道:
> The initial version of the agenda has been posted. It places v6ops on Wednesday and Friday mornings, a total of 4.5 hours. I personally am satisfied with it, but if folks have issues I can pass them along.
>
> I'll note that the deadline for -00 drafts is 24 October, and the deadline for updated drafts is a week later. For discussion in the working group meetings, I'm looking for a draft posted after 25 July, with supporting email discussion on the list.
>
> I'm looking for (and in some cases have seen) commentary on each of:
>
> -rw-rw-r--  1 fred  fred  13796 Jul 25 23:59 
> draft-xli-v6ops-ivi-icmp-address-00.txt

I would like to request that the V6ops WG adopt draft-xli-v6ops-ivi-icmp-address-00.txt as a WG adoption.

The draft describes the operational considerations of mapping ICMPv6 packets through an RFC6145 gateway where the IPv6 address is not directly translatable into an IPv4 address, and requests an IANA Special Purpose IPv4 address allocation (192.70.192.0/24) to allow this address mapping to take place using a protocol-specific designated address block in IPv4.

The authors are hopeful that this will not require any valuable face-to-face WG time at IETF 82 and the WG's consideration of this document can be undertaken entirely on the mailing list.

Regards,

xing

> -rw-rw-r--  1 fred  fred  34974 Sep 14 10:45 
> draft-ietf-v6ops-happy-eyeballs-04.txt
> -rw-rw-r--  1 fred  fred  26625 Sep 27 13:22 
> draft-kuarsingh-v6ops-6to4-provider-managed-tunnel-04.txt
> -rw-rw-r--  1 fred  fred  25341 Oct  2 11:39 
> draft-jjmb-v6ops-comcast-ipv6-experiences-02.txt
> -rw-rw-r--  1 fred  fred  28127 Oct  6 14:13 
> draft-gashinsky-v6ops-v6nd-problems-00.txt
> -rw-rw-r--  1 fred  fred  45016 Oct  7 12:39 draft-ietf-v6ops-6204bis-00.txt
> -rw-rw-r--  1 fred  fred   8877 Oct 10 09:00 draft-ietf-v6ops-ipv6-discard-prefix-00.txt
> -rw-rw-r--  1 fred  fred  15656 Oct 12 20:38 
> draft-carpenter-v6ops-label-balance-00.txt
>
> plus any new drafts that are posted.
>
> Begin forwarded message:
>
>> From: IETF Agenda<[email-masked]>
>> Date: October 13, 2011 2:13:10 PM PDT
>> To: Working Group Chairs<[email-masked]> Cc:[email-masked]
>> Subject: 82nd IETF DRAFT Agenda
>>
>> The DRAFT agenda is ready for viewing.  Please note the cutoff date 
>> for requests to reschedule Working Group and BOF meetings is October 
>> 17, 2011
>> 17:00 PT.  The final agenda will be published on October 21, 2011.
>>
>> https://datatracker.ietf.org/meeting/82/agenda.html
>> https://datatracker.ietf.org/meeting/82/agenda.txt
>>
>> http://www.ietf.org/meeting/82/index.html
>>
>>
>> Thanks,
>> Wanda
>>
>> Only 30 days until Taipei, 82nd IETF!
>> Online registration for the IETF meeting is at:
>> http://www.ietf.org/meeting/register.html
>>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>
>

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Joel jaeggli <[email-masked]>
Date: Sun, 30 Oct 2011 15:51:53 -0700

On 10/30/11 03:32 , 孟少卿 wrote:
> Hi all I also support draft-xli-v6ops-ivi-icmp-address-00.txt  to be
> adopted as a WG document in V6ops. A special block of IPv4 address
> mapping for  the non-directly translatable IPv6 address will  helpful
> for us to troubleshoot. We have deployed the stateless translator for
> about two years in the campus networks.

What addresses do you presentialy use a the source address for icmp
messages sent from the stateless translator?

> Best Regards Shaoqing Meng Tianjin University Information and Network
> Center
> 
> -----邮件原件----- 发件人: [email-masked]
> [mailto:[email-masked]] 代表 Xing Li 发送时间: 2011年10月24日 18:37 收件
> 人: V6ops Chairs 抄送: [email-masked] WG 主题: Re: [v6ops] Fwd: 82nd IETF
> DRAFT Agenda
> 
> Hi, Fred and All,
> 
>> The initial version of the agenda has been posted. It places v6ops
>> on Wednesday and Friday mornings, a total of 4.5 hours. I
>> personally am satisfied with it, but if folks have issues I can
>> pass them along.
>> 
>> I'll note that the deadline for -00 drafts is 24 October, and the
>> deadline for updated drafts is a week later. For discussion in the
>> working group meetings, I'm looking for a draft posted after 25
>> July, with supporting email discussion on the list.
>> 
> I would like to request that the V6ops WG adopt
> draft-xli-v6ops-ivi-icmp-address-00.txt as a WG adoption.
> 
> The draft describes the operational considerations of mapping ICMPv6
> packets through an RFC6145 gateway where the IPv6 address is not
> directly translatable into an IPv4 address, and requests an IANA
> Special Purpose IPv4 address allocation (192.70.192.0/24) to allow
> this address mapping to take place using a protocol-specific
> designated address block in IPv4.
> 
> The authors are hopeful that this will not require any valuable
> face-to-face WG time at IETF 82 and the WG's consideration of this
> document can be undertaken entirely on the mailing list.
> 
> Regards,
> 
> xing
> 
>> draft-ietf-v6ops-happy-eyeballs-04.txt -rw-rw-r--  1 fred  fred
>> 26625 Sep 27 13:22 
>> draft-jjmb-v6ops-comcast-ipv6-experiences-02.txt -rw-rw-r--  1 fred
>> fred  28127 Oct  6 14:13 
>> draft-gashinsky-v6ops-v6nd-problems-00.txt -rw-rw-r--  1 fred  fred
>> 45016 Oct  7 12:39 draft-ietf-v6ops-6204bis-00.txt -rw-rw-r--  1
>> fred  fred   8877 Oct 10 09:00
>> draft-ietf-v6ops-ipv6-discard-prefix-00.txt -rw-rw-r--  1 fred
>> fred  15656 Oct 12 20:38 
>>> From: IETF Agenda<[email-masked]> Date: October 13, 2011 2:13:10
>>> PM PDT To: Working Group Chairs<[email-masked]>
>>> Cc:[email-masked] Subject: 82nd IETF DRAFT Agenda
>>> 
>>> The DRAFT agenda is ready for viewing.  Please note the cutoff
>>> date for requests to reschedule Working Group and BOF meetings is
>>> October 17, 2011 17:00 PT.  The final agenda will be published on
>>> October 21, 2011.
>>> 
>>> Thanks, Wanda
>>> Only 30 days until Taipei, 82nd IETF! Online registration for the
>>> IETF meeting is at: http://www.ietf.org/meeting/register.html
>>> 
>> _______________________________________________ v6ops mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>> 
>> 
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
> 
> _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Fred Baker <[email-masked]>
Date: Mon, 31 Oct 2011 09:50:55 +0800

> messages sent from the stateless translator?

My understanding is that he doesn't - the message is dropped. The net effect in a traceroute (IPv4) is to see something that looks like a routing loop or a black hole on the far side (IPv6) of the translator. He'd like something that shows that distance is progressing and it's a state number of hops beyond the translator. It's not all the information one would like to see, but it's more and better than "* * *".

In the reverse direction, traceroute6 from the IPv6 side, the ICMP6 message can represent the IPv4 address as ::ipv4 or ::FFFF:ipv4. We see that in the wild now.

---

From: Joel jaeggli <[email-masked]>
Date: Sun, 30 Oct 2011 19:39:51 -0700

On 10/30/11 18:50 , Fred Baker wrote:
>>> Hi all I also support draft-xli-v6ops-ivi-icmp-address-00.txt  to
>>> be adopted as a WG document in V6ops. A special block of IPv4
>>> address mapping for  the non-directly translatable IPv6 address
>>> will  helpful for us to troubleshoot. We have deployed the
>>> stateless translator for about two years in the campus networks.
>> 
>> What addresses do you presentialy use a the source address for
>> icmp messages sent from the stateless translator?
> 
> My understanding is that he doesn't - the message is dropped. The net
> effect in a traceroute (IPv4) is to see something that looks like a
> routing loop or a black hole on the far side (IPv6) of the
> translator. He'd like something that shows that distance is
> progressing and it's a state number of hops beyond the translator.
> It's not all the information one would like to see, but it's more and
> better than "* * *".

Why not use a gua v4 address bound to the translator

It might not be asthetically pleasing but it identifies the source
rather well and it's not likely to be filtered.

> In the reverse direction, traceroute6 from the IPv6 side, the ICMP6
> message can represent the IPv4 address as ::ipv4 or ::FFFF:ipv4. We
> see that in the wild now.
> 
>>> Best Regards Shaoqing Meng Tianjin University Information and
>>> Network Center
>>> 
>>> [mailto:[email-masked]] 代表 Xing Li 发送时间: 2011年10月24日
>>> 18:37 收件 人: V6ops Chairs 抄送: [email-masked] WG 主题: Re: [v6ops]
>>> Fwd: 82nd IETF DRAFT Agenda
>>> 
>>> Hi, Fred and All,
>>> 
>>>> The initial version of the agenda has been posted. It places
>>>> v6ops on Wednesday and Friday mornings, a total of 4.5 hours.
>>>> I personally am satisfied with it, but if folks have issues I
>>>> can pass them along.
>>>> 
>>>> I'll note that the deadline for -00 drafts is 24 October, and
>>>> the deadline for updated drafts is a week later. For discussion
>>>> in the working group meetings, I'm looking for a draft posted
>>>> after 25 July, with supporting email discussion on the list.
>>>> 
>>> The draft describes the operational considerations of mapping
>>> ICMPv6 packets through an RFC6145 gateway where the IPv6 address
>>> is not directly translatable into an IPv4 address, and requests
>>> an IANA Special Purpose IPv4 address allocation (192.70.192.0/24)
>>> to allow this address mapping to take place using a
>>> protocol-specific designated address block in IPv4.
>>> 
>>> face-to-face WG time at IETF 82 and the WG's consideration of
>>> this document can be undertaken entirely on the mailing list.
>>> 
>>> Regards,
>>> 
>>> xing
>>> 
>>>> draft-ietf-v6ops-happy-eyeballs-04.txt -rw-rw-r--  1 fred
>>>> fred 26625 Sep 27 13:22 
>>>> draft-jjmb-v6ops-comcast-ipv6-experiences-02.txt -rw-rw-r--  1
>>>> fred fred  28127 Oct  6 14:13 
>>>> draft-gashinsky-v6ops-v6nd-problems-00.txt -rw-rw-r--  1 fred
>>>> fred 45016 Oct  7 12:39 draft-ietf-v6ops-6204bis-00.txt
>>>> -rw-rw-r--  1 fred  fred   8877 Oct 10 09:00 
>>>>> From: IETF Agenda<[email-masked]> Date: October 13, 2011
>>>>> 2:13:10 PM PDT To: Working Group Chairs<[email-masked]> 
>>>>> The DRAFT agenda is ready for viewing.  Please note the
>>>>> cutoff date for requests to reschedule Working Group and BOF
>>>>> meetings is October 17, 2011 17:00 PT.  The final agenda will
>>>>> be published on October 21, 2011.
>>>>> 
>>>>> Only 30 days until Taipei, 82nd IETF! Online registration for
>>>>> the IETF meeting is at:
>>>> _______________________________________________ v6ops mailing
>>>> list [email-masked]
>>> _______________________________________________ v6ops mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>>> 
>>> _______________________________________________ v6ops mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
>>> 
>> 
> 
>

---

From: Yu Guanghui <[email-masked]>
Date: Mon, 31 Oct 2011 11:00:09 +0800

> Why not use a gua v4 address bound to the translator

From IPv4 side, We can't identify it's a translator or a regular router if use a IPv4 address bound to the translator.

---

From: Joel jaeggli <[email-masked]>
Date: Sun, 30 Oct 2011 20:17:36 -0700

> From IPv4 side, We can't identify it's a translator or a regular router if use a IPv4 address bound to the translator.

it is a router...

---

From: Yu Guanghui <[email-masked]>
Date: Mon, 31 Oct 2011 12:53:01 +0800

Here is a example:

ping ivi.dlut.edu.cn   <- it's a pure IPv6 site behind a stateless translator.
PING ivi.dlut.edu.cn (58.200.163.1) 56(84) bytes of data.
64 bytes from 58.200.163.1: icmp_seq=1 ttl=45 time=103 ms
64 bytes from 58.200.163.1: icmp_seq=2 ttl=45 time=106 ms

but when we trace it:

traceroute ivi.dlut.edu.cn
traceroute to ivi.dlut.edu.cn (58.200.163.1), 30 hops max, 40 byte packets
 1  202.118.66.1 (202.118.66.1)  0.399 ms  0.459 ms  0.582 ms
 ...
10  202.112.61.182 (202.112.61.182)  15.579 ms *  15.503 ms  <- what happened here? maybe a firewall, router or translator?
11  * * *
12  * * *
....
29  * * *
30  * * *

We will don't what happened after hop 10.  If we have a special mapping address, for example 192.70.192.0, we will understand there's a translator and have some other helpful information.

Yu Guanghui <ygh at dlut.edu.cn>
Network and Information Center
Dalian University of Technology, China
Tel: +86 411 84708117

---

From: Joel jaeggli <[email-masked]>
Date: Sun, 30 Oct 2011 21:59:23 -0700

> 10  202.112.61.182 (202.112.61.182)  15.579 ms *  15.503 ms  <- what happened here? maybe a firewall, router or translator?

right...

and we know that  this guy:

202.112.61.182

Is the last hop on this side of the event horizon.  just like if there
were a firewall or a non-stateful icmp filter.

---

From: 孟少卿 <[email-masked]>
Date: Mon, 31 Oct 2011 14:16:15 +0800

I map www-ivi.tju.edu.cn (58.200.205.80) to 2001:da8:ff3a:c8cd:5000::/64 , now you can visit it from IPv4. 
When ping from IPv4,it work well:
C:\Users\msq>ping 58.200.205.80

正在 Ping 58.200.205.80 具有 32 字节的数据:
来自 58.200.205.80 的回复: 字节=32 时间=34ms TTL=46
来自 58.200.205.80 的回复: 字节=32 时间=38ms TTL=46
来自 58.200.205.80 的回复: 字节=32 时间=41ms TTL=46
来自 58.200.205.80 的回复: 字节=32 时间=33ms TTL=46 And the server tcpdump output:
[root@ivi /]# tcpdump -n  | grep icmp
tcpdump: WARNING: eth0: no IPv4 address assigned
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
10:37:30.757919 2001:da8:ffca:710d:200:: > 2001:da8:ff3a:c8cd:5000::: icmp6: echo request seq 152
10:37:30.757938 2001:da8:ff3a:c8cd:5000:: > 2001:da8:ffca:710d:200::: icmp6: echo reply seq 152
10:37:31.761187 2001:da8:ffca:710d:200:: > 2001:da8:ff3a:c8cd:5000::: icmp6: echo request seq 153
10:37:31.761200 2001:da8:ff3a:c8cd:5000:: > 2001:da8:ffca:710d:200::: icmp6: echo reply seq 153
10:37:32.768389 2001:da8:ffca:710d:200:: > 2001:da8:ff3a:c8cd:5000::: icmp6: echo request seq 154

When traceroute from IPv4,it output:
C:\Users\msq>tracert -d www-ivi.tju.edu.cn

通过最多 30 个跃点跟踪
到 www-ivi.tju.edu.cn [58.200.205.80] 的路由:

  1    <1 毫秒   <1 毫秒   <1 毫秒 202.113.13.1
  2    <1 毫秒   <1 毫秒   <1 毫秒 202.113.14.17
  3    <1 毫秒   <1 毫秒   <1 毫秒 202.113.14.1
  4     *        *        *     请求超时。
  5    <1 毫秒   <1 毫秒   <1 毫秒 202.113.14.22
  6     *        *        *     请求超时。
  7    <1 毫秒   <1 毫秒   <1 毫秒 202.127.216.101
  8     3 ms     3 ms     2 ms  202.112.62.77
  9     3 ms     2 ms     3 ms  202.112.61.158
 10     3 ms     3 ms     3 ms  202.112.53.18
 11     3 ms     2 ms     3 ms  202.112.61.182
 12     *        *        *     请求超时。
 13     *        *        *     请求超时。
 14     *        *        *     请求超时。
 15     *        *        *     请求超时。
 16     *        *        *     请求超时。
 17     *        *        *     请求超时。
 18     *        *        *     请求超时。
 19    40 ms    39 ms    41 ms  58.200.205.80

跟踪完成。

So the source address is the mapped IPv4 address 58.200.205.80

-----邮件原件-----
发件人: Joel jaeggli [mailto:[email-masked]] 
发送时间: 2011年10月31日 6:52
收件人: [email-masked]
抄送: 'Xing Li'; [email-masked]; [email-masked]
主题: Re: [v6ops] Fwd: 82nd IETF DRAFT Agenda

> about two years in the campus networks.

What addresses do you presentialy use a the source address for icmp messages sent from the stateless translator?

>> The initial version of the agenda has been posted. It places v6ops on 
>> Wednesday and Friday mornings, a total of 4.5 hours. I personally am 
>> satisfied with it, but if folks have issues I can pass them along.
>> 
>> working group meetings, I'm looking for a draft posted after 25 July, 
>> with supporting email discussion on the list.
>> 
>> fred  28127 Oct  6 14:13 draft-gashinsky-v6ops-v6nd-problems-00.txt 
>> -rw-rw-r--  1 fred  fred
>> draft-ietf-v6ops-ipv6-discard-prefix-00.txt -rw-rw-r--  1 fred fred  
>> 15656 Oct 12 20:38 draft-carpenter-v6ops-label-balance-00.txt
>> 
>>> From: IETF Agenda<[email-masked]> Date: October 13, 2011 2:13:10 PM 
>>> PDT To: Working Group Chairs<[email-masked]> Cc:[email-masked] 
>>> 17, 2011 17:00 PT.  The final agenda will be published on October 
>>> 21, 2011.
>>>

---

From: Yu Guanghui <[email-masked]>
Date: Mon, 31 Oct 2011 15:03:53 +0800

> and we know that  this guy:

The difference is it happens close to the end host in IPv4 firewall schema, but in stateless IPv4-IPv6 Schema, it maybe happen in somewhere IPv4-IPv6 edge of ISP ( in middle of end hosts).

---

From: Yu Guanghui <[email-masked]>
Date: Mon, 31 Oct 2011 15:03:53 +0800