Subject: [v6ops] Privacy Considerations of draft-ietf-v6ops-v6-aaaa-whitelisting-implications-07

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 14 Oct 2011 13:58:05 +0000

One open question on the latest draft is in Section 6.2, pertaining to Privacy Considerations. One reviewer has suggestion removing the first two paragraphs in this section (http://tools.ietf.org/html/draft-ietf-v6ops-v6-aaaa-whitelisting-implications-07#section-6.2) and leaving only the third paragraph.

I am asking for feedback from the v6ops WG and from 2 IAB members here, Alissa and Hannes, who have been vocal on the topic of privacy consideration sections. My inclination is to leave the section largely as it is now in a longer form, rather than reducing it down (more detail being better).

Any opinions in the WG or from Alissa or Hannes?

Thanks!
Jason

---

From: "George, Wes" <[email-masked]>
Date: Fri, 14 Oct 2011 11:44:57 -0400

I think that the first two paragraphs are useful, and that you should keep 6.2 pretty much as-is, but remove "probably" in both of the places that it is used.

Thanks,

Wes George

From: [email-masked] [mailto:[email-masked]] On Behalf Of Livingood, Jason
Sent: Friday, October 14, 2011 9:58 AM
To: [email-masked]; Hannes Tschofenig; Alissa Cooper
Subject: [v6ops] Privacy Considerations of draft-ietf-v6ops-v6-aaaa-whitelisting-implications-07

Thanks!
Jason

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 23 Oct 2011 10:54:40 +0100

I agree. I would suggest some tweaks to the first paragraph to make the intent and applicability more clear:

As noted in Section 4.1, there is a benefit in sharing IPv6-related
   impairment statistics within the Internet community over time.  Any
   statistics that are shared or disclosed publicly should be aggregate statistics, such as
   "the domain example.com has observed an average daily impairment rate
   of 0.05% in September 2011, down from 0.15% in January 2011".  They should not include information that can directly or indirectly identify individuals, such as names or email addresses.  Sharing only aggregate data can help
   protect end user privacy and any information which may be proprietary
   to a domain.

In the second paragraph you might replace "or otherwise" with "and" since advising an end user is not necessarily a means of obtaining consent.

Incidentally, the IAB has published draft guidance about privacy considerations, http://tools.ietf.org/html/draft-iab-privacy-considerations-01. One of the areas that the guidance highlights is device fingerprinting. I assume that IPv6 impairment status is a piece of information that can make a device more susceptible to being uniquely fingerprinted; it might be worth mentioning that in this section to illustrate why impairment status should be disclosed/shared with care.

Alissa

On Oct 14, 2011, at 4:44 PM, George, Wes wrote:

> I think that the first two paragraphs are useful, and that you should keep 6.2 pretty much as-is, but remove “probably” in both of the places that it is used.
>  
> Thanks,
>  
> Wes George
>