Subject: Re: [v6ops] new draft: draft-carpenter-v6ops-icp-guidance

From: Arturo Servin <[email-masked]>
Date: Mon, 31 Oct 2011 09:00:34 -0200

Hi,

	I think the document is very well written and gives to the reader a very good initial idea of how to deploy IPv6 as an ICP. However I am not sure if this document belongs to the IETF. We are learning new ways (and better ways) to develop IPv6 and every day we found caveats in what in the past used to be the "only true".  I fear that this document will be obsoleted very quickly by events. 

	Some initial thoughts about the text. 

	Basically I do not agree with the recommendations of section 5.1 

	- IPv6 PI is not more expensive than IPv4 PI, so simply if a ICP has IPv4 PI the recommendation should be to get IPv6 PI. It won't cost more.
	- I do not buy the argument that we are going to have millions of PI prefixes and we are going to break the DFZ. Please, do not use that argument here, we do not still enough data.
	- If the ICP is multi-homed, go PI. Do not get complex with multiple PA assignments.
	- If you are an ICP, I do not see why not just go with a minimum of /48
	- As commented in other threads, I think the addressing strategy for servers should be static and then SLACC or DHCPv6 (not sure which one first).

	Section 5.3, DNS

	There is a lot of confusion out there about transport and data. It would be good to make an statement saying that you can serve AAAA records in a single stacked DNS with IPv4.

	Section 7.

	I would be good to have some recommendations from ICPs doing this. Is any document describing it? (I think it would be interesting to document it).

	Section 8.2

	I think it needs to advise strong testing before going production IPv6. We have found some applications (java for example) supported IPv6 but we found that the performance was very poor. I do not have the details now but I can ask to our developing and infrastructure team for them.

	This gets more complex as your applications uses more third party libraries.

Regards,
/as

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 01 Nov 2011 09:26:23 +1300

Arturo,

Thanks for the technical input, we will deal with that in the next version.

> However I am not sure if this document belongs to the IETF.

If not here, where does it belong? I agree that this is an evolving
area, of course; IMHO the enterprise deployment RFCs produced a few
years ago are not much use today.

Regards
   Brian

On 2011-11-01 00:00, Arturo Servin wrote:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Arturo Servin <[email-masked]>
Date: Mon, 31 Oct 2011 18:46:50 -0200

Brian,

On 31 Oct 2011, at 18:26, Brian E Carpenter wrote:

> If not here, where does it belong?

	I do not have an answer, that's why I do not oppose to it.

> I agree that this is an evolving

	That's is my fear, but I see no harm to have it now. 

Regards,
/as