Subject: [v6ops] Fwd: 82nd IETF DRAFT Agenda

From: Fred Baker <[email-masked]>
Date: Thu, 13 Oct 2011 14:52:04 -0700

The initial version of the agenda has been posted. It places v6ops on Wednesday and Friday mornings, a total of 4.5 hours. I personally am satisfied with it, but if folks have issues I can pass them along.

I'll note that the deadline for -00 drafts is 24 October, and the deadline for updated drafts is a week later. For discussion in the working group meetings, I'm looking for a draft posted after 25 July, with supporting email discussion on the list.

I'm looking for (and in some cases have seen) commentary on each of:

-rw-rw-r--  1 fred  fred  13796 Jul 25 23:59 draft-xli-v6ops-ivi-icmp-address-00.txt
-rw-rw-r--  1 fred  fred  34974 Sep 14 10:45 draft-ietf-v6ops-happy-eyeballs-04.txt
-rw-rw-r--  1 fred  fred  26625 Sep 27 13:22 draft-kuarsingh-v6ops-6to4-provider-managed-tunnel-04.txt
-rw-rw-r--  1 fred  fred  25341 Oct  2 11:39 draft-jjmb-v6ops-comcast-ipv6-experiences-02.txt
-rw-rw-r--  1 fred  fred  28127 Oct  6 14:13 draft-gashinsky-v6ops-v6nd-problems-00.txt
-rw-rw-r--  1 fred  fred  45016 Oct  7 12:39 draft-ietf-v6ops-6204bis-00.txt
-rw-rw-r--  1 fred  fred   8877 Oct 10 09:00 draft-ietf-v6ops-ipv6-discard-prefix-00.txt
-rw-rw-r--  1 fred  fred  15656 Oct 12 20:38 draft-carpenter-v6ops-label-balance-00.txt

plus any new drafts that are posted.

Begin forwarded message:

> From: IETF Agenda <[email-masked]>
> Date: October 13, 2011 2:13:10 PM PDT
> To: Working Group Chairs <[email-masked]>
> Cc: [email-masked]
> Subject: 82nd IETF DRAFT Agenda 
> 
> The DRAFT agenda is ready for viewing.  Please note the cutoff date for
> requests to reschedule Working Group and BOF meetings is October 17, 2011
> 17:00 PT.  The final agenda will be published on October 21, 2011.
> 
> https://datatracker.ietf.org/meeting/82/agenda.html
> https://datatracker.ietf.org/meeting/82/agenda.txt
> 
> http://www.ietf.org/meeting/82/index.html
> 
> 
> Thanks,
> Wanda
> 
> Only 30 days until Taipei, 82nd IETF!
> Online registration for the IETF meeting is at:
> http://www.ietf.org/meeting/register.html
>

---

From: Fred Baker <[email-masked]>
Date: Fri, 14 Oct 2011 10:49:01 -0700

Let me put out a general question for the group - who plans to post new drafts this time around? 

The reason for the question is that we right now have three slots, on Wednesday, Thursday, and Friday, on the draft agenda. If we have half hour discussions for each of the drafts below, that will take less than the 4.5 hours that Wednesday and Thursday comprise; if we get a total of ten drafts, we could have half hour discussions on each if we keep the Wednesday and Friday slots. We only need to keep three slots if we have more than that number and the WG wants to discuss them all. I want to know whether to release one and which to release. I also need to put together an agenda, which this is a big part of.
 
On Oct 13, 2011, at 2:52 PM, Fred Baker wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 15 Oct 2011 08:24:22 +1300

If there's interest, I'd like to discuss draft-carpenter-v6ops-label-balance
(Using the IPv6 Flow Label for Server Load Balancing), which is already
posted.

I would like to post draft-carpenter-v6ops-icp-guidance (IPv6 Guidance for
Internet Content and Application Service Providers) but I'm not quite sure
it will be ready.

Regards
   Brian Carpenter

---

From: "t.petch" <[email-masked]>
Date: Sat, 15 Oct 2011 12:23:51 +0200

----- Original Message -----
From: "Fred Baker" <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 14, 2011 7:49 PM
Subject: Re: [v6ops] Fwd: 82nd IETF DRAFT Agenda

> The reason for the question is that we right now have three slots, on
Wednesday, Thursday, and Friday, on the draft agenda. If we have half hour
discussions for each of the drafts below, that will take less than the 4.5 hours
that Wednesday and Thursday comprise; if we get a total of ten drafts, we could
have half hour discussions on each if we keep the Wednesday and Friday slots. We
only need to keep three slots if we have more than that number and the WG wants
to discuss them all. I want to know whether to release one and which to release.
I also need to put together an agenda, which this is a big part of.

Fred

Not long ago, you were suggesting that the sheer volume of I-Ds warranted a
split into v6ops-a and v6ops-b, so if there is time available, then a key topic
would be to review the 25 I-Ds listed on the web site under Related Topics in
order to decide which to bin.  The presence of the authors would be optional; if
they are not there to speak up in defence, and noone else there is, then bin the
I-D, as far as v6ops is concerned, for the forseeable future.

Almost as useful would be to produce criteria by which to judge what should and
should not make the grade in future.

Tom Petch

> > The initial version of the agenda has been posted. It places v6ops on
Wednesday and Friday mornings, a total of 4.5 hours. I personally am satisfied
with it, but if folks have issues I can pass them along.
> >
> > I'll note that the deadline for -00 drafts is 24 October, and the deadline
for updated drafts is a week later. For discussion in the working group
meetings, I'm looking for a draft posted after 25 July, with supporting email
discussion on the list.
> > -rw-rw-r--  1 fred  fred  26625 Sep 27 13:22
draft-kuarsingh-v6ops-6to4-provider-managed-tunnel-04.txt
> > -rw-rw-r--  1 fred  fred  25341 Oct  2 11:39
draft-jjmb-v6ops-comcast-ipv6-experiences-02.txt
> > -rw-rw-r--  1 fred  fred  28127 Oct  6 14:13
draft-gashinsky-v6ops-v6nd-problems-00.txt
> > -rw-rw-r--  1 fred  fred   8877 Oct 10 09:00
draft-ietf-v6ops-ipv6-discard-prefix-00.txt
> > -rw-rw-r--  1 fred  fred  15656 Oct 12 20:38
draft-carpenter-v6ops-label-balance-00.txt

---

From: Fred Baker <[email-masked]>
Date: Sun, 16 Oct 2011 20:33:34 -0700

> should not make the grade in future.

For the moment, as discussed at IETF 81, the criteria we're using is "fits the charter" and "Operators on the list comment on it saying it is interesting for them to discuss, or it is directly related to something operational such as IPv6 Day etc". I'd be willing to hear better criteria.

---

From: Xing Li <[email-masked]>
Date: Mon, 24 Oct 2011 18:36:39 +0800

Hi, Fred and All,

> -rw-rw-r--  1 fred  fred  13796 Jul 25 23:59 draft-xli-v6ops-ivi-icmp-address-00.txt

I would like to request that the V6ops WG adopt 
draft-xli-v6ops-ivi-icmp-address-00.txt as a WG adoption.

The draft describes the operational considerations of mapping ICMPv6 
packets through an RFC6145 gateway where the IPv6 address is not 
directly translatable into an IPv4 address, and requests an IANA Special 
Purpose IPv4 address allocation (192.70.192.0/24) to allow this address 
mapping to take place using a protocol-specific designated address block 
in IPv4.

The authors are hopeful that this will not require any valuable 
face-to-face WG time at IETF 82 and the WG's consideration of this 
document can be undertaken entirely on the mailing list.

Regards,

xing

>> From: IETF Agenda<[email-masked]>
>> To: Working Group Chairs<[email-masked]>
>> Cc:[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Mon, 24 Oct 2011 05:23:59 -0700

Looking for comments/support from the working group.

On Oct 24, 2011, at 3:36 AM, Xing Li wrote:

> I would like to request that the V6ops WG adopt draft-xli-v6ops-ivi-icmp-address-00.txt as a WG adoption.
> 
> The draft describes the operational considerations of mapping ICMPv6 packets through an RFC6145 gateway where the IPv6 address is not directly translatable into an IPv4 address, and requests an IANA Special Purpose IPv4 address allocation (192.70.192.0/24) to allow this address mapping to take place using a protocol-specific designated address block in IPv4.
> 
> The authors are hopeful that this will not require any valuable face-to-face WG time at IETF 82 and the WG's consideration of this document can be undertaken entirely on the mailing list.
> 
> Regards,
> 
> xing
>

---

From: Li pengfei <[email-masked]>
Date: Tue, 25 Oct 2011 10:41:29 +0800

Hi,

I support the adoption of draft-xli-v6ops-ivi-icmp-address-00.txt.

Being CERNET/CERNET2 NOC, I think allocation of a special IPv4 block can 
greatly help for the trouble shooting, especially for large-scale network.

Regards,

Pengfei

于 11-10-24 下午6:36, Xing Li 写道:
>> Wednesday and Friday mornings, a total of 4.5 hours. I personally am 
>> satisfied with it, but if folks have issues I can pass them along.
>>
>> I'll note that the deadline for -00 drafts is 24 October, and the 
>> deadline for updated drafts is a week later. For discussion in the 
>> working group meetings, I'm looking for a draft posted after 25 July, 
>> with supporting email discussion on the list.
>>
> directly translatable into an IPv4 address, and requests an IANA 
> Special Purpose IPv4 address allocation (192.70.192.0/24) to allow 
> this address mapping to take place using a protocol-specific 
> designated address block in IPv4.
>

-- 
Li Pengfei
CERNET NOC
[email-masked]
010-62784048

---

From: Yu Guanghui <[email-masked]>
Date: Tue, 25 Oct 2011 11:07:37 +0800

Hi all
       I also support draft-xli-v6ops-ivi-icmp-address-00.txt  to be adopted as a WG document in V6ops. A special block of IPv4 address mapping for  the non-directly translatable IPv6 address will  helpful for us to troubleshoot. We have deployed the stateless translator for about two years in the campus networks.

Yu Guanghui <ygh at dlut.edu.cn>
Network and Information Center
Dalian University of Technology, China

---

From: Joel jaeggli <[email-masked]>
Date: Mon, 24 Oct 2011 20:32:55 -0700

two thoughts...

wg cohchair hat on -
	I think the request deserves our consideration and certainly
	discussion on the mailing list and probably in the meeting.

wg cochair hat off -
	A well known address that I pretty much have to accept is imo 	
	a super attractive DOS source address and the security 		
	considerations section does little to mollify that concern for
	me. non-exclusive advertisement for the purpose of defeating
	urpf doesn't really excite me either.

	I haven't studied the issue deeply but it seems like there is
	substantial opportunity to spoof traffic to a 	
	stateless translator, that results in the third party of my
	choice recieving the icmp messages that are rather hard to
	determine the source of.

---

From: Zhankao WEN <[email-masked]>
Date: Wed, 26 Oct 2011 08:36:05 +0800 (CST)

I second.

--
Zhankao WEN
Networking Center of Northeastern University, China

----- Original Message -----
From: "Xing Li" <[email-masked]>
To: "V6ops Chairs" <[email-masked]>
Cc: "[email-masked] WG" <[email-masked]>
Sent: Monday, October 24, 2011 6:36:39 PM
Subject: Re: [v6ops] Fwd: 82nd IETF DRAFT Agenda

Hi, Fred and All,

Regards,

xing

---

From: Warren Kumari <[email-masked]>
Date: Wed, 26 Oct 2011 07:16:07 -0400

On Oct 24, 2011, at 6:36 AM, Xing Li wrote:

>> draft-xli-v6ops-ivi-icmp-address-00.txt

---

From: Warren Kumari <[email-masked]>
Date: Wed, 26 Oct 2011 07:32:35 -0400

> The draft describes the operational considerations of mapping ICMPv6 packets through an RFC6145 gateway where the IPv6 address is not directly translatable into an IPv4 address, and requests an IAN…

Summary:
I support adoption.

More words: 
I must admit to being somewhat uncomfortable with the potential for using this space to hide that actual course of a DoS -- yes, this is somewhat addressed in the Security Considerations, but that doesn't actually remove the problem.
That said, the sad fact is that with so many networks not doing BCP38 you already have no faith in the source address of a packet IMO the benefits outweigh the risks.

W

---

From: Warren Kumari <[email-masked]>
Date: Wed, 26 Oct 2011 07:35:02 -0400

>>> draft-xli-v6ops-ivi-icmp-address-00.txt

Apologies for the content free message (and then this apology for the content free message :-P), clicked the wrong button.
W

---

From: Xing Li <[email-masked]>
Date: Wed, 26 Oct 2011 21:55:40 +0800

Hi, Joel,

Thanks for the comments. Answers are inline.

> 	discussion on the mailing list and probably in the meeting.

Thanks.

> 	urpf doesn't really excite me either.

This well-konwn address block is only used as source address of ICMP
packets and will never be used as destination address. Therefore,

    Packet firewall filters should be configured to treat addresses in
    the IANA-assigned /24 network as martian addresses by discarding all
    non-ICMP packets that use the IANA-assigned /24 network as a source
    address, and all packets that use the IANA-assigned /24 network as a
    destination address.

It may be the case that some ISPs are slow to add this block as martian
addresses. However, if we can move forward the ISPs will have time to
take action, before more and more IPv4/IPv6 translators being deployed.

> 	choice recieving the icmp messages that are rather hard to

I believe it is not worse than an ISP whoes infrastructure is configured 
using
RFC1918 addresses. It is very difficult to trace back. But when treat this
block as martian address, the risk can be minimized.

Regards,

xing

---

From: Joel jaeggli <[email-masked]>
Date: Thu, 27 Oct 2011 17:01:05 -0700

>    address, and all packets that use the IANA-assigned /24 network as a

since it's in the special use block I already filter it.

it's the receiving icmp messages that I can't trace back to a source
that's the problem...

> block as martian address, the risk can be minimized.

you're not asking for it to be treated as a martian... if it were a
martian I would expect to never receive traffic from it at all. you're
asking for networks that wish to communicate with users using ivi
translators unconditionally accept icmp messages with this source
address (as opposed to for example a global unicast ip address bound to
the translator that appears as part of a prefix in my routing table).

---

From: 王竹威 <[email-masked]>
Date: Fri, 28 Oct 2011 12:29:13 +0800

I also support draft-xli-v6ops-ivi-icmp-address-00.txt  to be adopted as a WG document in V6ops. 
My university has been using stateless translator for more than one year,  and I found a special block of IPv4 address representing non-IPv4 translatable address will be very useful for trouble shooting. 

Regards,
WANG Zhuwei
Peking University

---

From: "George, Wes" <[email-masked]>
Date: Fri, 28 Oct 2011 10:01:11 -0400

I share some of the concerns raised by other folks regarding how this gets treated across AS boundaries, but probably this means that it's useful discussion to have in a WG meeting to determine if there is a way to meet the needs of the solution without creating concerns for operators about the traffic.

However, I'd like to pose a different question -
This is basically an effort to complete previously incomplete work on RFC6145, which was managed through BEHAVE. I know that BEHAVE is likely being closed down, but based on my read of the AD and list discussion, this was because there was not enough additional work to be undertaken to justify a recharter. No commentary intended on that front, but should we expect that our WG, which was already trying to find work to shed will now be seeing more orphaned BEHAVE work? Should we perhaps be pushing back on the decision to close down BEHAVE, or pushing back on those who are pursuing additional work in that space given that the consensus seems to be "we're done now"?

Thanks
Wes George

> Special Purpose IPv4 address allocation (192.70.192.0/24) to allow this
> address mapping to take place using a protocol-specific designated
> address block in IPv4.
> >
> > The authors are hopeful that this will not require any valuable face-
> to-face WG time at IETF 82 and the WG's consideration of this document
> can be undertaken entirely on the mailing list.
> >
> > Regards,
> >
> > xing
> >

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: buptnoc <[email-masked]>
Date: Sat, 29 Oct 2011 14:40:38 +0800

Hi, all,

I support that draft-xli-v6ops-ivi-icmp-address-00.txt

is adopted by V6ops WG as a WG item.

We have deployed IVI in BUPT, provided wireless access for
students and published a few of IPv6-only websites (such as http://www.mayan.cn/IA/) to
IPv4 Internet for one and half year.

At the same time, as an operator of CERNET2 NOC, I think the
allocation of a special IPv4 address block can greatly help us
for trouble-shooting, especially in large-scale network.

Best wishes

zhaoqin

于 2011-10-24 18:36, Xing Li 写道:

Hi,
Fred and All,

The initial version of the agenda has been
posted. It places v6ops on Wednesday and Friday mornings, a
total of 4.5 hours. I personally am satisfied with it, but if
folks have issues I can pass them along.

I'll note that the deadline for -00 drafts is 24 October, and
the deadline for updated drafts is a week later. For discussion
in the working group meetings, I'm looking for a draft posted
after 25 July, with supporting email discussion on the list.

I'm looking for (and in some cases have seen) commentary on each
of:

-rw-rw-r--  1 fred  fred  13796 Jul 25 23:59
draft-xli-v6ops-ivi-icmp-address-00.txt

The draft describes the operational considerations of mapping
ICMPv6 packets through an RFC6145 gateway where the IPv6 address
is not directly translatable into an IPv4 address, and requests an
IANA Special Purpose IPv4 address allocation (192.70.192.0/24) to
allow this address mapping to take place using a protocol-specific
designated address block in IPv4.

Regards,

xing

-rw-rw-r--  1 fred  fred  34974 Sep 14
10:45 draft-ietf-v6ops-happy-eyeballs-04.txt

-rw-rw-r--  1 fred  fred  45016 Oct  7 12:39
draft-ietf-v6ops-6204bis-00.txt

Begin forwarded message:

Cc:[email-masked]

The DRAFT agenda is ready for viewing.  Please note the cutoff
date for

requests to reschedule Working Group and BOF meetings is
October 17, 2011

17:00 PT.  The final agenda will be published on October 21,
2011.

Thanks,

Wanda

v6ops mailing list

[email-masked]

v6ops mailing list

[email-masked]

---

From: buptnoc <[email-masked]>
Date: Sat, 29 Oct 2011 14:52:27 +0800

+1

Best wishes

zhaoqin

---

From: 孟少卿 <[email-masked]>
Date: Sun, 30 Oct 2011 18:25:55 +0800

Hi all

Best Regards
Shaoqing Meng
Tianjin University Information and Network Center

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Fred Baker
发送时间: 2011年10月24日 20:24
收件人: [email-masked] WG
抄送: V6ops Chairs
主题: Re: [v6ops] Fwd: 82nd IETF DRAFT Agenda

On Oct 24, 2011, at 3:36 AM, Xing Li wrote:

>>> To: Working Group Chairs<[email-masked]> Cc:[email-masked]
>>> The DRAFT agenda is ready for viewing.  Please note the cutoff date 
>>> for requests to reschedule Working Group and BOF meetings is October 
>>> 17, 2011