Subject: [v6ops] HE and SSL

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 11 Oct 2011 13:37:30 +0200 (CEST)

Hi.

I quickly scanned the HE draft and couldn't find any reference to 
https/ssl. What is the strategy to use for https considerning some https 
based sites require you to re-authenticate if you change source IP 
address, how do they handle a change between IPv4 and IPv6 ? Does this 
need to be addressed in the draft somehow?

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Mark Andrews <[email-masked]>
Date: Wed, 12 Oct 2011 00:40:50 +1100

In message <[email-masked]>, Mikael Abrah
> need to be addressed in the draft somehow?

Once HE has given you a destination address you use it and don't use
HE for new connections.

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 11 Oct 2011 18:38:15 +0200 (CEST)

On Wed, 12 Oct 2011, Mark Andrews wrote:

> Once HE has given you a destination address you use it and don't use HE 
> for new connections.

For how long? When I reload the page 30 seconds later, will it re-initate 
a new "HE" decision?

---

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Tue, 11 Oct 2011 20:06:54 +0300

There is already a similar reference for HTTP under "5.8. Interaction with Same Origin Policy".
Doesn't the same apply to HTTPS too?

--
Tassos

Mikael Abrahamsson wrote on 11/10/2011 14:37:
>
> Hi.
>
> I quickly scanned the HE draft and couldn't find any reference to https/ssl. What is the strategy to use for https 
> considerning some https based sites require you to re-authenticate if you change source IP address, how do they handle 
> a change between IPv4 and IPv6 ? Does this need to be addressed in the draft somehow?
>

---

From: Mark Andrews <[email-masked]>
Date: Wed, 12 Oct 2011 08:39:41 +1100

In message <[email-masked]>, Mikael Abrah
> For how long? When I reload the page 30 seconds later, will it re-initate 

Is is the "same" session or not?  HE really doesn't change any of
this.  You shouldn't have been depending apon address lists to make
second connections anyway without HE.

Mark