Subject: Re: [v6ops] I-D Action: draft-ietf-v6ops-3gpp-eps-08.txt

From: Jouni <[email-masked]>
Date: Wed, 5 Oct 2011 00:15:17 +0300

Hi Paco,

On Oct 4, 2011, at 10:54 PM, Paco Cortes wrote:

> Hi Jouni,
> 
> I finally found the time to read this draft. It's a really good work.

Thanks. You are a bit late.. but..

> I have a few comments:
> 
> 1) End of section 1, list of "objectives of transition to IPv6": Do
> you intentionally omit the objective of allowing IPv6 only devices to
> be introduced? I would expect that some operators want to be able to
> introduce such devices sooner or later (some "sooner"). And you do
> have section 8.4 dedicated to networks with IPv6-only bearers, as well
> as several considerations about NAT64.
> 
> 2) Section 2.1, definition of APN: It states that an APN "resolves to
> a specific gateway". I think it is not strictly correct and possibly
> misleading. That it resolves to "a set of gateways" would be better.
> Nevertheless, you might ignore my comment if you think that this
> simplification is preferable to keep the draft simple.

The text could use your wording here.. as I try to say the same thing but over-simplifying.

> 
> 3) Section 2.1, definition of GTP: you might want to include a
> reference to 29.281

For the completeness that would be ok. However, in general [TS.29060] should be enough as a pointer to GTP-U since we are not too interested in GTP versioning per se.

> 
> 4) Section 2.1, definition of PDP Context: defined as virtual
> connection "between host and gateway". Correct would be "between UE
> and a PDN using a specific gateway". You might even omit the "gateway"

The text could use your wording here.

> part, although I think it is good to keep it to help a reader not
> familiar with 3gpp to understand the traffic paths.
> Related comment: Why don't you define "PDN Connection"? As you mention
> later in the draft, it is the EPS term for the older "PDP Context"
> term and it is more specific (Given that "PDP Contex" is sometimes
> used to mean "PDN connection" and some times just "bearer within a PDN
> connection")

The draft has own section later for those.

> 
> 5) Section 2.1, definition of SGSN, second sentence: "A per User
> Equipment ..." is not strictly correct. It is per PDN-Connection or
> PDP-Context (which implies per UE, but not the other way around. I.e.,
> one UE with two PDN Connections would require two tunnels). In

Well, the text does not make difference whether there is one or more PDN Connections/PDP Contexts.. so within that simplification I think the text is ok.

> addition, it is not correct for 3GDT cases.   Maybe the easiest would
> be to just remove the sentence.

We do skip most direct tunnel details in the draft. Though, in Section 3.1 we actually mention direct tunnel briefly where this case gets clarified.

> 
> 6) Section 2.2, first sentence: The APN does not refer to a GW, but to
> a PDN, potentially determining a specific GW (but also possibly a
> bigger set of GWs out of which the MME has to select one).

Correct and again mind our intentional over simplification ;)

> 
> 7) Section 4.1: Why is the definition of S11 missing? It looks strange
> as you do define S1-MME and all user-plane interfaces.

Hmm.. Seems the one line description of it got, for some reason, removed between -03 and -04. Probably an editing mistake.

> 
> 8) Section 4.3, second paragraph:"...GPRS, where UEs are not
> automatically assigned with an IP..." should rather be "...GPRS, where
> UEs are not automatically connected to PDN and where they therefore do
> not get an IP address assigned until the activate their first PDP
> context".
> I think it is important to understand that it is the existence of a
> default PDN that makes the difference between GPRS and EPS, the "IP
> address" is just a consequence.

Again, the text could use your wording.

> 
> 9) Section 4.3, last sentence: "...are immune to such losses". I would
> add "as long as they honor the contracted bit rates".

And again, the text could use your wording.

> 
> 
> I hope these comments help. Feel free to adopt proposed changes, to
> react to the comments in a different way, or just to ignore them if
> you did intentionally write the statements I'm concerned with.

I could try to squeeze most of these into AUTH48.. Some of the proposed rewordings really make the text better.

Thanks,
	Jouni

> 
> best regards,
>  Paco
> 
> 
> 
> 2011/9/30  <[email-masked]>:
>> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the IPv6 Operations Working Group of the IETF.
>> 
>>        Title           : IPv6 in 3GPP Evolved Packet System
>>        Author(s)       : Jouni Korhonen
>>                          Jonne Soininen
>>                          Basavaraj Patil
>>                          Teemu Savolainen
>>                          Gabor Bajko
>>                          Kaisu Iisakkila
>>        Filename        : draft-ietf-v6ops-3gpp-eps-08.txt
>>        Pages           : 35
>>        Date            : 2011-09-30
>> 
>>   Use of data services in smart phones and broadband services via HSPA
>>   and HSPA+, in particular Internet services, has increased rapidly and
>>   operators that have deployed networks based on 3GPP network
>>   architectures are facing IPv4 address shortages at the Internet
>>   registries and are feeling a pressure to migrate to IPv6.  This
>>   document describes the support for IPv6 in 3GPP network
>>   architectures.
>> 
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-eps-08.txt
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> This Internet-Draft can be retrieved at:
>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-v6ops-3gpp-eps-08.txt
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
>>

---

From: Paco Cortes <[email-masked]>
Date: Tue, 4 Oct 2011 21:54:52 +0200

Hi Jouni,

best regards,
  Paco