Subject: [v6ops] Review solicitation - draft-jiang-v6ops-semantic-prefix

From: Sheng Jiang <[email-masked]>
Date: Wed, 27 Feb 2013 03:22:03 +0000

Hi, all v6ops,

We have submitted a new version draft-jiang-v6ops-semantic-prefix, "A Framework for Semantic IPv6 Prefix and Gap Analysis" (http://tools.ietf.org/html/draft-jiang-v6ops-semantic-prefix). It is describes a framework that embeds semantics into IPv6 prefixes, so that network operators can efficiently manage their network traffic based on these explicit semantics.

This document was once presented in v6ops @ ietf84, Vancouver. There was many discussions and interests was expressed. After that, we have rewritten the document largely along with two new co-authors from China Telecom and Deutsche Telecom.

The authors believe it is useful work and operators can benefit from such network planning/management.

Please read the draft and comment. Your reviewing is important for us to improve the document.

A companion draft "Use case of IPv6 prefix semantics for operators" (http://tools.ietf.org/html/draft-sun-v6ops-semantic-usecase) has also been submitted to v6ops WG. It describes more specific use case for telecommunication operators.

Best regards,

Sheng

---

From: John Curran <[email-masked]>
Date: Wed, 27 Feb 2013 12:17:20 +0800

On Feb 27, 2013, at 11:22 AM, Sheng Jiang <[email-masked]> wrote:

> ...

Sheng - 

The draft contains the following text -

>    Using semantic prefix information for this function also makes it
>    possible for the service provider to increase the level of trust in
>    a customer-generated packet.  If the packet has an incorrectly set
>    source or destination address, then a session will simply fail to
>    establish.
> ...
>    The prefix can offer a higher level of trust for the network operator
>    because it is delegated by the network and therefore the network is
>    better able to detect any undesired modifications and filter the
>    packet accordingly.  If a user manipulated the destination address,
>    the packet will never arrive at the desired service; if the source
>    address is altered, then the return packet will not be received.

The premise that "prefix can offer a higher level of trust for the network 
operator because it is delegated by the network" does not apply to a source 
address, and we have ample proof on the Internet today that source addresses 
are routinely forged (the fact that the return packet is not received does
not make an effective deterrent.) 

One may perform entry control from subscribers to make sure that the source 
address complies with a certain requirements (such as your semantic prefix
information)  This _would_ allow an actual increase in the level of trust 
in customer-generated packets.

Note however that use of filters for customer-packet entry control may just 
as readily be deployed for header extension or option compliance, hence it is 
incorrect to state that "Using semantic prefix information for this function 
also makes it possible for the service provider to increase the level of trust 
in a customer-generated packet", as the increased trust in the user packets 
would come from the compliance filters in either case.

Can you update the document accordingly?

Thanks!
/John

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 27 Feb 2013 06:24:51 +0000

Hi, John,

Thanks for your reply. Your observation is accurate. The increasing of trust is brought by the compliance filters rather than semantic prefix. We will modify the content accordingly in the next version.

Many thanks and best regards,

Sheng

>-----Original Message-----
>From: John Curran [mailto:[email-masked]]
>Sent: Wednesday, February 27, 2013 12:17 PM
>To: Sheng Jiang
>Cc: [email-masked]; [email-masked]; sunqiong
>Subject: Re: [v6ops] Review solicitation - draft-jiang-v6ops-semantic-prefix
>
>> We have submitted a new version draft-jiang-v6ops-semantic-prefix, "A
>Framework for Semantic IPv6 Prefix and Gap Analysis"
>(http://tools.ietf.org/html/draft-jiang-v6ops-semantic-prefix). It is describes a
>framework that embeds semantics into IPv6 prefixes, so that network
>operators can efficiently manage their network traffic based on these explicit
>semantics.
>> ...