Subject: [v6ops] new draft: draft-ietf-v6ops-design-choices

From: <[email-masked]>
Date: Tue, 19 Feb 2013 05:45:01 -0800 (PST)

A new draft has been posted, at http://tools.ietf.org/html/draft-ietf-v6ops-design-choices. Please take a look at it and comment.

---

From: Mark Smith <[email-masked]>
Date: Tue, 19 Feb 2013 11:42:38 -0800 (PST)

Hi,

----- Original Message -----
> From: "[email-masked]" <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Sent: Wednesday, 20 February 2013 12:45 AM
> Subject: [v6ops] new draft: draft-ietf-v6ops-design-choices
> 
> 
> A new draft has been posted, at 
> http://tools.ietf.org/html/draft-ietf-v6ops-design-choices. Please take a look 
> at it and comment.
> _

This draft only covers unicast, however I think it would be useful to also cover anycast and multicast as they have been "baked in" to IPv6 from day one, and therefore they're ubiquitous capabilities.

Regarding anycast, IPv6 anycast is different from IPv4's, as in IPv6 it is also possible to anycast within the subnets on the link, rather than requiring packets to enter the routing/forwarding domain. This may have increased it's utility e.g. for some applications, link level anycast might be more useful than link level multicast. One application I can think of might be NTP servers on the link - the NTP servers have anycast addresses, and anycast is used to pick one of them, rather than having them all issue multicasts. Architectural Considerations of IP Anycast (draft-iab-anycast-arch-implications) and Operation of Anycast Services (RFC4786) would be useful references. RFC4786 seems to be limited to the "anycast implemented using the routing domain" scenario, so this draft would be an opportunity to add to that by also focussing on uses and advice on IPv6 anycast implemented within the link/subnet.

Regarding multicast, I think the common view might be that it is only useful for end-user applications, and therefore isn't useful or necessary to enable until a network needs to support one. However, I think multicast can be useful to a network operator, with an example being DHCPv6 relays using multicast to reach a distributed set of DHCPv6 servers. Another example I have heard of is the use of multicast to distribute Netflow/IPFix information to multiple collectors. As syslog is typically carried within UDP, using multicast to replicate it for redundancy to distributed syslog servers could be another use of interest to a network designer. Stepping back, the common requirements that multicast can satisfy for a network designer are duplication of packets/data and geographic diversity, for availability.

Regards,
Mark.