Subject: [v6ops] draft-steffann-tunnels-00.txt

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 15 Feb 2013 09:44:03 +0100

Hi all,

Three of us were asked by the Dutch academic network Surfnet to write an overview of IPv6-in-IPv4 tunneling mechanisms. To benefit the wider community, we did so in the form of a draft, that we intend to submit to the RFC Editor as an independent submission.

However, we would very much appreciate reviews and comments from within the IETF. These are the mechanisms we discuss:

3.  Tunnel Mechanisms  . . . . . . . . . . . . . . . . . . . . . .  5
     3.1.  Configured Tunnels (Manual Tunnels / 6in4) . . . . . . . .  6
     3.2.  Automatic Tunneling  . . . . . . . . . . . . . . . . . . .  7
     3.3.  IPv6 over IPv4 without Explicit Tunnels (6over4) . . . . .  8
     3.4.  Generic Routing Encapsulation (GRE)  . . . . . . . . . . .  9
     3.5.  Connection of IPv6 Domains via IPv4 Clouds (6to4)  . . . .  9
     3.6.  Anything In Anything (AYIYA) . . . . . . . . . . . . . . . 10
     3.7.  Intra-site Automatic Tunnel Addressing (ISATAP)  . . . . . 11
     3.8.  Tunneling IPv6 over UDP through NATs (Teredo)  . . . . . . 12
     3.9.  IPv6 Rapid Deployment (6rd)  . . . . . . . . . . . . . . . 13
     3.10. Native IPv6 behind NAT44 CPEs (6a44) . . . . . . . . . . . 14
     3.11. Peer-to-Peer IPv6 on Any Internetwork (6bed4)  . . . . . . 15
     3.12. The Locator/ID Separation Protocol (LISP)  . . . . . . . . 16
   4.  Related Protocols  . . . . . . . . . . . . . . . . . . . . . . 17
     4.1.  Tunnel Information and Control protocol (TIC)  . . . . . . 17
     4.2.  Tunnel Setup Protocol (TSP)  . . . . . . . . . . . . . . . 18
     4.3.  Dual-Stack Lite (Softwire) . . . . . . . . . . . . . . . . 19

Thanks!

Iljitsch

Begin forwarded message:

> From: [email-masked]
> Subject: I-D Action: draft-steffann-tunnels-00.txt
> Date: 15 februari 2013 9:34:07 CET
> To: [email-masked]
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : A comparison of IPv6 tunneling mechanisms
> 	Author(s)       : S.J.M. Steffann
>                          Iljitsch van Beijnum
>                          Rick van Rein
> 	Filename        : draft-steffann-tunnels-00.txt
> 	Pages           : 37
> 	Date            : 2013-02-15
> 
> Abstract:
>   This document provides an overview of various ways to to tunnel IPv6
>   packets over IPv4 networks.  It covers mechanisms in contemporary
>   use, touches on several mechanisms that are now only of historic
>   interest, and discusses some newer tunneling mechanisms that are not
>   (yet) widely used at the time of publication.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-steffann-tunnels
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-steffann-tunnels-00
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Fri, 15 Feb 2013 09:48:19 +0100

> Three of us were asked by the Dutch academic network Surfnet to write an overview of IPv6-in-IPv4 tunneling mechanisms. To benefit the wider community, we did so in the form of a draft, that we int…

Lest I forget: please note that we're 98% done with the document, there are still a few things we need to look at. But we wanted to get the document submitted well before Monday's cutoff.

---

From: "Ivan Pepelnjak" <[email-masked]>
Date: Sat, 16 Feb 2013 18:46:34 +0100

One word: amazing! Great job.

Ivan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Iljitsch van Beijnum
> Sent: Friday, February 15, 2013 9:44 AM
> To: IPv6 Ops WG
> Subject: [v6ops] draft-steffann-tunnels-00.txt
> 
> Hi all,
> 
> Three of us were asked by the Dutch academic network Surfnet to write an
> overview of IPv6-in-IPv4 tunneling mechanisms. To benefit the wider
> community, we did so in the form of a draft, that we intend to submit to
> the RFC Editor as an independent submission.
> 
> However, we would very much appreciate reviews and comments from within
> the IETF. These are the mechanisms we discuss:
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops