Subject: [v6ops] Internet Protocol Version 6 (IPv6) Profile for Mobile Devices

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 11 Mar 2013 11:43:27 +0000

I remain concerned about the cognitive dissonance between this draft and draft-ietf-v6ops-rfc3316bis.

> Abstract
> 
>    This document specifies an IPv6 profile for mobile devices.  It lists
>    the set of features a mobile device is to be compliant with to
>    connect to an IPv6-only or dual-stack mobile network.  The document
>    identifies also features to ensure IPv4 service continuity over an
>    IPv6-only transport.
> 
>    Both Hosts and devices with LAN capabilities are in scope.

It is correct to say that this is "an IPv6 Profile", in the sense that there may be other profiles. It is incorrect to say that this is the profile required for connecting to "an IPv6-only or dual-stack mobile network", which is to say "for connecting the device to any IPv6 mobile network, whether IPv4 or also configured or not". That profile is described in RFC 3316 and is being updated in draft-ietf-v6ops-rfc3316bis.

I will send one document to the IESG that updates or replaces RFC 3316, and I am willing to send one document that refers to 3316bis and adds additional requirements for some more specialized service. I will not send two drafts that claim to replace 3316's requirements but differ in their listed requirements, because that is guaranteed to cause confusion for both operators and vendors.

Please change the Abstract and language in the document to recognize that this is a *different* profile than the one for general connection to IPv6 mobile networks. It is by definition for IPv6 services with some kind of qualifier, which must be stated. 

If you can't distinguish this document from 3316bis, its requirements need to be merged into 3316bis.

---

From: <[email-masked]>
Date: Mon, 11 Mar 2013 13:53:05 +0100

Dear Fred,

draft-ietf-v6ops-mobile-device-profile does not say it updates RFC3316. Its scope is clearly mentioned in the abstract and the introduction. 
The document includes a section which positions this draft vs. draft-ietf-v6ops-rfc3316bis (see http://tools.ietf.org/html/draft-ietf-v6ops-mobile-device-profile-00#section-1.1). 

You have already raised the same question and I replied to your message here (Feb 18th) http://www.ietf.org/mail-archive/web/v6ops/current/msg15303.html but I didn't seen a follow up on that discussion. So, I can not guess what you are expecting to see recorded in the document.

As a matter of fact, three intermediate versions of draft-binet-* were submitted and discussed in this list before draft-korhonen-* came out. Even if draft-korhonen-* was never discussed in this list nor a call for adoption is issued in the list, we never complained nor claimed this is not fair with regards to the effort we made to explain why the profile document is needed, to integrate comments from the reviewers, to resubmit a new version without mentioning rfc3316update, etc.

Can you please explicit what changes you want to see added to http://tools.ietf.org/html/draft-ietf-v6ops-mobile-device-profile-00#section-1.1?

Cheers,
Med 

>-----Message d'origine-----
>De : Fred Baker (fred) [mailto:[email-masked]] 
>Envoyé : lundi 11 mars 2013 12:43
>À : [email-masked]
>Cc : v6ops WG; John Brzozowski; joel jaeggli
>Objet : Internet Protocol Version 6 (IPv6) Profile for Mobile Devices
>
>It is correct to say that this is "an IPv6 Profile", in the 
>sense that there may be other profiles. It is incorrect to say 
>that this is the profile required for connecting to "an 
>IPv6-only or dual-stack mobile network", which is to say "for 
>connecting the device to any IPv6 mobile network, whether IPv4 
>or also configured or not". That profile is described in RFC 
>3316 and is being updated in draft-ietf-v6ops-rfc3316bis.
>
>I will send one document to the IESG that updates or replaces 
>RFC 3316, and I am willing to send one document that refers to 
>3316bis and adds additional requirements for some more 
>specialized service. I will not send two drafts that claim to 
>replace 3316's requirements but differ in their listed 
>requirements, because that is guaranteed to cause confusion 
>for both operators and vendors.
>
>Please change the Abstract and language in the document to 
>recognize that this is a *different* profile than the one for 
>general connection to IPv6 mobile networks. It is by 
>definition for IPv6 services with some kind of qualifier, 
>which must be stated. 
>
>If you can't distinguish this document from 3316bis, its 
>requirements need to be merged into 3316bis.