Subject: Re: [v6ops] Review solicitation - draft-jiang-v6ops-semantic-prefix

From: "Liubing (Leo)" <[email-masked]>
Date: Mon, 4 Mar 2013 09:16:59 +0000

Hi, Sheng

Hope it's not too late to catch up this, sorry for the delay.

Generally, I think it is a good idea to encoding semantics in IPv6 address. The 128bit seems could provide us a loose space for doing this. 

Just two general comments:
1. Section 5 "Sharing semantic definition among Semantic Prefix Domains enables more semantic based network operations."
Does "sharing" means an absolute definition across domains, or some mechanisms of semantic mapping between domains, or both available? I think the Inter-Domain semantic operation is an important topic, maybe we need more description on it.

2. Section 9 Gaps
Maybe it's better to have a brief review of operational considerations which are needed to support semantic, before the gap analysis? 
E.g. operational considerations of the addressing plan/allocation, will it bring too much complexity for the operators or not; filtering operations to increase the semantic trust .etc.

Best regards,
Bing

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Sheng Jiang
> Sent: Wednesday, February 27, 2013 11:22 AM
> To: [email-masked]
> Cc: [email-masked]; sunqiong
> Subject: [v6ops] Review solicitation - draft-jiang-v6ops-semantic-prefix
> 
> Hi, all v6ops,
> 
> We have submitted a new version draft-jiang-v6ops-semantic-prefix, "A
> Framework for Semantic IPv6 Prefix and Gap Analysis"
> (http://tools.ietf.org/html/draft-jiang-v6ops-semantic-prefix). It is describes
> a framework that embeds semantics into IPv6 prefixes, so that network
> operators can efficiently manage their network traffic based on these
> explicit semantics.
> 
> This document was once presented in v6ops @ ietf84, Vancouver. There was
> many discussions and interests was expressed. After that, we have rewritten
> the document largely along with two new co-authors from China Telecom
> and Deutsche Telecom.
> 
> The authors believe it is useful work and operators can benefit from such
> network planning/management.
> 
> Please read the draft and comment. Your reviewing is important for us to
> improve the document.
> 
> A companion draft "Use case of IPv6 prefix semantics for operators"
> (http://tools.ietf.org/html/draft-sun-v6ops-semantic-usecase) has also been
> submitted to v6ops WG. It describes more specific use case for
> telecommunication operators.
> 
> Best regards,
> 
> Sheng
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 4 Mar 2013 09:49:30 +0000

Hi, Bing,

Thanks for your review and comments. Replies in lines.

>1. Section 5 "Sharing semantic definition among Semantic Prefix Domains
>enables more semantic based network operations."
>Does "sharing" means an absolute definition across domains, or some
>mechanisms of semantic mapping between domains, or both available? I
>think the Inter-Domain semantic operation is an important topic, maybe we
>need more description on it.

It is not possible to define generic/standard semantics across domains. We have emphasized semantics are only meaningful locally within domain. What we mean by "sharing" is only between two trusted domain. There was some discussion that may be have security concerns and should be limited. We will put more description and discussion in.

>2. Section 9 Gaps
>Maybe it's better to have a brief review of operational considerations which
>are needed to support semantic, before the gap analysis?
>E.g. operational considerations of the addressing plan/allocation, will it bring
>too much complexity for the operators or not; filtering operations to increase
>the semantic trust .etc.

Your suggestion is very valuable. Actually, I guess, we should separate gap analysis to be another independent document. In that document, operational considerations within various application scenarios should be the most important analysis. After then, we can draw the conclusion where gaps are.

Many thanks and best regards,

Sheng